Mail archive
alpine-user

Re: [alpine-user] Makig a custom ISO image

From: Natanael Copa <ncopa_at_alpinelinux.org>
Date: Thu, 15 Sep 2016 12:53:52 +0200

On Wed, 14 Sep 2016 12:33:37 +0200
Matija Papec <matija.papec_at_gmail.com> wrote:

> Hello
> *
> Natanael,
>
> it shows some progress, but ends with same error message,
>
> https://snag.gy/r3F7wP.jpg


The warning message says that the apk index is untrusted. This means that the pubkey is missing in the initramfs.

You need to copy the key (~/.abuild/*.pub) to /etc/apk/keys/ and rebuild the iso.


>
>
> On Wed, Sep 14, 2016 at 12:02 PM,
> **
> Natanael Copa <ncopa_at_alpinelinux.org> wrote:
>
> > On Wed, 14 Sep 2016 12:00:18 +0200
> > Natanael Copa <ncopa_at_alpinelinux.org> wrote:
> >
> > > On Wed, 14 Sep 2016 09:26:44 +0200
> > > Matija Papec <matija.papec_at_gmail.com> wrote:
> > >
> > > > http://stackoverflow.com/questions/39484723/alpine-
> > linux-makig-a-custom-iso-image
> > > >
> > > > Tnx in advance
> > >
> > > In case someone would like to answer on the mailing list, the question
> > is:
> > >
> > >
> > > Tried to build rescue iso by following
> > >
> > > https://wiki.alpinelinux.org/wiki/How_to_make_a_custom_ISO_image
> > >
> > > (used alpine-extended-3.4.3-x86.iso installed onto hdd before that)
> > >
> > > When booting newly created image, it complains immediately after boot
> > prompt. What should I do to create proper ISO image?
> > >
> > > <screenshot with error message: "/sbin/init not found in new root.
> > Launching emergency recovery shell">
> >
> > At the boot prompt, could you please try enter: grsec noquiet
> >
> > I suspect that apk fails to install the needed packages to the /sysroot
> > for some reason.
> >
> > -nc
> >
> >



---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Thu Sep 15 2016 - 12:53:52 GMT