Mail archive
alpine-user

Re: [alpine-user] Re: [alpine-announce] Alpine 3.5.0 released

From: Natanael Copa <ncopa_at_alpinelinux.org>
Date: Fri, 23 Dec 2016 16:12:26 +0100

On Fri, 23 Dec 2016 09:33:44 +0100
Olivier Mauras <olivier_at_mauras.ch> wrote:

> On Fri, 23 Dec 2016 09:14:23 +0100
> Olivier Mauras <olivier_at_mauras.ch> wrote:
>
> > Please be wary that lvm2-2.02.168-r3 included in this release is broken and won't let you use your lvm devices. Especially with LVM root you'd have a broken boot.
> > Any LVM binary will give this relocationg error:
> > # vgs
> > Error relocating /sbin/vgs: dm_report_group_push: symbol not found
> > Error relocating /sbin/vgs: dm_report_group_destroy: symbol not found
> > Error relocating /sbin/vgs: dm_report_group_pop: symbol not found
> > Error relocating /sbin/vgs: dm_report_set_selection: symbol not found
> > Error relocating /sbin/vgs: dm_config_parse_without_dup_node_check: symbol not found
> > Error relocating /sbin/vgs: dm_report_group_create: symbol not found
>
> My bad, not using -a in apk upgrade updates device-mapper-libs without purging old device-mapper package.
> using "apk upgrade -a" fixes the issue.

I'm glad to hear that it was not the lvm package that was broken. thanks for sharing!

-nc


---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Fri Dec 23 2016 - 16:12:26 GMT