Mail archive
alpine-user

Re: [alpine-user] Using qmake-qt5 on alpine

From: Natanael Copa <ncopa_at_alpinelinux.org>
Date: Fri, 4 Aug 2017 16:28:40 +0200

On Fri, 04 Aug 2017 07:11:25 -0400
Kakadu <Kakadu_at_protonmail.ch> wrote:

> Hey,
> We have a build server where my qt5 package doesn't compile. I found a right alpine package [1] but it installs `qmake-qt5` executable nut my package expects it to be just `qmake` (Ubuntu and others have it that way). Should I fix my package somehow to support this location or should I use some system-wide utility to update paths (like update-alternatives on Debian-based distros)?
> [[1] https://pkgs.alpinelinux.org/contents?branch=edge&name=qt5-qtbase-dev&arch=ppc64le&repo=community](https://pkgs.alpinelinux.org/contents?branch=edge&name=qt5-qtbase-dev&arch=ppc64le&repo=community)
>
> Happy hacking,
> Kakadu

Hi,

We currently don't have any update-alternatives feature in Alpine so
you will have to fix your package to support the location.

You can either call qmake-qt5 directly or set
PATH="/usr/lib/qt5/bin:$PATH" so /usr/lib/qt5/bin/qmake is found.

-nc


---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Fri Aug 04 2017 - 16:28:40 GMT