Mail archive
alpine-user

Re: [alpine-user] Alpine Linux is second class member in an IPv6 network

From: Jean-Louis Fuchs <ganwell_at_fangorn.ch>
Date: Thu, 19 Oct 2017 13:24:52 +0200

Hi

On Wed, Oct 18, 2017 at 02:36:38PM +0200, Bernhard Ehlers wrote:
> Hi,
>
> I’m quite frustrated trying to integrate Alpine Linux in an IPv6 network.

There is also a problem with static IPv6 config. Something locks the
IPv6 routing table for 30min (containing the correct routes), but
after 30min the lock goes away, along with the routes. I worked
around this by reseting the routing table, just after the interface is
configured. So the script will stay for 30min and then fix the routing
table, when the lock goes away. (Alpine 3.6)

I haven't reported this because I didn't have time to investigate the
cause or compare to edge. And of course the whole issue is more
complex. The problem has also to do with the fact that although the
default of accept_ra and autoconf are set to 0, the interface comes up
with accept_ra and autoconf set to 1.

$> cat /etc/sysctl.d/01-ipv6.conf
net.ipv6.conf.default.accept_ra = 0
net.ipv6.conf.default.autoconf = 0
net.ipv6.conf.all.accept_ra = 0
net.ipv6.conf.all.autoconf = 0

Again I just worked around it:

iface eth0 inet6 static
        address X
        netmask 64
        gateway X
        pre-up echo 0 > /proc/sys/net/ipv6/conf/eth0/accept_ra
        pre-up echo 0 > /proc/sys/net/ipv6/conf/eth0/autoconf

My guess even though the interface is set to static, some
auto-configuration mechanism is still being started.

Best,
    Jean-Louis




---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Thu Oct 19 2017 - 13:24:52 GMT