Mail archive
alpine-user

[alpine-user] Installing package from later version?

From: Dave Johansen <davejohansen_at_gmail.com>
Date: Tue, 5 Dec 2017 14:43:39 -0700

I'm trying to use the version of chromium from 3.7 in 3.6, but I need to
update freetype for that to work. When running this command:

apk add --upgrade 'freetype>2.8.1' --repository
http://dl-cdn.alpinelinux.org/alpine/v3.7/community

I get this error:

ERROR: unsatisfiable constraints:
  freetype-2.7.1-r1:
    breaks: world[freetype>2.8.1]
    satisfies:
               chromium-61.0.3163.100-r0[so:libfreetype.so.6]
               pango-1.40.5-r0[so:libfreetype.so.6]
               cairo-1.14.8-r0[so:libfreetype.so.6]
               libxft-2.3.2-r1[so:libfreetype.so.6]
               harfbuzz-1.3.4-r1[so:libfreetype.so.6]
               chromium-chromedriver-61.0.3163.100-r0[so:libfreetype.so.6]
               fontconfig-2.12.1-r0[so:libfreetype.so.6]
               mkfontscale-1.0.7-r2[so:libfreetype.so.6]

Is there a way to fix that?

Here's the relevant bug:
https://bugs.alpinelinux.org/issues/8197#change-22179

Thanks,
Dave



---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Tue Dec 05 2017 - 14:43:39 GMT