Mail archive
alpine-user

Re: [alpine-user] Installing package from later version?

From: Dave Johansen <davejohansen_at_gmail.com>
Date: Wed, 10 Jan 2018 12:47:45 -0700

I was able to update to Alpine 3.7. I'm using the Python Docker container
and originally it looked like they might not support 3.7, but they did and
so I was able to switch.
Thanks,
Dave

On Fri, Dec 15, 2017 at 12:13 PM, Jean-Louis Fuchs <ganwell_at_fangorn.ch>
wrote:

> Hi Dave
>
> On Tue, Dec 05, 2017 at 02:43:39PM -0700, Dave Johansen wrote:
>
> It is definitely not recommended, even if you can install a future
> version it might introduce subtle bugs. The best way to do this is:
>
> 1. Clone the aports repository.
> 2. cd to chromium
> 3. abuild -rK
>
> But even that might fail, because packages have been renamed or aren't
> compatible anymore. In that case you have to backport and build even
> more packages. And be aware that chromium is one of these packages
> that takes forever to build.
>
> So in the end upgrading to 3.7 is the recommended way.
>
> Best,
> Jean-Louis
>
> > I'm trying to use the version of chromium from 3.7 in 3.6, but I need to
> > update freetype for that to work. When running this command:
> >
> > apk add --upgrade 'freetype>2.8.1' --repository
> > http://dl-cdn.alpinelinux.org/alpine/v3.7/community
> >
> > I get this error:
> >
> > ERROR: unsatisfiable constraints:
> > freetype-2.7.1-r1:
> > breaks: world[freetype>2.8.1]
> > satisfies:
> > chromium-61.0.3163.100-r0[so:libfreetype.so.6]
> > pango-1.40.5-r0[so:libfreetype.so.6]
> > cairo-1.14.8-r0[so:libfreetype.so.6]
> > libxft-2.3.2-r1[so:libfreetype.so.6]
> > harfbuzz-1.3.4-r1[so:libfreetype.so.6]
> > chromium-chromedriver-61.0.3163.100-r0[so:libfreetype.so.
> 6]
> > fontconfig-2.12.1-r0[so:libfreetype.so.6]
> > mkfontscale-1.0.7-r2[so:libfreetype.so.6]
> >
> > Is there a way to fix that?
> >
> > Here's the relevant bug:
> > https://bugs.alpinelinux.org/issues/8197#change-22179
> >
> > Thanks,
> > Dave
>



---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Wed Jan 10 2018 - 12:47:45 GMT