Mail archive
alpine-user

[alpine-user] Mongo DB Tools

From: Gabor Toth <gabor.toth_at_maximilianeum.de>
Date: Sun, 8 Apr 2018 09:40:57 +0200

Dear All,

I am building a Docker Image from node:8-Alpine, and I am trying to add
not only mongodb but also mongodb-tools (mongorestore, mongodump etc
commands), and apk add mongodb-tools is not working:

libsasl2-dev (missing):
    required by: world[libsasl2-dev]

but I have added libsasl2-dev earlier:


RUN apk update && apk upgrade && \
    apk add \
      bash \
      g++ \
      gcc \
      make \
      boost-system \
      boost \
      mongodb \
      go \
      libsasl2-dev \
      libpcap \
      libpcap-dev \
      mongodb-tools \
      --no-cache && \
    rm -rf /var/cache/apk/*

Can you please let me know how to install mongodb-tools?

Thanks,

Gabor



---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Sun Apr 08 2018 - 09:40:57 UTC