Mail archive
alpine-user

[alpine-user] Trying to install mongodb-3.6.3-r2

From: <bodenhaltung_at_gmail.com>
Date: Mon, 9 Apr 2018 10:37:52 +0200

Hi,

i struggle how to install mongodb-3.6:

alpsrv:~# apk add mongodb_at_edgecommunity=3.6.3-r2
ERROR: unsatisfiable constraints:
  boost-program_options-1.66.0-r0:
    masked in: _at_edge
    satisfies: world[boost-program_options]
mongodb-3.6.3-r2[so:libboost_program_options-mt.so.1.66.0]
  boost-system-1.66.0-r0:
    masked in: _at_edge
    satisfies: mongodb-3.6.3-r2[so:libboost_system-mt.so.1.66.0]
boost-filesystem-1.66.0-r0[so:libboost_system-mt.so.1.66.0]
boost-filesystem-1.66.0-r0[so:libboost_system.so.1.66.0]
  boost-filesystem-1.66.0-r0:
    masked in: _at_edge
    satisfies: mongodb-3.6.3-r2[so:libboost_filesystem-mt.so.1.66.0]
  boost-iostreams-1.66.0-r0:
    masked in: _at_edge
    satisfies: mongodb-3.6.3-r2[so:libboost_iostreams-mt.so.1.66.0]

Or:
alpsrv:~# apk add mongodb_at_edge=3.6.3-r2
ERROR: unsatisfiable constraints:
  yaml-cpp-0.6.2-r0:
    masked in: _at_edgecommunity
    satisfies: world[yaml-cpp] mongodb-3.6.3-r2[so:libyaml-cpp.so.0.6]
  mongodb-3.6.3-r2:
    masked in: _at_edgecommunity
    satisfies: world[mongodb=3.6.3-r2]

My "/etc/apk/repositories":

###
http://mirror.leaseweb.com/alpine/v3.7/main
http://mirror.leaseweb.com/alpine/v3.7/community
_at_edge http://mirror.leaseweb.com/alpine/edge/main
_at_edgecommunity http://mirror.leaseweb.com/alpine/edge/community
_at_testing http://mirror.leaseweb.com/alpine/edge/testing
###

It seems to be are dependencies betweet edge and edgecommunity and there es
now way to resolve that blocker by "mixing" both (i understand why is
mixing not a good idea, but in this case maybe)?

What is the best practise way to install mongodb.3.6?


Thank you for your Help.



---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Mon Apr 09 2018 - 10:37:52 GMT