Mail archive
alpine-user

Re: [alpine-user] Boot process cannot mount filesystem

From: Paul Zillmann <p.zillmann_at_h6g.de>
Date: Fri, 24 Aug 2018 12:12:23 +0200

Hello Steven,

the mounting of /sysroot takes place in the init script located in the
initramfs.
I've worked a bit with the initramfs on 3.6 and 3.7 - but haven't had a
chance to look into 3.8's initramfs.
mdev is used for the discovery of disks. What partition is mounted is
decided via kernel parameters.

Take a look into the init script and search for: ebegin "Mounting root"
A good method to debug this is: you can hit 'exec /bin/busybox sh' to
pull up a shell in the init process.

Good luck,
Paul

Am 24.08.2018 um 04:07 schrieb Steven Nunez:
> Gents,
>
> I'm trying to install and evaluate Alpine 3.8.0 on an old 32bit Mac
> Mini circa 2007. All seems to be working, except that in the boot
> process I receive:
>
> "mounting /dev/sda3 on /sysroot failed: no such file or directory"
>
> At first my search lead me to think that because I installed a 64 bit
> filesystem on that partition, and syslinux does not support it
> <http://www.syslinux.org/wiki/index.php?title=Filesystem#ext>, we were
> seeing this error. Sadly, reverting to a 32 bit ext for (with
> resize2fs -s /dev/sda3) has not effect.
>
> What /is /odd is that once dropped into the emergency shell, I can
> mount the filesystem with 'mount -t ext4 /dev/sda3 /sysroot' and exit,
> and all works just fine. Just out of desperation I tried modifying
> /etc/fstab and a few other mounting related files, all with no effect,
> which leads me to believe this is happening somewhere in step 4 of the
> boot sequence
> <https://wiki.alpinelinux.org/wiki/Alpine_Source_Map_by_boot_sequence>,
> just before things are handed over to openrc.
>
> Does anyone know where exactly this mounting is done? I also checked
> refined (the EFI 'manager' I am using on this Mac) and it correctly
> specifies the UUID for this disk. I've been at this for 3 days and
> have exhausted all the documentation and searching there is; hoping
> some of the experts here can help.
>
> Regards,



---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Fri Aug 24 2018 - 12:12:23 GMT