Mail archive

Re: [alpine-user] Boot process cannot mount filesystem

From: <>
Date: Fri, 24 Aug 2018 15:07:50 +0000

Did you install using the sys option from the official 3.8 iso? Standard or extended? You mentioned efi, do you boot using efi? Is there a built-in efi support on a 07 mac? Have you tried mbr?

Not directly related to the error you're getting, but I tried evaluating 3.8 in a recent version of virtualbox, the iso could never boot using both efi and mbr. 3.7 worked fine however.

On my other machine, 3.8 boots fine with efi only, mbr won't work. I was wondering whether i could have mbr with an older version and have discovered that the most recent alpine which could boot this particular machine with mbr is version 3.5.2.

Bottom line is, i'd try an older version of alpine and go from there. Luckily, flash drives are fast and the iso images are small enough to go through the alpine versions

On 2018 8 24 02:07:24 UTC, Steven Nunez <> wrote:
>I'm trying to install and evaluate Alpine 3.8.0 on an old 32bit Mac
>Mini circa 2007. All seems to be working, except that in the boot
>process I receive:
>"mounting /dev/sda3 on /sysroot failed: no such file or directory"
>At first my search lead me to think that because I installed a 64 bit
>filesystem on that partition, and syslinux does not support it, we were
>seeing this error. Sadly, reverting to a 32 bit ext for (with resize2fs
>-s /dev/sda3) has not effect.
>What is odd is that once dropped into the emergency shell, I can mount
>the filesystem with 'mount -t ext4 /dev/sda3 /sysroot' and exit, and
>all works just fine. Just out of desperation I tried modifying
>/etc/fstab and a few other mounting related files, all with no effect,
>which leads me to believe this is happening somewhere in step 4 of the
>boot sequence, just before things are handed over to openrc.
>Does anyone know where exactly this mounting is done? I also checked
>refined (the EFI 'manager' I am using on this Mac) and it correctly
>specifies the UUID for this disk. I've been at this for 3 days and have
>exhausted all the documentation and searching there is; hoping some of
>the experts here can help.

Received on Fri Aug 24 2018 - 15:07:50 UTC