Mail archive
alpine-user

Re: [alpine-user] Working OS suddenly got "exit due to timeout" after reboot.

From: Magicloud Magiclouds <magicloud.magiclouds_at_gmail.com>
Date: Sat, 6 Oct 2018 20:48:07 +0800

Thanks for the info. I suspected USB. And tried usbdelay=5, did not
help. Then I noticed that, The USB stick was recognized as SDB, and
SDB1 got mounted to /media/sdb1 successfully, which is quite
confusing. It was usbdisk mounted on /media/usb.
On Sat, Oct 6, 2018 at 7:54 PM Natanael Copa <ncopa_at_alpinelinux.org> wrote:
>
> On Sat, 6 Oct 2018 13:46:29 +0800
> Magicloud Magiclouds <magicloud.magiclouds_at_gmail.com> wrote:
>
> > Hi,
> > I am running an Alpinelinux in ramdisk + USB storage way. It worked
> > fine until I rebooted. I am sure I did not update the initfs. But now
> > I got "nlplug-findfs: exit due to timeout". Rebooting did not fix
> > this.
> >
> > Where should I check?
> >
>
> The message means that kernel did not find the USB stick within time.
> Possible reasons is that USB host controller is too slow to initialize,
> that driver to USB storage (or USB host controller) is missing in
> initramfs or that the USB storage is broken.
>
> You can try add a boot option `usbdelay=10` to give it more time. If
> that does not help, then verify that drivers for USB controller is
> included in initramfs image and that the USB storage is not defect.
>
> -nc



-- 
竹密岂妨流水过
山高哪阻野云飞
And for G+, please use magiclouds#gmail.com.
---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Sat Oct 06 2018 - 20:48:07 GMT