Mail archive
alpine-user

Re: [alpine-user] Wacom tablet has stopped working - SOLVED

From: fao_ <finnoleary_at_inventati.org>
Date: Mon, 21 Jan 2019 02:15:10 +0000

Hi,

just for the record and to avoid the problem from xkcd://979
(my thread is one of two threads that comes up when searching
for this problem), I fixed it by doing three things:

1) Downloading the latest source release of input-wacom from here:
    https://github.com/linuxwacom/input-wacom/releases
    and compiling and installing it (details are in the repo's wiki).

2) Downloading the latest source release of xf86-input-wacom from here:
    https://github.com/linuxwacom/xf86-input-wacom/releases
    and compiling and installing it (details are in the repo's wiki).

3) Adding 'wacom' to the end of /etc/modules

4) Rebooting.

Interestingly enough the serial bus error has not gone away, the Xorg
log still shows an I/O error on /dev/ttyS0, but the tablet now works
and there is more information wrt. connecting and disconnecting the
tablet in `dmesg -w`'s output (and the tablet now shows up in
xsetwacom's
output). So to me it looks like it's now bypassing the old method of
communicating.

It is worth noting that the kernel module shipped with Alpine:
wacom_w8001, is actually a driver for communcating with *old* wacom
tablets.

-- 
- fao_
PGP fingerprint: 739B 6C5C 3DE1 33FA
"Too enough is always not much!"
On 2019-01-08 5:36 am, fao_ wrote:
> Hi,
> Today after a few months of disuse, I decided to plug in my wacom 
> tablet.
> The light comes on, and the tablet seems to detect the pen, however the
> cursor does not move. This bug is present when using the USB cable and 
> when
> using the wireless dongle.
> 
> After some digging, it seems that the tablet is detected by the kernel, 
> the
> default udev rules are run, and Xorg attempts to load the driver. 
> However,
> it fails to open the serial console because:
> 
>> (EE) Serial Wacom Tablet WACf004: Error opening /dev/ttyS0 (I/O error)
> 
> Running statserial gives me:
> 
>> $ sudo statserial /dev/ttyS0the only
>> statserial: TIOCMGET failed: I/O error
> 
> (Indeed, I get the same result from all of /dev/ttyS*)
> 
> `dmesg` doesn't seem to have anything particularly interesting in it, 
> but
> I've attached both dmesg and Xorg.0.log in case there's something 
> useful
> there I'm not seeing.
> 
> Removing the `xf86-input-wacom` package and relying on libinput to 
> provide
> access to the tablet, seems to produce the same bug.
> 
> I'm not sure where to go from here, so any advice that you can give 
> will
> probably be useful.
> 
> Thanks in advance.
---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Mon Jan 21 2019 - 02:15:10 UTC