Mail archive
alpine-user

Re: [alpine-user] passwordless wifi,

From: PICCORO McKAY Lenz <mckaygerhard_at_gmail.com>
Date: Wed, 23 Jan 2019 22:21:44 -0400

i made new instalation from zero.. now get those errors:

1) theres no wpa'roam supprot in alpine.. pufff inclusivelly i copy and use
all from debian and does not work...

2) manny issues:

root_at_alpine:/usr/share/doc/wpa_supplicant/examples$ rc-update del
wpa_supplicant default
 * rc-update: service `wpa_supplicant' is not in the runlevel `default'
root_at_alpine:/usr/share/doc/wpa_supplicant/examples$ rc-update del wpa_cli
default
 * rc-update: service `wpa_cli' is not in the runlevel `default'
root_at_alpine:/usr/share/doc/wpa_supplicant/examples$ rc-update add
wpa_supplicant boot
 * service wpa_supplicant added to runlevel boot
root_at_alpine:/usr/share/doc/wpa_supplicant/examples$ rc-update add wpa_cli
boot
 * rc-update: service `wpa_cli' does not exist
root_at_alpine:/usr/share/doc/wpa_supplicant/examples$



Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com


El mié., 16 de ene. de 2019 a la(s) 16:31, PICCORO McKAY Lenz (
mckaygerhard_at_gmail.com) escribió:

>
>
> El mié., 16 de ene. de 2019 a la(s) 15:31, Cosmo Borsky (
> me_at_cosmoborsky.com) escribió:
>
>> Try the following:
>> ```
>> rc-update del wpa_supplicant default
>> rc-update del wpa_cli default
>> rc-update add wpa_supplicant boot
>> rc-update add wpa_cli boot
>> ```
>>
> of course was done.. still get "device not ready" any other idea? my
> direct wired does not have direct connection.. so i cannot play minetest
> and make many things.. only using wifi
>
>
>>
>> On 1/16/19 2:22 PM, PICCORO McKAY Lenz wrote:
>>
>> El mié., 16 de ene. de 2019 a la(s) 15:19, Cosmo Borsky (
>> me_at_cosmoborsky.com) escribió:
>>
>>> Try `cat /etc/group | grep "net\|dial\|wheel"`
>>> It should print out:
>>> ```
>>> wheel:x:10:root,user
>>> dialout:x:20:root,user
>>> netdev:x:28:
>>> ```
>>>
>> user gneral already in those groups
>>
>>
>>
>>> 2) users cannot odo nay thing.. due the firts
>>>
>>> I'm not sure what you mean by this
>>>
>>> 3) cosole now works, but at the xfce4 does not!
>>>
>>> Do you mean X11 does not work?
>>> Does `startx` work?
>>>
>> Please sorrry, i write very bad due in hurry.. ok again:
>>
>> 2) users cannot do any thing, network manager still said: "device its not
>> ready"
>>
>> 3) connection at console works but in some restarts (randomly) said
>> "device are busy"
>>
>> tested in a hp dual core with atheros and also on a classmate minilaptop
>> with rtl device wifi
>>
>>
>>>
>>> Ensure you have the proper video driver installed:
>>> https://wiki.alpinelinux.org/wiki/XFCE_Setup#Video_packages
>>> `xf86-video-nouveau` for nvidia graphics
>>>
>>>
>>>
>>> El mar., 15 de ene. de 2019 a la(s) 14:45, Cosmo Borsky (
>>> me_at_cosmoborsky.com) escribió:
>>>
>>>> Try adding
>>>> `wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf` to `iface wlan0` in
>>>> your `/etc/network/interfaces` file.
>>>> You might have luck changing `wpa-conf` to `wpa-roam`:
>>>> http://manual.aptosid.com/en/inet-setup-en.htm
>>>>
>>>> On 1/14/19 2:00 PM, PICCORO McKAY Lenz wrote:
>>>>
>>>>
>>>> El lun., 14 de ene. de 2019 a la(s) 14:35, Cosmo Borsky (
>>>> me_at_cosmoborsky.com) escribió:
>>>> > Hi Gert,
>>>> > As for passwordless wifi, try setting `key_mgmt=NONE` in your
>>>> wpa_supplicant network entry.
>>>>
>>>> hi, i already do that! does permit scan and there's no connect..
>>>> network manager at desktop said: "device its not ready" and at the console
>>>> if there's no desktop install said "device its busy"
>>>>
>>>> detailed steps here, some important notes, i added group netdev due so
>>>> also networkmananger can manage too using "manager=true" in ifupdown, see
>>>> and tell me what are the bad steps here?
>>>>
>>>> echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6
>>>>
>>>> apk add dhcpcd wireless-tools wpa_supplicant wireless-tools-doc wpa_supplicant-doc
>>>> rc-update add wpa_supplicant
>>>> rc-update add dhcpcd
>>>>
>>>> ip link set wlan0 up
>>>> iwlist wlan0 scanning
>>>> iwconfig wlan0 essid PASSLESSNET
>>>>
>>>> cat > /etc/network/intefaces << EOF
>>>> auto lo
>>>> iface lo inet loopback
>>>>
>>>> auto eth0
>>>> iface eth0 inet dhcp
>>>>
>>>> auto wlan0
>>>> allow-hotplug wlan0
>>>> iface wlan0 inet dhcp
>>>> wireless-essid PASSLESSNET
>>>> EOF
>>>> cat > /etc/wpa_supplicant/wpa_supplicant.conf << EOF
>>>> ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=dialoutnetwork={
>>>> ssid=PASSLESSNET
>>>> key_mgmt=NONE }
>>>> EOF
>>>>
>>>> rc-service wpa_supplicant startrc-service dhcpcd start
>>>>
>>>> cat > /etc/NetworkManager/NetworkManager.conf << EOF
>>>> [main]
>>>> plugins=ifupdown,keyfile
>>>>
>>>> [ifupdown]
>>>> managed=true
>>>>
>>>> EOF
>>>>
>>>> Lenz McKAY Gerardo (PICCORO)
>>>> http://qgqlochekone.blogspot.com
>>>>
>>>>
>>>>
>>>
>>



---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Wed Jan 23 2019 - 22:21:44 UTC