Mail archive
alpine-user

Re: [alpine-user] issues with compiler & crt

From: PICCORO McKAY Lenz <mckaygerhard_at_gmail.com>
Date: Wed, 27 Feb 2019 23:03:10 -0400

seems you dont read and pay attention of my prevously mail.. gcc in alpines
seems support that other olders gcc can be linked with the default
libstdc++ but you try to use older version that need a hard fixed dependency
so you must compile by yourselft then!

El mié., 27 de feb. de 2019 a la(s) 17:24, Riccardo Mottola (
riccardo.mottola_at_libero.it) escribió:

> Currently, my issue is this:
>
> ~# apk add g++6
> ERROR: unsatisfiable constraints:
> libstdc++-8.3.0-r0:
> breaks: g++6-6.4.0-r9[libstdc++=6.4.0-r9]
> satisfies: gcc-8.3.0-r0[so:libstdc++.so.6]
> gcc-8.3.0-r0:
> breaks: g++6-6.4.0-r9[gcc=6.4.0-r9]
>
its not an issue, its a "limitation of the behaviour" in the distro due
alpine assumes that always will be only one compiler

when i try to provide some "made by me" package noted that will need more
time and i not have it so that's why i used debian to those complicated
thins like compile a binary and redistribute! until alpine can support many
things like that (seems not?)

>
>
> I wonder if this is an error my side and it can be solved? or
> essentially the gcc6 package provided is broken.
>
> Riccardo
>



---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Wed Feb 27 2019 - 23:03:10 UTC