Mail archive
alpine-user

Re: [alpine-user] LAMP setup

From: PICCORO McKAY Lenz <mckaygerhard_at_gmail.com>
Date: Mon, 4 Mar 2019 12:32:47 -0430

not! /etc/apache2/conf.d/ are deprecated! a common mistake if you are
not close to system changes respect upstream projects.. another
inheritcs by using windo-like distributions

also there's no need to change ownershiop of the conf file.. system
must own the changes and users only must "use" ... the "apache" user
must not have access to system files, that are a security misctake
inherits from "muti-vendor" sites how to..

2019-03-04 4:08 GMT-04:30, Marco Dickert <marco_at_misterunknown.de>:
> On 2019-03-02 21:14:25, PICCORO McKAY Lenz wrote:
>> ummm sorry but there-s too much differences beetween winbutu to alpine
>>
>> if you apt instal apache phpmyadmin
>> in winbutnu quickly you have inmmediatelly at localhost/phpmyadmin the
>> result
>>
>> in apine not all are like that!
>
> Well, I understand your point, but you choose a very bad example to argue:
>
> $ apk add apache2 php7-apache2 phpmyadmin
> [...]
> * If you use apache2:
> * 1) Change the ownership of the config directory:
> * chown -R apache:apache /etc/phpmyadmin
> * 2) See if you need to modify the apache2 config:
> * /etc/apache2/conf.d/phpmyadmin.conf
> * 3) Restart apache2 when done.
> *
> OK: 524 MiB in 321 packages
> $ chown -R apache:apache /etc/phpmyadmin
> $ /etc/init.d/apache2 restart
>
> This works instantly^^
>
> Cheers,
> Marco
> --
> Marco Dickert
> marco_at_misterunknown.de
> https://misterunknown.de
>


-- 
Lenz McKAY Gerardo (PICCORO)
http://qgqlochekone.blogspot.com
---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Mon Mar 04 2019 - 12:32:47 UTC