Mail archive
alpine-user

[alpine-user] Graphic glitches with video acceleration

From: Genoperno Translucente <fz12345_at_gmail.com>
Date: Thu, 14 Mar 2019 17:00:50 +0100

Yesterday I have installed alpine (extended x86_64) on a key.
I used this guide
https://wiki.alpinelinux.org/wiki/Create_a_Bootable_USB , so the
result must be a "diskless-mode".
After that I started setup-alpine and configured the distro (leaving
the setup-disk on "none", setup-lbu on "usb" and setup-apkcache on
"/media/usb/cache").
I saved the settings with "lbu ci" and found that they were preserved
on restart.
Next thing I know, I tried to follow this other guide to set a wm:
https://wiki.alpinelinux.org/wiki/XFCE_Setup
So I started "setup-xorg-base", enable communy repo and update, and
install xfce4 and xf86-video-intel (pc is a intel atom with integrated
graphic card).
To be sure I have also installed mesa-dri-intel
I did another commit and so I tried to start the wm with "startx".

Xfce is very slow to start (it loads one piece at times and many of
the icons are not seen), but the main problem is that I see artifacts
(such as small disturbances of the graphics) and often I see the
pointer in multiple positions simultaneously and when I move it, the
pointer leaves a track that disappears later.
All these problems disappear when the composite manager of xfce is
deactivated (in setting > tweaks > composite) so I thought it was a
problem with graphics acceleration.

I tried an ubuntu studio live on the same PC with xfce and composite
active without the same problem. The driver used seems to be the same
in both distros (i915.ko).
If I understand correctly, this is the saying with the modules
installed by xorg "/usr/lib/xorg/modules/drivers/".
In alpine there are only 2 modules inside this dir: intel_drv.so
modesetting_drv.so
In ubuntu studio a little more (but i think a lot of this is not
usefull): amdgpu_drv.so fbdev_drv.so modesetting_drv.so qxl_drv.so
vesa_drv.so ati_drv.so intel_drv.so nouveau_drv.so radeon_drv.so
vmware_drv.so

I could not start Xorg -configure from ubuntu studio, but I make one
from alpine: http://dpaste.com/38KBTA1


---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Thu Mar 14 2019 - 17:00:50 UTC