Mail archive
alpine-user

Re: [alpine-user] Graphic glitches with video acceleration

From: Genoperno Translucente <fz12345_at_gmail.com>
Date: Thu, 14 Mar 2019 22:58:00 +0100

Thanks for the answer, you warn me that I see some graphical glitches
also from the shell, so I think you've found the right problem.
Not knowing what this kms is I searched on the net and found this
page: https://wiki.archlinux.org/index.php/kernel_mode_setting#Disabling_modesetting
My syslinux already was set by default the nomodeset, but that page
says that I must also set i915.modeset=0, and so I tried:
http://dpaste.com/0JR7GY4

However, when I run startx with that option setted in the syslinux,
the GUI doesn't even start and Xorg returns this
error:http://dpaste.com/0K6ZDRB (I captured this error having also
removed nomodeset and only with i915.modeset=0 but I have the same
problemi)
Xorg -configure does not even work.



2019-03-14 17:33 GMT+01:00, PICCORO McKAY Lenz <mckaygerhard_at_gmail.com>:
> deactivate the new kms and restart . that0s enought
> Lenz McKAY Gerardo (PICCORO)
> http://qgqlochekone.blogspot.com
>
>
> El jue., 14 de mar. de 2019 a la(s) 12:01, Genoperno Translucente (
> fz12345_at_gmail.com) escribió:
>
>> Yesterday I have installed alpine (extended x86_64) on a key.
>> I used this guide
>> https://wiki.alpinelinux.org/wiki/Create_a_Bootable_USB , so the
>> result must be a "diskless-mode".
>> After that I started setup-alpine and configured the distro (leaving
>> the setup-disk on "none", setup-lbu on "usb" and setup-apkcache on
>> "/media/usb/cache").
>> I saved the settings with "lbu ci" and found that they were preserved
>> on restart.
>> Next thing I know, I tried to follow this other guide to set a wm:
>> https://wiki.alpinelinux.org/wiki/XFCE_Setup
>> So I started "setup-xorg-base", enable communy repo and update, and
>> install xfce4 and xf86-video-intel (pc is a intel atom with integrated
>> graphic card).
>> To be sure I have also installed mesa-dri-intel
>> I did another commit and so I tried to start the wm with "startx".
>>
>> Xfce is very slow to start (it loads one piece at times and many of
>> the icons are not seen), but the main problem is that I see artifacts
>> (such as small disturbances of the graphics) and often I see the
>> pointer in multiple positions simultaneously and when I move it, the
>> pointer leaves a track that disappears later.
>> All these problems disappear when the composite manager of xfce is
>> deactivated (in setting > tweaks > composite) so I thought it was a
>> problem with graphics acceleration.
>>
>> I tried an ubuntu studio live on the same PC with xfce and composite
>> active without the same problem. The driver used seems to be the same
>> in both distros (i915.ko).
>> If I understand correctly, this is the saying with the modules
>> installed by xorg "/usr/lib/xorg/modules/drivers/".
>> In alpine there are only 2 modules inside this dir: intel_drv.so
>> modesetting_drv.so
>> In ubuntu studio a little more (but i think a lot of this is not
>> usefull): amdgpu_drv.so fbdev_drv.so modesetting_drv.so qxl_drv.so
>> vesa_drv.so ati_drv.so intel_drv.so nouveau_drv.so radeon_drv.so
>> vmware_drv.so
>>
>> I could not start Xorg -configure from ubuntu studio, but I make one
>> from alpine: http://dpaste.com/38KBTA1
>>
>>
>> ---
>> Unsubscribe: alpine-user+unsubscribe_at_lists.alpinelinux.org
>> Help: alpine-user+help_at_lists.alpinelinux.org
>> ---
>>
>>
>


---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Thu Mar 14 2019 - 22:58:00 UTC