Mail archive
alpine-user

Re: [alpine-user] Wifi connection problem

From: PICCORO McKAY Lenz <mckaygerhard_at_gmail.com>
Date: Sun, 24 Mar 2019 23:44:01 -0400

El dom., 24 de mar. de 2019 a la(s) 22:46, Genoperno Translucente (
fz12345_at_gmail.com) escribió:

> 1) rc-service start dhcpcd: I reversed the word start and dhcpcd (maybe a
> typo)
>
the document still has many typos, sorry...


> 2) at the end of the file "/etc/wpa_supplicant/wpa_supplicant.conf" i
> add "key_mgmt=WPA-PSK" and "psk="my_password"" because i have a pass
> setted.
>
yeas that's cos my wifi are rogued! have proxy and reverse autentication
also mac filters


> 3) because after I start the service "rc-service wpa_supplicant start"
> anything happen, I try with command "wpa_supplicant -i wlan0 -c
> /etc/wpa_supplicant/wpa_supplicant.conf", but I obtain an endless
> attempt to connection: https://termbin.com/b3oj

same for me.. my partner said "works for me" of course he not have modern
laptops..

alpone seems works good for server and dockers but for wifi and desktop
need many work

this weekend i not work in alpine but next i'll break agains that problem
definitivelly in some way using some geento solutions..

i suspect that the respective involved software parts are not well
integrated..


>
>
>
>
> 2019-03-16 23:23 GMT+01:00, Steffen Nurpmeso <steffen_at_sdaoden.eu>:
> > Genoperno Translucente wrote in <CAB+Gb1EJ3Ai+ts68hEj2HbjGWb-T6BMeVL3L0G\
> > sg_pVOzAEJxw_at_mail.gmail.com>:
> > |I have a problem with a wifi connection, I'm using alpine 3.9.2.
> > |I use the "setup-interfaces" script, enter the network ssid, the
> > |password and then I choose dhcp.
> > |When I restart the networking (/etc/init.d/networking restart), alpine
> > |try to connect unsuccessfully:
> > |...
> > |udhcpc: sending discover
> > |udhcpc failed to get a DHCP lease
> > |udhcpc: no lease, forking to background
> > |
> > |I also tried inserting ip, netmask and gateways manually but it
> > |doesn't work anyway.
> > |
> > |On other PCs the connection works correctly (both in dhcp and manually
> > |mode) and also on the same PC with another live distro.
> > |Instead Alpine have any problem with wifi tethering of my phone (both
> > |manual and with dhcp), so I can't even imagine what kind of problem
> > |that would be.
> >
> > How long did you wait? I am not doing it like you, but DHCP
> > sometimes needs some time to get the address.
> >
> > --steffen
> > |
> > |Der Kragenbaer, The moon bear,
> > |der holt sich munter he cheerfully and one by one
> > |einen nach dem anderen runter wa.ks himself off
> > |(By Robert Gernhardt)
> >
>
>
> ---
> Unsubscribe: alpine-user+unsubscribe_at_lists.alpinelinux.org
> Help: alpine-user+help_at_lists.alpinelinux.org
> ---
>
>



---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Sun Mar 24 2019 - 23:44:01 UTC