Mail archive
alpine-user

[alpine-user] APK hangs on some packages

From: Tristan Kohl <tristan_at_iceity.de>
Date: Wed, 3 Apr 2019 16:14:52 +0200

Hey guys,

I build most of my images on top of Alpine. However for the last couple
of days I come accross some weird problem which causes apk add to hang
for some packages. I tried following Dockerfile on an Alpine 3.9 host
with Docker 18.09.1-ce and my Void Linux desktop with docker 18.09.4.


FROM alpine:latest

RUN apk add --no-cache build-base cmake git linux-headers perl

<snip>



#> docker build -t test .
Sending build context to Docker daemon 2.56kB
Step 1/18 : FROM alpine:latest
 ---> 5cb3aa00f899
Step 2/18 : RUN apk add --no-cache build-base cmake git linux-headers perl
 ---> Running in 9736754a88cc
fetch http://dl-cdn.alpinelinux.org/alpine/v3.9/main/x86_64/APKINDEX.tar.gz
fetch
http://dl-cdn.alpinelinux.org/alpine/v3.9/community/x86_64/APKINDEX.tar.gz
(1/41) Upgrading musl (1.1.20-r3 -> 1.1.20-r4)
(2/41) Installing binutils (2.31.1-r2)
(3/41) Installing libmagic (5.35-r0)
(4/41) Installing file (5.35-r0)
(5/41) Installing gmp (6.1.2-r1)
(6/41) Installing isl (0.18-r0)
(7/41) Installing libgomp (8.2.0-r2)
(8/41) Installing libatomic (8.2.0-r2)
(9/41) Installing libgcc (8.2.0-r2)
(10/41) Installing mpfr3 (3.1.5-r1)
(11/41) Installing mpc1 (1.0.3-r1)
(12/41) Installing libstdc++ (8.2.0-r2)
(13/41) Installing gcc (8.2.0-r2)


Process hangs here (I let it alone for >1h and then killed it), but
running an Alpine instance via

docker run -it --rm alpine

and trying to install those packages manually one by one has worked both
times I tried this (today and on Sunday). However, installing gcc or
build-base did not work (aka. hang) two or three times and only
succedded on consecutive tries. Weirdly enough, calling

apk add g++

pulled in gcc and finished within seconds as I was used to...

So I "think" there is no problem with docker's network setup but I have
no idea of the inner workings so please tell me where to look if you
think this is a docker issue.

Cheers,
Tristan

P.S.: Previous builds ~2 weeks ago worked and there was no docker update
as far as I can remember.


---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Wed Apr 03 2019 - 16:14:52 UTC