Mail archive

[alpine-user] Raspberry Pi Zero can't boot rpi armhf version

From: East <>
Date: Tue, 21 May 2019 01:00:31 +0000

I am starting a new thread here, seeing as my earlier question was answered, (thanks Paul).

Based on [this]( page, I am lead to believe that someone got Alpine working on the Pi Zero W. The Zero W is basically the same as the RPi Zero, with the only difference being the addition of wifi and bluetooth. In that page, it sounded like most of the author's problems had to do with wifi, and the install worked normally otherwise. So, there is the possibility that something changed between 3.9.2 and 3.9.4 that broke the install on RPi Zero.

I have been referencing these three pages:
[1] (linked above)

The installation process is basically the same for the first part: simply create a FAT32 partition (in [1] and [2]) or FAT16 (in [3]) and extract the tar to it.

[1] recommends setting the following in usercfg.txt:

It also has a section: "Create cache folder and add rng-tools packages". I do not believe this section is relevant for this problem.

[2] recommends setting the following in usercfg.txt:

[3] recommends this in usercfg.txt:

With the exception of perhaps "enable_uart", I don't think any of these settings would prevent the Pi Zero from booting.

I have extracted the tar to both FAT32 and FAT16 partitions. I have tried setting the boot and lba flags on the partition in gparted. No matter what I do, the Pi Zero will not boot.

My theory is that this has something to do with the Pi Zero being unable to find the correct kernel. The LED blinks 7 times, pauses, and repeats. From [here]( "7 flashes: kernel.img not found"

I have tried moving "boot/vmlinuz-rpi" up a directory (to what would be the / directory if it were booted instead of mounted on my PC) and renaming it "kernel.img". When I try booting it that way, I get a kernel panic:

"Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)"

This is an improvement, because at least it gives me something other than the rainbow screen (which I enabled in config.txt).

Beyond this, I am not sure what I should do. In theory, the Pi Zero should parse the config.txt file and locate the correct kernel to load that way. I have tried setting "boot_delay=1" to no avail. I have also theorized that it might refuse to boot because I extracted the files from the tar using my regular user, and the Pi won't read config.txt unless it is owned by root. A recursive chgrp/chown has debunked that theory, because even after that it still refuses to boot.

I am going to try moving/renaming initramfs as well as the kernel and see if that changes anything. At the very least, it might be a workaround... but if I do that, it will refuse to boot on RPi 2/3. In my case I don't care, because I only intend to use this on a Zero, but would be unusable as a long term fix.

Received on Tue May 21 2019 - 01:00:31 UTC