Mail archive
alpine-user

Re: [alpine-user] Raspberry Pi Zero can't boot rpi armhf version

From: Paul Zillmann <p.zillmann_at_h6g.de>
Date: Tue, 21 May 2019 15:35:25 +0200

Hello East,

> "Kernel panic - not syncing: VFS: Unable to mount root fs on
> unknown-block(0,0)"
suggest that the kernel doesn't know what rootfs to mount nor has any
modules for that.
An initramfs would be usefull in that situation - at least to get an
emergency shell.
In the config.txt look out for the kernel= line (you could also set it
so your kernel don't have to be on kernel.img).
kernel=path/to/kernel
initramfs path/to/initramfs

The missing = sign is there on purpose!

You could also try ramfsfile= and ramfsaddr= but I've found no memory
address for the Pi Zero W. Some use 0x00a0000, other use 0x00800000,
"followkernel" is also a valid address.

You could also create an cmdline.txt which should contain kernel cmd
paremeters, eg. root=/dev/mmcblk0xyz

Please check out this resource and see if it helps:
https://pi3g.com/2019/01/10/alpine-boot-process-on-the-raspberry-pi/

Here are some boot parameters for the Pi bootloader:
https://www.raspberrypi.org/documentation/configuration/config-txt/boot.md

- Paul

Am 21.05.19 um 03:00 schrieb East:
> I am starting a new thread here, seeing as my earlier question was
> answered, (thanks Paul).
>
> Based on this
> <https://wiki.alpinelinux.org/wiki/Raspberry_Pi_Zero_W_-_Installation>
> page, I am lead to believe that someone got Alpine working on the Pi
> Zero W. The Zero W is basically the same as the RPi Zero, with the
> only difference being the addition of wifi and bluetooth. In that
> page, it sounded like most of the author's problems had to do with
> wifi, and the install worked normally otherwise. So, there is the
> possibility that something changed between 3.9.2 and 3.9.4 that broke
> the install on RPi Zero.
>
> I have been referencing these three pages:
> [1]
> https://wiki.alpinelinux.org/wiki/Raspberry_Pi_Zero_W_-_Installation
> (linked above)
> [2] https://wiki.alpinelinux.org/wiki/Raspberry_Pi
> [3]
> https://wiki.alpinelinux.org/wiki/Classic_install_or_sys_mode_on_Raspberry_Pi
>
> The installation process is basically the same for the first part:
> simply create a FAT32 partition (in [1] and [2]) or FAT16 (in [3]) and
> extract the tar to it.
>
> [1] recommends setting the following in usercfg.txt:
> gpu_mem=16
> dtparam=audio=off
> dtoverlay=pi3-disable-bt
> dtoverlay=w1-gpio
> enable_uart=1
>
> It also has a section: "Create cache folder and add rng-tools
> packages". I do not believe this section is relevant for this problem.
>
> [2] recommends setting the following in usercfg.txt:
> dtparam=audio=on
> disable_overscan=1
>
> [3] recommends this in usercfg.txt:
> enable_uart=1
>
> With the exception of perhaps "enable_uart", I don't think any of
> these settings would prevent the Pi Zero from booting.
>
> I have extracted the tar to both FAT32 and FAT16 partitions. I have
> tried setting the boot and lba flags on the partition in gparted. No
> matter what I do, the Pi Zero will not boot.
>
> My theory is that this has something to do with the Pi Zero being
> unable to find the correct kernel. The LED blinks 7 times, pauses, and
> repeats. From here
> <https://elinux.org/R-Pi_Troubleshooting#Green_LED_blinks_in_a_specific_pattern>:
> "7 flashes: kernel.img not found"
>
> I have tried moving "boot/vmlinuz-rpi" up a directory (to what would
> be the / directory if it were booted instead of mounted on my PC) and
> renaming it "kernel.img". When I try booting it that way, I get a
> kernel panic:
>
> "Kernel panic - not syncing: VFS: Unable to mount root fs on
> unknown-block(0,0)"
>
> This is an improvement, because at least it gives me something other
> than the rainbow screen (which I enabled in config.txt).
>
> Beyond this, I am not sure what I should do. In theory, the Pi Zero
> should parse the config.txt file and locate the correct kernel to load
> that way. I have tried setting "boot_delay=1" to no avail. I have also
> theorized that it might refuse to boot because I extracted the files
> from the tar using my regular user, and the Pi won't read config.txt
> unless it is owned by root. A recursive chgrp/chown has debunked that
> theory, because even after that it still refuses to boot.
>
> I am going to try moving/renaming initramfs as well as the kernel and
> see if that changes anything. At the very least, it might be a
> workaround... but if I do that, it will refuse to boot on RPi 2/3. In
> my case I don't care, because I only intend to use this on a Zero, but
> would be unusable as a long term fix.



---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Tue May 21 2019 - 15:35:25 UTC