Mail archive

[alpine-user] Alpine Linux is second class member in an IPv6 network

From: Bernhard Ehlers <>
Date: Wed, 18 Oct 2017 14:36:38 +0200


I’m quite frustrated trying to integrate Alpine Linux in an IPv6 network.
My requirements should be pretty standard, I want to use auto
configuration (SLAAC) for address assignment and classless DHCPv6
for getting the DNS server IPs and domain name from the router.

While SLAAC is working fine, DHCPv6 is a nightmare in Alpine.
The default DHCP client udhcpc6 is simply not ready for use.
They made some changes in busybox v1.27, so it might work,
but that’s available only in the edge branch. Furthermore the
ifup from busybox doesn’t support the use of DHCPv6 for IPv6.

Then I tried using the ifupdown package together with dhclient.
The first stumbling block is, that ifupdown looks for /sbin/dhclient,
while it is installed in /usr/sbin/dhclient. Adding a symlink solves this.
Next is, that ifupdown calls the ip command with options, it doesn’t
support. So I additionally installed iproute2, that solves that.

But the stateless DHCPv6 still doesn’t work. After some more
debugging (and comparing with a working Debian) I saw that
ifup doesn’t wait for a link-local address before starting the DHCPv6
client. Therefore ifup often fails. That was fixed in ifupdown v0.8,
but Alpine still uses 0.7. So I tagged ifupdown as outdated.

At that point I gave up.



Received on Wed Oct 18 2017 - 14:36:38 UTC