Mail archive
alpine-user

Re: [alpine-user] Can't boot linux-vanilla on armhf

From: Natanael Copa <ncopa_at_alpinelinux.org>
Date: Thu, 3 Jan 2019 14:14:07 +0100

Hi!

On Thu, 3 Jan 2019 12:07:30 +0000 (UTC)
paul gauret <pgauret_at_yahoo.com> wrote:

> I can't boot the Alpine linux kernel on my armhf boards (tested on Cubieboard and OrangePI Plus with similar results).
> Sample u-boot session below, messages stop after "Starting kernel" and board requires a hard reset:
> -----
> => setenv bootargs earlyprintk console=ttyS0,115200 root=/dev/mmcblk0p2 rw rootwait=> env set fdt_high ffffffff=> fatload mmc 0 0x46000000 vmlinuz-vanilla3834368 bytes read in 310 ms (11.8 MiB/s)=> fatload mmc 0 0x49000000 linux-4.19.13-0-vanilla-sun4i-a10-cubieboard.dtb22448 bytes read in 4 ms (5.4 MiB/s)=> bootz 0x46000000 - 0x49000000## Flattened Device Tree blob at 49000000   Booting using the fdt blob at 0x49000000   Using Device Tree in place at 49000000, end 490087af
> Starting kernel ...
> -----
>
> For reference I can boot my custom built mainline kernel using the above commands without any trouble.
> What I've already tried without success:- Use mainline u-boot rather than the Alpine u-boot for cubieboard- boot through extlinux- user older versions of the Alpine vanilla kernel
> Am I doing something wrong here or shall I open a bug? 
> Happy to help with troubleshooting if needed.
>

I'm pretty sure this is a bug. Please create an issue on bugs.alpinelinux.org.
It would also be good if you could share your kenrel config that you know works.

Thanks!

-nc


---
Unsubscribe:  alpine-user+unsubscribe_at_lists.alpinelinux.org
Help:         alpine-user+help_at_lists.alpinelinux.org
---
Received on Thu Jan 03 2019 - 14:14:07 UTC