Subject: [alpine-aports] [PATCH 0/3] Add vmware monitoring support to proxies

From: Kevin Daudt <[email-masked]>
Date: Tue, 5 May 2015 19:44:13 +0000

The first two patches are updating the config files, those could be left
out if it's not desired.

The last patch adds libxml2 support which is required for vmware monitoring
support.

This has been tested to compile and run, but hasn't been actually used.

Kevin Daudt (3):
  main/zabbix: Update zabbix_server.conf
  main/zabbix: Use the actual zabbix_proxy.conf
  main/zabbix: Add libxml2 flag for vmware support

 main/zabbix/APKBUILD           |  17 +-
 main/zabbix/zabbix_proxy.conf  | 708 +++++++++++++++++++++++++++++++----------
 main/zabbix/zabbix_server.conf | 689 +++++++++++++++++++++++++++++++--------
 3 files changed, 1104 insertions(+), 310 deletions(-)

-- 
2.2.1

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Kevin Daudt <[email-masked]>
Date: Wed, 6 May 2015 13:11:08 +0000

This flag is required for vmware monitoring, together with libcurl,
which was already present.

Adds a dependency to libxml2-dev.
---
This patch is built on top of master.

 main/zabbix/APKBUILD | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/main/zabbix/APKBUILD b/main/zabbix/APKBUILD
index df27dc5..defdb35 100644
--- a/main/zabbix/APKBUILD
+++ b/main/zabbix/APKBUILD
@@ -12,7 +12,7 @@ license="GPL"
 depends="fping"
 makedepends="postgresql-dev curl-dev net-snmp-dev
 	sqlite-dev mariadb-dev curl-dev openipmi-dev unixodbc-dev
-	autoconf automake"
+	libxml2-dev autoconf automake"
 install="$pkgname.pre-install"
 pkgusers="zabbix"
 pkggroups="zabbix"
@@ -75,6 +75,7 @@ build() {
 			--enable-ipv6 \
 			--with-net-snmp \
 			--with-libcurl \
+			--with-libxml2 \
 			--with-openipmi \
 			--with-unixodbc \
 			"
-- 
2.4.0

---