Subject: [alpine-aports] [PATCH 3/3] main/zabbix: Add libxml2 flag for vmware support

From: Kevin Daudt <[email-masked]>
Date: Tue, 5 May 2015 19:44:16 +0000

This flag is required for vmware monitoring, together with libcurl,
which was already present.

Adds a dependency to libxml2-dev.
---
 main/zabbix/APKBUILD | 17 +++++++++--------
 1 file changed, 9 insertions(+), 8 deletions(-)

diff --git a/main/zabbix/APKBUILD b/main/zabbix/APKBUILD
index a081968..eda2733 100644
--- a/main/zabbix/APKBUILD
+++ b/main/zabbix/APKBUILD
@@ -3,7 +3,7 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=zabbix
 pkgver=2.4.3
-pkgrel=0
+pkgrel=1
 pkgdesc="Enterprise-class open source distributed monitoring"
 url="http://www.zabbix.com"
 arch="all"
@@ -11,7 +11,7 @@ license="GPL"
 depends="fping"
 makedepends="postgresql-dev curl-dev libiconv-dev net-snmp-dev
 	sqlite-dev mysql-dev curl-dev openipmi-dev unixodbc-dev
-	autoconf automake"
+	libxml2-dev autoconf automake"
 install="$pkgname.pre-install"
 pkgusers="zabbix"
 pkggroups="zabbix"
@@ -74,6 +74,7 @@ build() {
 			--enable-ipv6 \
 			--with-net-snmp \
 			--with-libcurl \
+			--with-libxml2 \
 			--with-openipmi \
 			--with-unixodbc \
 			"
@@ -190,9 +191,9 @@ agent() {
 }
 
 md5sums="e8a0699c4e49999a15c63650a2280600  zabbix-2.4.3.tar.gz
-26b0401a83bdb1dce29338e5b2786620  zabbix_server.conf
+9c4fff4fdffb59771a46cf680f5903ed  zabbix_server.conf
 9832a81e134c8e2c11e2a06b7adbf88f  zabbix_trapper.conf
-0310b92afb3f35c1075fff53db737212  zabbix_proxy.conf
+1788dcfeed84bd3954d4c8433e4e520f  zabbix_proxy.conf
 721c18077fa739f956340afca9f067f4  zabbix_agentd.conf
 3a71e310bd2b38498a7c6830169f7480  zabbix-getloadavg.patch
 bf62c539870874e11de39c60cb974786  automake.patch
@@ -203,9 +204,9 @@ d679ccec92ccc1e7a117b27652e6b856  zabbix-agentd.initd
 a99978139481e69434f78fc3e8c53441  zabbix-proxy.initd
 c3b399a406f7dd1df0de7b3fae3ed081  002-fix-res_send-on-uclibc.patch"
 sha256sums="3791a98cbb7c8906ad37c284a49a8be5f431e18c684bacd37bd32f7b4a492d05  zabbix-2.4.3.tar.gz
-3b09a8fdc38216d859022c5966c36f0bcb6984974208cf4c69c17129649efdf5  zabbix_server.conf
+31ea2d8740d9369697eb976c2cd48392e35400e9bad248328bca27d30112e9b9  zabbix_server.conf
 3ae307895c9a7189e29c4ebf7479ce08d4c3bbe1a7f0a3554828170dac417bab  zabbix_trapper.conf
-0cd9cab17d1a2f791262b683aeedc5115722478a4847cb438aadb51198f67287  zabbix_proxy.conf
+03c4fe07488082dcf4f1f18844a0027fee9bff5f4b03a998e917e621ed84acf0  zabbix_proxy.conf
 98343193215c9e1bc79ff332688c684f7023da38583bba800acc404b12c6cc51  zabbix_agentd.conf
 d2c0651c5fa67a1857707552e79ecece7ca95c149042460c40456634bf7611dc  zabbix-getloadavg.patch
 b347ca77660e69bea353c50e2fce0c7c4cc837f782c9f84f74ba92c1a62b4c1b  automake.patch
@@ -216,9 +217,9 @@ ddf75041fb0afc5b211dd79a934341cc9db4325447ad33a42cbf09bdfb5cad42  zabbix-server.
 60a01c08df054a0c1bcfb71e378544b4c4e489e6a6779d96383387ed34ddc0b0  zabbix-proxy.initd
 c796e9aa371f50155b396da53504375f35f77bd3941440525dcaf92da33dac99  002-fix-res_send-on-uclibc.patch"
 sha512sums="df1713d9d8d21c326f55bd033f105614356a69bbd81a21e80e8d82eb2842435fd9a7291c4f168502feacb38318b47db39f7fe161b956976967c7a68ffcbc49cb  zabbix-2.4.3.tar.gz
-3170d56a61871e6efadf705c19f864fdecf9420c4263f2a1129245b3b55bd730d1ba5a6a26ea866fc7842c86f7745e51ea28878bb9e9267ed9176499cb75e8bb  zabbix_server.conf
+9d9884096807691c65e3d8e624cc3da3ad843b0374fe2d8a0df1ec12b70d2c7bb56f5d09889b5c9ddcd08322f49e8f9b870438187e4e5b2bb9bdebb715774d8c  zabbix_server.conf
 cd08d907838de646f65316950e8c71deae25be1701e0cc22e5fd2f636c21ef2365a537d247277bafb694cae8c5dbd22eb725c1647797ad3e4ac4b3df2084ef07  zabbix_trapper.conf
-a3703641125dda8c13d658ad4e1cf2cde94af01ed953480a37006e354ff58ade4a99b3575e3f095d8639ac9c481be52e25120353d9a4cd2104a68aff4a5596e5  zabbix_proxy.conf
+b4d245408c7c5a9cab4851fa18f2e076b10524709061a867a61fabebe2d14e9867bda72d8c8fed1335aeee0eee8fc855640bc7407284d2c30a15435411ad7146  zabbix_proxy.conf
 8a3298cb98787f89b4cc0faa6168a1ab59860c60bec159ecd341db25c0903e89061b40d2b37df9e2df99e08b71b57089bcb25f352e7edf09fbc1b0bd3f1034f6  zabbix_agentd.conf
 b65c6ba7701d98ae7f6fe2124c1d2b8b8fea3c3cc7ee080bf99f5afff0aaa6a025c2a1f5136b4700b53d1b7609e6185642650d7edd013c554b2af37fddae771c  zabbix-getloadavg.patch
 9bff8966cb8b3f1767bfb1b3f3529bca5c9957f2c8179a40ded3b4e43615ba9fb408aef43092fd119b7df80b042555d05c9780fac3760176b95524aa48252fee  automake.patch
-- 
2.2.1

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Leonardo Arena <[email-masked]>
Date: Wed, 06 May 2015 10:09:14 +0200

>  1 file changed, 9 insertions(+), 8 deletions(-)

Hi,

the previous two patches were applied (I had to fix checksums though).
This doesn't:

Applying: main/zabbix: Add libxml2 flag for vmware support
error: patch failed: main/zabbix/APKBUILD:3
error: main/zabbix/APKBUILD: patch does not apply
Patch failed at 0001 main/zabbix: Add libxml2 flag for vmware support

Could you please resend it against current master?
Thanks!

- leo

---

From: Kevin Daudt <[email-masked]>
Date: Wed, 6 May 2015 10:22:19 +0200

> Could you please resend it against current master?

Sorry forgot to mention. I built it on top of 3.1, would it be possible
to apply it on top of that tree? I can send another patch for master.

Kind regards, Kevin

---

---

From: Leonardo Arena <[email-masked]>
Date: Wed, 06 May 2015 10:41:15 +0200

> to apply it on top of that tree? I can send another patch for master.

Usually we apply patches to master and we backport to stable trees upon
request, if it doesn't break configuration or dependencies.

The current master will become 3.2-stable which is due out soon. Would
that be enough for you?

Thanks!

- leo

---

From: Kevin Daudt <[email-masked]>
Date: Wed, 6 May 2015 11:39:47 +0200

> The current master will become 3.2-stable which is due out soon. Would

I'll provide the patch for master, and then request it to be backported,
as it should not introduce any breaking changes. 

Our production servers are currently tied to 3.1, so it's not easy to
use the 3.2 repositories.

Please let me know what you think.

Kevin.

---

---

From: Leonardo Arena <[email-masked]>
Date: Wed, 06 May 2015 16:35:12 +0200

> Please let me know what you think.

Patch backported:

http://git.alpinelinux.org/cgit/aports/commit/?h=3.1-stable&id=5bb622feba2063f6b018b266abc7654798ce92be

While there I also upgraded to 2.4.5 since there are a number of
bugfixes, including some VMWare related.

Thanks!

---

From: Kevin Daudt <[email-masked]>
Date: Wed, 6 May 2015 19:15:52 +0200

> bugfixes, including some VMWare related.

Thank you too!

---