Subject: [alpine-aports] [PATCH] main/py-twisted: update to 15.1.0

From: Dustin Lacewell <[email-masked]>
Date: Thu, 7 May 2015 21:40:13 -0700

http://twistedmatrix.com/
Asynchronous networking framework written in Python.
---
 main/py-twisted/APKBUILD | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/main/py-twisted/APKBUILD b/main/py-twisted/APKBUILD
index 358c15e..c8b0801 100644
--- a/main/py-twisted/APKBUILD
+++ b/main/py-twisted/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=py-twisted
 _pkgname=Twisted
-pkgver=14.0.0
+pkgver=15.1.0
 pkgrel=0
 pkgdesc="Asynchronous networking framework written in Python."
 url="http://twistedmatrix.com/"
@@ -11,6 +11,7 @@ depends="py-crypto py-zope-interface"
 makedepends="python-dev"
 install=""
 subpackages="$pkgname-doc"
+sourcefile="$_pkgname-$pkgver.tar.bz2"
 source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.bz2"
 
 _builddir="$srcdir"/"$_pkgname"-$pkgver
@@ -30,6 +31,6 @@ package() {
 	done
 }
 
-md5sums="9625c094e0a18da77faa4627b98c9815  Twisted-14.0.0.tar.bz2"
-sha256sums="bdfd961ac2216f5c65b07f2c3a5e5116f6713b8c1cf076c40010c64810d26963  Twisted-14.0.0.tar.bz2"
-sha512sums="657a89603ffb6a0b5b9f41307d2f4400e8fd8947f122f40639b0d87cc769a47a09822c1612206e66bdee2be8b297e53a4271682981cdbeca7d910e57c8582413  Twisted-14.0.0.tar.bz2"
+md5sums="df65e3da0bee81140e7637156802a518  $sourcefile"
+sha256sums="82025d24cee178a7328a0467240bb6b1e7c283a9d85f115a9872dfcbfe20732a  $sourcefile"
+sha512sums="f7a755c7957d85c688db1076409ed1dd61967cf399253961caf584ab5b923d830fe995870bf7da1c9cbd304d98f0dc0a97c91ba92dc41301f652b360e5c5820f  $sourcefile"
-- 
2.4.0

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Carlo Landmeter <[email-masked]>
Date: Fri, 8 May 2015 09:32:25 +0200

> +++ b/main/py-twisted/APKBUILD

What is sourcefile doing here?

>  source="
> http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.bz2
> "
>

---

From: Dustin Lacewell <[email-masked]>
Date: Fri, 8 May 2015 08:43:29 -0700

I saw the value repeated a number of times so I did that as a refactor :3

---

From: Carlo Landmeter <[email-masked]>
Date: Sat, 9 May 2015 09:57:26 +0200

> I saw the value repeated a number of times so I did that as a refactor :3
I commited it and removed it. Thanks.