Subject: [alpine-aports] [PATCH] testing/terminus-font: new aport

From: Andrew Hills <[email-masked]>
Date: Sun, 24 May 2015 11:13:56 -0400

http://sourceforge.net/projects/terminus-font/
Monospace bitmap font (for X11 and console)

This is actually Orion's APKBUILD, with the missing makedepend
"grep" added to allow the build to succeed. Busybox's "grep"
command does not support the regular expression from the package's
micro-configure script on line 42.
---
 testing/terminus-font/APKBUILD                   | 47 ++++++++++++++++++++++++
 testing/terminus-font/terminus-font.post-install |  6 +++
 2 files changed, 53 insertions(+)
 create mode 100644 testing/terminus-font/APKBUILD
 create mode 100644 testing/terminus-font/terminus-font.post-install

diff --git a/testing/terminus-font/APKBUILD b/testing/terminus-font/APKBUILD
new file mode 100644
index 0000000..81bc233
--- /dev/null
+++ b/testing/terminus-font/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Orion <systmkor_at_gmail.com>
+# Maintainer: Orion <systmkor_at_gmail.com>
+# Reference
+#   https://www.archlinux.org/packages/community/any/terminus-font/
+
+pkgname=terminus-font
+pkgver=4.39
+pkgrel=0
+pkgdesc="Monospace bitmap font (for X11 and console)"
+url="http://sourceforge.net/projects/terminus-font/"
+arch="noarch"
+license="GPL2 custom:OFL"
+depends="fontconfig libfontenc font-util"
+depends_dev=""
+makedepends="$depends_dev bdftopcf fontconfig mkfontscale mkfontdir grep"
+install="$pkgname.post-install"
+subpackages=""
+source="http://downloads.sourceforge.net/project/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz"
+
+_builddir=${srcdir}/${pkgname}-${pkgver}
+prepare() {
+   chmod +x ${_builddir}/configure
+}
+
+build() {
+   cd "$_builddir"
+   ./configure --prefix=/usr \
+          --x11dir=/usr/share/fonts/misc \
+          --psfdir=/usr/share/kbd/consolefonts
+   make
+}
+
+package() {
+   cd "$_builddir"
+   make -C ${_builddir} DESTDIR="$pkgdir" install
+   install -Dm644 "${_builddir}/75-yes-terminus.conf" \
+      "$pkgdir/etc/fonts/conf.avail/75-yes-terminus.conf"
+   install -Dm644 "${_builddir}/OFL.TXT" \
+      "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+   install -d "$pkgdir/etc/fonts/conf.d"
+   cd "$pkgdir/etc/fonts/conf.d"
+   ln -s ../conf.avail/75-yes-terminus.conf .
+}
+
+md5sums="1ec1bee67a1c017f349bc8558b2d4fa6  terminus-font-4.39.tar.gz"
+sha256sums="3108383986b365a4b9cc08c31a4195196f6de974d2735d77f6c6efa9feb1f5bf  terminus-font-4.39.tar.gz"
+sha512sums="d2b1c55584eabf423a455ea11d90ba8037b4e5823c677a8c604de1e41c55d829b743db2d1932cd755064db681fcd0b5be8484439ddde4394955d0af5174ff591  terminus-font-4.39.tar.gz"
diff --git a/testing/terminus-font/terminus-font.post-install b/testing/terminus-font/terminus-font.post-install
new file mode 100644
index 0000000..428369f
--- /dev/null
+++ b/testing/terminus-font/terminus-font.post-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+# add something which happends after install
+
+fc-cache -s
+mkfontscale usr/share/fonts/misc
+mkfontdir usr/share/fonts/misc
-- 
2.4.1

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 4 Jun 2015 10:01:54 +0200

On Sun, 24 May 2015 11:13:56 -0400

> micro-configure script on line 42.

Thanks for this patch.

I think it needs a bit more cleanup. Please see comments below.

...
> +depends="fontconfig libfontenc font-util"

Are those actually needed to use the font at runtime? is not a font just static data?

...

> +++ b/testing/terminus-font/terminus-font.post-install

We have a trigger to do the fc-cache. I think the post-install can simply be removed.

-nc

---