Subject: [alpine-aports] [PATCH 1/2] main/xorg-xserver: remove duplicate configure flag

From: Andrew Hills <[email-masked]>
Date: Sun, 24 May 2015 15:57:46 -0400

---
 main/xorg-server/APKBUILD | 1 -
 1 file changed, 1 deletion(-)

diff --git a/main/xorg-server/APKBUILD b/main/xorg-server/APKBUILD
index 9d86472..61fb471 100644
--- a/main/xorg-server/APKBUILD
+++ b/main/xorg-server/APKBUILD
@@ -135,7 +135,6 @@ build() {
 		--disable-config-hal \
 		--disable-dmx \
 		--disable-tslib \
-		--enable-config-udev \
 		|| return 1
 
 	make || return 1
-- 
2.4.1

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Andrew Hills <[email-masked]>
Date: Sun, 24 May 2015 15:57:47 -0400

---
 main/xorg-server/APKBUILD | 2 ++
 1 file changed, 2 insertions(+)

diff --git a/main/xorg-server/APKBUILD b/main/xorg-server/APKBUILD
index 61fb471..9899f0e 100644
--- a/main/xorg-server/APKBUILD
+++ b/main/xorg-server/APKBUILD
@@ -116,6 +116,7 @@ build() {
 		--with-default-font-path=${_fontroot}/misc,${_fontroot}/100dpi:unscaled,${_fontroot}/75dpi:unscaled,${_fontroot}/TTF,${_fontroot}/Type1 \
 		--with-xkb-path=/usr/share/X11/xkb \
 		--with-xkb-output=/var/lib/xkb \
+        --without-systemd-daemon \
 		--enable-aiglx \
 		--enable-composite \
 		--enable-config-udev \
@@ -135,6 +136,7 @@ build() {
 		--disable-config-hal \
 		--disable-dmx \
 		--disable-tslib \
+        --disable-systemd-logind \
 		|| return 1
 
 	make || return 1
-- 
2.4.1

---

---

From: Bartłomiej Piotrowski <[email-masked]>
Date: Sun, 24 May 2015 22:12:55 +0200

On Sun, 24 May 2015 15:57:47 -0400
Andrew Hills <[email-masked]> wrote:
>  		--with-default-font-path=${_fontroot}/misc,${_fontroot}/100dpi:unscaled,${_fontroot}/75dpi:unscaled,${_fontroot}/TTF,${_fontroot}/Type1
> \ --with-xkb-path=/usr/share/X11/xkb \

You either have used tabs or spaces for indentation, when APKBUILD has
the opposite one. Could you update your patch to reflect that?

Cheers,
Bartłomiej