Subject: [alpine-aports] [PATCH] main/git: don't fetch source from the github mirror

From: Sören Tempel <[email-masked]>
Date: Fri, 7 Aug 2015 20:36:16 +0200

---
 main/git/APKBUILD | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/main/git/APKBUILD b/main/git/APKBUILD
index eed4f4f..41dfa94 100644
--- a/main/git/APKBUILD
+++ b/main/git/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=git
 pkgver=2.5.0
-pkgrel=0
+pkgrel=1
 pkgdesc="A distributed version control system"
 url="https://www.git-scm.com/"
 arch="all"
@@ -30,7 +30,7 @@ subpackages="$pkgname-doc
 # we need tcl and tk to be built before git due to git-gui and gitk
 makedepends="zlib-dev openssl-dev curl-dev expat-dev perl-dev python-dev
 	pcre-dev asciidoc xmlto perl-error tcl tk"
-source="git-$pkgver.tar.gz::https://github.com/git/git/archive/v$pkgver.tar.gz
+source="git-$pkgver.tar.xz::https://www.kernel.org/pub/software/scm/git/git-$pkgver.tar.xz
 	bb-tar.patch
 	git-daemon.initd
 	git-daemon.confd
@@ -233,15 +233,15 @@ _git_perl() {
 }

-md5sums="027152d303b4b93e6bd4168d451b2f03  git-2.5.0.tar.gz
+md5sums="f108b475a0aa30e9587be4295ab0bb09  git-2.5.0.tar.xz
 e63a201556c4f089de790805c09a2e5b  bb-tar.patch
 75b9d8f33fbec38a8e0e06baf5165b19  git-daemon.initd
 2258e95d389ccc6de0b5111d53d9eed6  git-daemon.confd"
-sha256sums="31ebd4f35b5b941a5ac51c01ecb211911650b834a4085878e854cce59a470424  git-2.5.0.tar.gz
+sha256sums="cc59b1bac6c1c67a9159872863f6c5bbe0d9404cac2a85c3e9d9fa49923ce45c  git-2.5.0.tar.xz
 cb6319f47d81605e199771350154cbed0a6e85ef9042a689f2b405c64039f49c  bb-tar.patch
 7918837f77b4cebce70b600b2f6da00e4c0df6b946f4ff5671c797c37b2ffc4f  git-daemon.initd
 aaa80bd059db549dadf4c4e27a9aa41a4b5def844f8e563c493bc8513dcd981e  git-daemon.confd"
-sha512sums="f8a0b491af0ac044764852c032e880804cdf334fa7f53be56796b149c8463d723a388998b401f50dd347f9a5151eca36e6b077c1911ef2a1623c245270d46d66  git-2.5.0.tar.gz
+sha512sums="ef7538c9f5ba5b2ac08962401c30e5fd51323b54b9fb5315d259adccec346e8fae9362815832dc2b5ce63a259b315c40e419bb2385dde04d84b992e62f6789b6  git-2.5.0.tar.xz
 6fa088a753c2a697e8dbef2032ed63e8c2a0553a41cff2fcff893c2f35c51d2c697054cc921c23ee606f77b93d0f340df85220b15e1c470bd352f7fba3986cd0  bb-tar.patch
 1e707250d133d56100f0311e7c2610920d6d81809c425ebf3e6acb4a289b958707a90dc38e1c17720da6dc2758dd84bf957fe6aed3854eacea79226eb616e885  git-daemon.initd
 9640f8078d68ed2678e5249da3f946fc21f50e858b94127a4221de73c6132101afcd46bc1fe33861e9a7f731c0dc9591915b8ebf376b8e690cd7135703966509  git-daemon.confd"
-- 
2.5.0

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Francesco Colista <[email-masked]>
Date: Mon, 10 Aug 2015 08:57:42 +0200

>  1 file changed, 5 insertions(+), 5 deletions(-)

Hello, thanks for your patch.
sadly, does not not apply:

Applying patch #367 using 'git am'
Description: [alpine-aports] main/git: don't fetch source from the 
github mirror
Applying: main/git: don't fetch source from the github mirror
error: patch failed: main/git/APKBUILD:2
error: main/git/APKBUILD: patch does not apply
Patch failed at 0001 main/git: don't fetch source from the github mirror
The copy of the patch that failed is found in:
    /home/fcolista/aports/.git/rebase-apply/patch
When you have resolved this problem, run "git am --continue".
If you prefer to skip this patch, run "git am --skip" instead.
To restore the original branch and stop patching, run "git am --abort".

Would you mind to send it with git format-patch?
Thanks.

-- 
:: Francesco Colista
:: Alpine Linux Infrstraucture
:: http://www.alpinelinux.org

---

---

From: Sören Tempel <[email-masked]>
Date: Mon, 10 Aug 2015 19:21:06 +0200

fixes #4292
---
 main/mksh/APKBUILD           | 10 +++++-----
 main/mksh/mksh.post-install  |  2 +-
 main/mksh/mksh.pre-deinstall |  2 +-
 3 files changed, 7 insertions(+), 7 deletions(-)

diff --git a/main/mksh/APKBUILD b/main/mksh/APKBUILD
index a1d7906..4902d2a 100644
--- a/main/mksh/APKBUILD
+++ b/main/mksh/APKBUILD
@@ -2,7 +2,7 @@
 pkgname=mksh
 pkgver=51
 _pkgver=R$pkgver
-pkgrel=0
+pkgrel=1
 pkgdesc="MirBSD KSH Shell"
 url="http://mirbsd.de/mksh"
 arch="all"
@@ -10,7 +10,7 @@ license="BSD"
 depends=""
 depends_dev=""
 makedepends=""
-install="mksh.post-install mksh.post-upgrade mksh.pre-deinstall"
+install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
 subpackages="$pkgname-doc"
 source="https://www.mirbsd.org/MirOS/dist/mir/mksh/$pkgname-$_pkgver.tgz"
 
@@ -22,9 +22,9 @@ build() {
 
 package() {
 	cd "$_builddir"
-	install -D -m 755 mksh "$pkgdir"/usr/bin/mksh
-	install -D -m 644 mksh.1 "$pkgdir"/usr/share/man/man1/mksh.1
-	install -D -m 644 dot.mkshrc "$pkgdir"/usr/share/doc/mksh/dot.mkshrc
+	install -Dm755 mksh "$pkgdir"/bin/mksh
+	install -Dm644 mksh.1 "$pkgdir"/usr/share/man/man1/mksh.1
+	install -Dm644 dot.mkshrc "$pkgdir"/usr/share/doc/mksh/dot.mkshrc
 }
 
 md5sums="8e522475da795c60f35a6f8035481baf  mksh-R51.tgz"
diff --git a/main/mksh/mksh.post-install b/main/mksh/mksh.post-install
index 7722392..5ba1f2f 100644
--- a/main/mksh/mksh.post-install
+++ b/main/mksh/mksh.post-install
@@ -1,3 +1,3 @@
 #!/bin/sh
-add-shell '/usr/bin/mksh'
+add-shell '/bin/mksh'
 exit 0
diff --git a/main/mksh/mksh.pre-deinstall b/main/mksh/mksh.pre-deinstall
index cc4e954..82e6d3b 100644
--- a/main/mksh/mksh.pre-deinstall
+++ b/main/mksh/mksh.pre-deinstall
@@ -1,3 +1,3 @@
 #!/bin/sh
-remove-shell '/usr/bin/mksh'
+remove-shell '/bin/mksh'
 exit 0
-- 
2.5.0

---

---

From: Francesco Colista <[email-masked]>
Date: Wed, 12 Aug 2015 14:20:30 +0200

>  3 files changed, 7 insertions(+), 7 deletions(-)

Hi Soren.
Care to rebase the patch?
This does not applied because of a previous-applied 
http://patchwork.alpinelinux.org/patch/391/
Thanks.

---

---

From: Sören Tempel <[email-masked]>
Date: Mon, 10 Aug 2015 19:26:35 +0200

---

index 24b8e67..ba22667 100644
 url="http://git.or.cz/"

---