Subject: [alpine-aports] [PATCH] testing/chicken: create -dev and -libs subpackage

From: Sören Tempel <[email-masked]>
Date: Mon, 14 Sep 2015 16:00:02 +0200

---
 testing/chicken/APKBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/testing/chicken/APKBUILD b/testing/chicken/APKBUILD
index bfbd7ce..b4fcaaa 100644
--- a/testing/chicken/APKBUILD
+++ b/testing/chicken/APKBUILD
@@ -2,16 +2,16 @@
 # Maintainer: Sören Tempel <[email-masked]>
 pkgname=chicken
 pkgver=4.10.0
-pkgrel=0
+pkgrel=1
 pkgdesc="R5RS and R7RS compatible scheme compiler and interpreter"
 url="http://call-cc.org/"
 arch="all"
 license="custom"
-depends="gcc libc-dev"
+depends="gcc libc-dev $pkgname-dev $pkgname-libs"
 depends_dev=""
 makedepends="$depends_dev"
 install=""
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-libs $pkgname-dev"
 source="http://code.call-cc.org/releases/$pkgver/$pkgname-$pkgver.tar.gz"
 
 _builddir="$srcdir"/$pkgname-$pkgver
-- 
2.5.2

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 15 Sep 2015 10:48:17 +0200

On Mon, 14 Sep 2015 16:00:02 +0200

>  1 file changed, 3 insertions(+), 3 deletions(-)

I applied this, but it is painfully slow to build. Is it possible to
fix/hack the Makefile so it does not need the -j1 option?

Sometimes it is only one of many subdirs that needs to be built first
or that needs be built without parallelism. Then it can be worked
around with something like:

  make -j1 -C lib && make

-nc

---

---

From: Sören Tempel <[email-masked]>
Date: Tue, 15 Sep 2015 13:10:13 +0200

> fix/hack the Makefile so it does not need the -j1 option?

It's painfully slow because it bootstrap a chicken compiler toolchain.
Of cause it could be speeded up by enabling parallel build. There is
actually an upstream bug[1] mentioning this issue and gentoo has a
patch[2] which enables parallel build in their source tree, the patch
works with chicken 4.8 but I suppose I could adjust it for 4.10. I just
didn't know that build time is a big issue.

[1]: http://bugs.call-cc.org/ticket/526
[2]: https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-scheme/chicken/files/chicken-4.8.0.3-parallel-build.patch

Sören.

---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 15 Sep 2015 15:40:16 +0200

On Tue, 15 Sep 2015 13:10:13 +0200

> didn't know that build time is a big issue.

Its not a big issue, just annoying that 23 cores of 24 are idle.

> [2]: https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-scheme/chicken/files/chicken-4.8.0.3-parallel-build.patch

The gentoo patch does not look too complicated. Maybe have a look at
rebasing that next time we need to touch it.

thanks!

-nc

---