Subject: [alpine-aports] [PATCH] main/freeswitch: Add more modules, and remove deprecated modules

From: "L. Tosser" <[email-masked]>
Date: Tue, 19 Jan 2016 14:09:48 +0000

* Add modules applications/mod_esl applications/mod_spy
* Remove codecs/mod_vp8 (and replace it in the list with the good one: #codecs/mod_vpx)
* Remove codecs/mod_speex (deprecated)
---
 main/freeswitch/APKBUILD     | 6 +++---
 main/freeswitch/modules.conf | 8 ++++----
 2 files changed, 7 insertions(+), 7 deletions(-)

diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index cf2efeb..1f8940f 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -204,18 +204,18 @@ conf() {
 md5sums="9a2383a7f321ab0f8fb1e7a212081a17  freeswitch-1.6.6.tar.xz
 1c08df4cf4ef737e6cc6945f9462f08e  0002-FS-verto-bswap_64.patch
 1e7f335ee00f589825ecc9affa779346  getlib.patch
-45bbdea4215ebcd6dbeb3ae6540a14dc  modules.conf
+21f5bf8e4a41bb8c6cc95aae6e2bfaa4  modules.conf
 c608cca8ad773acebf201f581438c7e7  freeswitch.confd
 3b0bf4847a61afa28229b58763f4c400  freeswitch.initd"
 sha256sums="397b9c63c2c1f7008a2cc269f2e0e9a935d862b3fb074a6044819bcaea02ebc0  freeswitch-1.6.6.tar.xz
 2685eb17fcd4510e46bb1d88be5550c3cb7b08f2acccfb41b2c680480c91b63e  0002-FS-verto-bswap_64.patch
 ab437c92149b6fc88bc2fc8a228d6a5f8af574e2c90469a6dc4c753d13972c34  getlib.patch
-5e4fa321a85650b446d54e33926ebea4fd76a6816f51612793cf9c14616c823b  modules.conf
+a5fbbaf4c929466a93a3394351bfe4e6b5cd89555d4c03e78c40febe379559a2  modules.conf
 846a29a361ef6eecd77876963b5c0133699c40fa8b34c68df42d5f8a1a1915b1  freeswitch.confd
 aa0d89221ffa47eba4a0e085f6041ee198476409dd15d1e90c5c357ba683f432  freeswitch.initd"
 sha512sums="1e16904084f8ada7cfea27ed3222eb660a14f08b12e6b4ddc5db2893b690936bf4d945b94d9f6eb1893e62124858c39b658c5c5ac425ad064db69d44f57179a9  freeswitch-1.6.6.tar.xz
 5f93150e1acd632df98bc3bed5613fb1e45180ae4096dcfee5c060da213c8355339260eaf5758cd77c785f6d84cf0661650a872ec574b586ab19803d4f6955f8  0002-FS-verto-bswap_64.patch
 4ceb48f64d2bc26a02cc0846276506241bfd30c156422b0a1d608fd172c099feb5c121a763652e9a45046dcdd0ba0eb71eab240e0c6ce2ad63ff781719e135a4  getlib.patch
-66921b330ace8fc330b1f58c0272325861f0a7bcb3a0f184b534da624beb7ef771065571b58866dd8a5891f1d1f4d12898beb378582b57e425bad65d11d2f281  modules.conf
+2c7574ef3c317ac8d1b3872a9d4234c6b5264cae281c997aa332822d7b87626b31e1ab27cdda3d47a6ac6fb5db4cfb38ced1bb5e7886cbc9993a2b7ec5990c0b  modules.conf
 a585f6411185a26206137a1ad97a06fd6c73e80c5439e9be45eabfa70e7a83120169ba882971fcd328436c8e0242cbd664170b80754ea2846021689baf1f1595  freeswitch.confd
 643d0a2e43f5d3bf3b99fcb6f6422302cb4b74a95eccf844eafb100b15aa9856b4ff41f112d6637255c2e9e2bec9fedc9a9215dfff214dfb83b52eae16b71dca  freeswitch.initd"
diff --git a/main/freeswitch/modules.conf b/main/freeswitch/modules.conf
index bb6c89c..6d052a2 100644
--- a/main/freeswitch/modules.conf
+++ b/main/freeswitch/modules.conf
@@ -14,7 +14,7 @@ applications/mod_dptools
 #applications/mod_easyroute
 applications/mod_enum
 applications/mod_esf
-#applications/mod_esl
+applications/mod_esl
 applications/mod_expr
 applications/mod_fifo
 #applications/mod_fsk
@@ -36,7 +36,7 @@ applications/mod_sms
 #applications/mod_snom
 #applications/mod_soundtouch
 applications/mod_spandsp
-#applications/mod_spy
+applications/mod_spy
 #applications/mod_stress
 applications/mod_valet_parking
 #applications/mod_vmd
@@ -58,14 +58,13 @@ codecs/mod_amr
 codecs/mod_g723_1
 codecs/mod_g729
 codecs/mod_h26x
-codecs/mod_vp8
+#codecs/mod_vpx
 codecs/mod_ilbc
 #codecs/mod_isac
 #codecs/mod_opus
 codecs/mod_sangoma_codec
 #codecs/mod_silk
 #codecs/mod_siren
-codecs/mod_speex
 dialplans/mod_dialplan_asterisk
 #dialplans/mod_dialplan_directory
 dialplans/mod_dialplan_xml
@@ -97,6 +96,7 @@ event_handlers/mod_event_socket
 event_handlers/mod_snmp
 formats/mod_local_stream
 formats/mod_native_file
+formats/mod_png
 #formats/mod_portaudio_stream
 formats/mod_shell_stream
 formats/mod_shout
-- 
2.6.4

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Timo Teras <[email-masked]>
Date: Wed, 20 Jan 2016 12:00:00 +0200

On Tue, 19 Jan 2016 14:09:48 +0000

> * Remove codecs/mod_vp8 (and replace it in the list with the good

Why the replacement is commented out? mod_vpx is not built then if
understood correctly.

> * Remove codecs/mod_speex (deprecated)

It is obsoleted by opus, but still relatively widely used to my
understanding. I'd rather not remove it yet. Or is some other module
implementing speex codec too?

> 643d0a2e43f5d3bf3b99fcb6f6422302cb4b74a95eccf844eafb100b15aa9856b4ff41f112d6637255c2e9e2bec9fedc9a9215dfff214dfb83b52eae16b71dca
> freeswitch.initd" diff --git a/main/freeswitch/modules.conf
> b/main/freeswitch/modules.conf index bb6c89c..6d052a2 100644 ---
> a/main/freeswitch/modules.conf +++ b/main/freeswitch/modules.conf @@
> -14,7 +14,7 @@ applications/mod_dptools #applications/mod_easyroute
> applications/mod_enum applications/mod_esf -#applications/mod_esl
> +applications/mod_esl applications/mod_expr applications/mod_fifo
> #applications/mod_fsk @@ -36,7 +36,7 @@ applications/mod_sms
> #applications/mod_snom #applications/mod_soundtouch
> applications/mod_spandsp -#applications/mod_spy +applications/mod_spy
> #applications/mod_stress applications/mod_valet_parking
> #applications/mod_vmd @@ -58,14 +58,13 @@ codecs/mod_amr
> codecs/mod_g723_1 codecs/mod_g729
>  codecs/mod_h26x
> -codecs/mod_vp8
> +#codecs/mod_vpx
>  codecs/mod_ilbc
>  #codecs/mod_isac
>  #codecs/mod_opus
>  codecs/mod_sangoma_codec
>  #codecs/mod_silk
>  #codecs/mod_siren
> -codecs/mod_speex

---

---

From: Loïc Tosser <[email-masked]>
Date: Wed, 20 Jan 2016 15:10:43 +0400

mod vpx is not built for the moment, because I need to find a good way to
patch it.

In every case mod_vp8 doesn't exists anymore, and mod speex too

╭─*loic@Loics-MacBook-Pro* * ~/Aswat/freeswitch-1.6.6/src/mod/codecs*

╰─*$* pwd

/Users/loic/Aswat/freeswitch-1.6.6/src/mod/codecs

╭─*loic@Loics-MacBook-Pro* * ~/Aswat/freeswitch-1.6.6/src/mod/codecs*

╰─*$* ls

*mod_amr*           *mod_bv*            *mod_dahdi_codec*   *mod_h26x*
    *mod_mp4v*          *mod_sangoma_codec* *mod_skel_codec*    *mod_yuv*

*mod_amrwb*         *mod_codec2*        *mod_g723_1*        *mod_ilbc*
    *mod_openh264*      *mod_silk*          *mod_theora*

*mod_b64*           *mod_com_g729*      *mod_g729*          *mod_isac*
    *mod_opus*          *mod_siren*         *mod_vpx*

╭─*loic@Loics-MacBook-Pro* * ~/Aswat/freeswitch-1.6.6/src/mod/codecs*

╰─*$* cat ../../../modules.conf| grep speex

╭─*loic@Loics-MacBook-Pro* * ~/Aswat/freeswitch-1.6.6/src/mod/codecs*

╰─*$* cat ../../../modules.conf| grep vp8

Regards

-- 
*Loïc Tosser*
CTO
[email-masked] | Skype: loic.aswat

UAE Tech Support 24/7 : 00971 44 252 754 <//0097144252754>
FR Tech Support 24/7 : 0033 1 79 99 99 42 <//0033179999942>
USA Tech Support 24/7 : 00 1 8666 97 99 30 <//0018666979930>