Subject: [alpine-aports] [PATCH] testing/php7: Enabled session by default

From: Fabio da Silva Ribeiro <[email-masked]>
Date: Sat, 19 Mar 2016 01:52:45 -0300

---
 testing/php7/APKBUILD | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/testing/php7/APKBUILD b/testing/php7/APKBUILD
index 8a56b5d..44c7314 100644
--- a/testing/php7/APKBUILD
+++ b/testing/php7/APKBUILD
@@ -58,7 +58,6 @@ subpackages="$pkgname-dev $pkgname-doc
 	$pkgname-posix
 	$pkgname-pspell
 	$pkgname-readline
-	$pkgname-session
 	$pkgname-shmop
 	$pkgname-snmp
 	$pkgname-soap
@@ -161,7 +160,7 @@ _build() {
 		--enable-posix=shared \
 		--enable-phar=shared \
 		--with-pspell=shared \
-		--enable-session=shared \
+		--enable-session \
 		--enable-shmop=shared \
 		--with-snmp=shared \
 		--enable-soap=shared \
@@ -379,7 +378,6 @@ phar()		{
 posix()		{ _mv_ext posix; }
 pspell()	{ _mv_ext pspell; }
 readline()	{ _mv_ext readline; }
-session()	{ _mv_ext session; }
 shmop()		{ _mv_ext shmop; }
 snmp()		{ _mv_ext snmp; }
 soap()		{ _mv_ext soap $pkgname-xml; }
-- 
2.1.4

-- 
***

Esta mensagem, incluindo seus anexos, pode conter informações confidenciais 
e/ou privilegiadas. Se você não for a pessoa autorizada a receber esta 
mensagem, não pode usar, copiar ou divulgar as informações nela contidas ou 
tomar qualquer ação baseada nessas informações. Caso esta mensagem tenha 
sido recebida por engano, por favor avise imediatamente o remetente, 
respondendo o e-mail e em seguida elimine-a do seu sistema. Agradecemos sua 
cooperação.

This message, including any attachments, may contain confidential and/or 
privileged information. If you are not the addressee or authorized to 
receive this for the addressee, you must not use, copy, disclose or take 
any action based on this message or any information herein. If you have 
received this message in error, please advise the sender immediately by 
reply e-mail and delete this message.Thank you for your cooperation

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Valery Kartel <[email-masked]>
Date: Thu, 24 Mar 2016 15:44:45 +0200

Hi Fabio,

What the reason to compile session support into main binary not as shared?

Just install php7-session extension to enable it (apk add php7-session)

---

From: Fabio da Silva Ribeiro <[email-masked]>
Date: Thu, 24 Mar 2016 12:59:54 -0300

Well, I tried to compile Redis and Memcached with session shared, but is
not possible, because the libraries not found the session register.

-- 
***

---

From: Valery Kartel <[email-masked]>
Date: Thu, 24 Mar 2016 18:20:41 +0200

Just reproduced it with your php7-memcached build.

php7 really won't start with an error: PHP Warning:  PHP Startup: Unable to
load dynamic library '/usr/lib/php7/modules/memcached.so' - Error
relocating /usr/lib/php7/modules/memcached.so: php_session_create_id:
symbol not found in Unknown on line 0

But when I renamed /etc/php7/conf.d/session.ini to
/etc/php7/conf.d/00_session.ini, php7 starts well.
So it's a problem with extension load order.

I'll make a patch to rename all ini files for bundled extensions from
<extname>.ini to 00_<extname>.ini
And you may need to add php7-session as dependency for memcached and redis
extensions...

2016-03-24 17:59 GMT+02:00 Fabio da Silva Ribeiro <
[email-masked]>:

> Esta mensagem, incluindo seus anexos, pode conter informações
> confidenciais e/ou privilegiadas. Se você não for a pessoa autorizada a
> receber esta mensagem, não pode usar, copiar ou divulgar as informações
> nela contidas ou tomar qualquer ação baseada nessas informações. Caso esta
> mensagem tenha sido recebida por engano, por favor avise imediatamente o
> remetente, respondendo o e-mail e em seguida elimine-a do seu sistema.
> Agradecemos sua cooperação.
>

---

From: Fabio da Silva Ribeiro <[email-masked]>
Date: Thu, 24 Mar 2016 15:34:51 -0300

Thanks!

I will work on it soon!

2016-03-24 13:20 GMT-03:00 Valery Kartel <[email-masked]>:

> php7 really won't start with an error: PHP Warning:  PHP Startup: Unable
> to load dynamic library '/usr/lib/php7/modules/memcached.so' - Error
>>>> confidenciais

-- 
***