Subject: [alpine-aports] [PATCH] main/iptables: new upstream verison 1.6.0

From: Christian Kampka <[email-masked]>
Date: Wed, 23 Mar 2016 22:05:19 +0100

---
 main/iptables/APKBUILD                         |  21 ++--
 main/iptables/iptables-1.4.14-musl-fixes.patch | 127 -------------------------
 main/iptables/iptables-1.6.0-musl-fixes.patch  |  45 +++++++++
 3 files changed, 55 insertions(+), 138 deletions(-)
 delete mode 100644 main/iptables/iptables-1.4.14-musl-fixes.patch
 create mode 100644 main/iptables/iptables-1.6.0-musl-fixes.patch

diff --git a/main/iptables/APKBUILD b/main/iptables/APKBUILD
index 611f3be..7a9a9a0 100644
--- a/main/iptables/APKBUILD
+++ b/main/iptables/APKBUILD
@@ -1,14 +1,14 @@
 # Maintainer: Natanael Copa <[email-masked]>
 
 pkgname=iptables
-pkgver=1.4.21
-pkgrel=4
+pkgver=1.6.0
+pkgrel=0
 pkgdesc="Linux kernel firewall, NAT and packet mangling tools"
 url="http://www.netfilter.org/projects/iptables/index.html"
 arch="all"
 license="GPL2+"
 source="http://ftp.netfilter.org/pub/iptables/iptables-$pkgver.tar.bz2
-	iptables-1.4.14-musl-fixes.patch
+	iptables-1.6.0-musl-fixes.patch
 
 	iptables.initd
 	iptables.confd
@@ -16,13 +16,12 @@ source="http://ftp.netfilter.org/pub/iptables/iptables-$pkgver.tar.bz2
 	"
 
 depends_dev="linux-headers"
-makedepends="$depends_dev autoconf automake"
+makedepends="$depends_dev libnftnl-dev bison flex autoconf automake"
 subpackages="ip6tables $pkgname-doc $pkgname-dev"
 
 _builddir="$srcdir"/$pkgname-$pkgver
 prepare() {
 	cd "$_builddir"
-	update_config_sub || return 1
 	local i
 	for i in $source; do
 		case $i in
@@ -88,18 +87,18 @@ ip6tables() {
 	install -m644 "$startdir"/ip6tables.confd "$subpkgdir"/etc/conf.d/ip6tables
 }
 
-md5sums="536d048c8e8eeebcd9757d0863ebb0c0  iptables-1.4.21.tar.bz2
-cd9f429bf0dbd73be5f95bf0d7169728  iptables-1.4.14-musl-fixes.patch
+md5sums="27ba3451cb622467fc9267a176f19a31  iptables-1.6.0.tar.bz2
+92fcad4dc7b3e34d5bf944f53e34563b  iptables-1.6.0-musl-fixes.patch
 2e8175456a98221c0be9b758d064ee09  iptables.initd
 c91286c54f8fe0de6ed8950f375cb7a5  iptables.confd
 d3f37ebc2cd3fbfc326c3a8df5a79e11  ip6tables.confd"
-sha256sums="52004c68021da9a599feed27f65defcfb22128f7da2c0531c0f75de0f479d3e0  iptables-1.4.21.tar.bz2
-3ad64af68ea70aa6de0649a68176c2ac68e1c0db567babb472648695dbff8f90  iptables-1.4.14-musl-fixes.patch
+sha256sums="4bb72a0a0b18b5a9e79e87631ddc4084528e5df236bc7624472dcaa8480f1c60  iptables-1.6.0.tar.bz2
+0b7c73ebbb1f207ff6a1d36cb460b654eda7993eda9053fd469a493cae310d80  iptables-1.6.0-musl-fixes.patch
 f297f985ad35fe45800f0c1c7aaf348c3fa920b97be2020c76983ab54e384ba0  iptables.initd
 421acbcd310f9c51e20e22e59af9452b1ba5d0db33e8960eba0095271060c3db  iptables.confd
 31ef5d759c64afd0ecbcb56b3982ed2bdb5ed9c8553c628c13d4a3b5687118a3  ip6tables.confd"
-sha512sums="dd4baccdb080284d8620e6ed59beafc2677813f3e099051764b07f8e394f6d94ca11861b181f3cce7c55c66de64c1e2add13dc1a0b64e24050cd9fb7aea0689b  iptables-1.4.21.tar.bz2
-bc1cb36957d5afb80b770fe15f951de3074e2b1b28015372fb6f121fd551dd0e86c76c1819022dc468d11750b3969db40ef2dc9651c654c9f99212c0f2746985  iptables-1.4.14-musl-fixes.patch
+sha512sums="60360910db76e3265fb7b6456a55b91708263bde9c4e5b9cadf3832d2e2a9db3e6cb60c82e278ea0672618bd5c9566c374e00d19d35a2e8f330116c3ab6aaf51  iptables-1.6.0.tar.bz2
+e79344cab67c4fa0449dfeef6d1504bcd41d16d595010a18a7d9e75eba46021617d31fbb79c62894fd35898ec643b542a6111b06d405c79ffff41a3078327b62  iptables-1.6.0-musl-fixes.patch
 059b3bd8dd7dec60060ec5eb1e639fe8203207629f3a7dd4fdbe5ebca3f7e9b80df5592ebb27542e31830fd15a53cffac5772567053c104dfccf9b78613a31a1  iptables.initd
 cb7fecd5cab2c78bd3f215a41f39ec11c37eb360efbe83982378a0e647e0aa9dc0b7ec915a5b5081aa2f7747464787e69404aa15ba15a063c32cb8fb7dd13d1e  iptables.confd
 0897a7a22f8b700f7f1f5c355ad6cbf39740e44d6c962af99e479978d8a2d556ca7fe4e31f238829046b4a871ce0b5fd52e2544f1361d15dd1ea3e33992646c4  ip6tables.confd"
diff --git a/main/iptables/iptables-1.4.14-musl-fixes.patch b/main/iptables/iptables-1.4.14-musl-fixes.patch
deleted file mode 100644
index 547d0df..0000000
--- a/main/iptables/iptables-1.4.14-musl-fixes.patch
+++ /dev/null
@@ -1,127 +0,0 @@
---- iptables-1.4.12.1.o/extensions/libip6t_ipv6header.c
-+++ iptables-1.4.12.1/extensions/libip6t_ipv6header.c
-@@ -10,6 +10,9 @@
- #include <netdb.h>
- #include <xtables.h>
- #include <linux/netfilter_ipv6/ip6t_ipv6header.h>
-+#ifndef IPPROTO_HOPOPTS
-+#	define IPPROTO_HOPOPTS 0
-+#endif
- 
- enum {
- 	O_HEADER = 0,
---- iptables-1.4.12.1.o/extensions/libxt_TCPOPTSTRIP.c
-+++ iptables-1.4.12.1/extensions/libxt_TCPOPTSTRIP.c
-@@ -12,6 +12,21 @@
- #ifndef TCPOPT_MD5SIG
- #	define TCPOPT_MD5SIG 19
- #endif
-+#ifndef TCPOPT_MAXSEG
-+#	define TCPOPT_MAXSEG 2
-+#endif
-+#ifndef TCPOPT_WINDOW
-+#	define TCPOPT_WINDOW 3
-+#endif
-+#ifndef TCPOPT_SACK_PERMITTED
-+#	define TCPOPT_SACK_PERMITTED 4
-+#endif
-+#ifndef TCPOPT_SACK
-+#	define TCPOPT_SACK 5
-+#endif
-+#ifndef TCPOPT_TIMESTAMP
-+#	define TCPOPT_TIMESTAMP 8
-+#endif
- 
- enum {
- 	O_STRIP_OPTION = 0,
---- iptables-1.4.12.1.o/include/libiptc/ipt_kernel_headers.h
-+++ iptables-1.4.12.1/include/libiptc/ipt_kernel_headers.h
-@@ -5,7 +5,6 @@
- 
- #include <limits.h>
- 
--#if defined(__GLIBC__) && __GLIBC__ == 2
- #include <netinet/ip.h>
- #include <netinet/in.h>
- #include <netinet/ip_icmp.h>
-@@ -13,15 +12,4 @@
- #include <netinet/udp.h>
- #include <net/if.h>
- #include <sys/types.h>
--#else /* libc5 */
--#include <sys/socket.h>
--#include <linux/ip.h>
--#include <linux/in.h>
--#include <linux/if.h>
--#include <linux/icmp.h>
--#include <linux/tcp.h>
--#include <linux/udp.h>
--#include <linux/types.h>
--#include <linux/in6.h>
--#endif
- #endif
---- iptables-1.4.12.1.o/include/linux/netfilter_ipv4/ip_tables.h
-+++ iptables-1.4.12.1/include/linux/netfilter_ipv4/ip_tables.h
-@@ -16,6 +16,7 @@
- #define _IPTABLES_H
- 
- #include <linux/types.h>
-+#include <sys/types.h>
- 
- #include <linux/netfilter_ipv4.h>
- 
---- iptables-1.4.12.1.o/iptables/ip6tables-restore.c
-+++ iptables-1.4.12.1/iptables/ip6tables-restore.c
-@@ -9,7 +9,7 @@
-  */
- 
- #include <getopt.h>
--#include <sys/errno.h>
-+#include <errno.h>
- #include <stdbool.h>
- #include <string.h>
- #include <stdio.h>
---- iptables-1.4.12.1.o/iptables/ip6tables-save.c
-+++ iptables-1.4.12.1/iptables/ip6tables-save.c
-@@ -6,7 +6,7 @@
-  * This code is distributed under the terms of GNU GPL v2
-  */
- #include <getopt.h>
--#include <sys/errno.h>
-+#include <errno.h>
- #include <stdio.h>
- #include <fcntl.h>
- #include <stdlib.h>
---- iptables-1.4.12.1.o/iptables/iptables-restore.c
-+++ iptables-1.4.12.1/iptables/iptables-restore.c
-@@ -6,7 +6,7 @@
-  */
- 
- #include <getopt.h>
--#include <sys/errno.h>
-+#include <errno.h>
- #include <stdbool.h>
- #include <string.h>
- #include <stdio.h>
---- iptables-1.4.12.1.o/iptables/iptables-save.c
-+++ iptables-1.4.12.1/iptables/iptables-save.c
-@@ -6,7 +6,7 @@
-  *
-  */
- #include <getopt.h>
--#include <sys/errno.h>
-+#include <errno.h>
- #include <stdio.h>
- #include <fcntl.h>
- #include <stdlib.h>
---- iptables-1.4.12.1.o/iptables/iptables-xml.c
-+++ iptables-1.4.12.1/iptables/iptables-xml.c
-@@ -7,7 +7,7 @@
-  */
- 
- #include <getopt.h>
--#include <sys/errno.h>
-+#include <errno.h>
- #include <string.h>
- #include <stdio.h>
- #include <stdlib.h>
diff --git a/main/iptables/iptables-1.6.0-musl-fixes.patch b/main/iptables/iptables-1.6.0-musl-fixes.patch
new file mode 100644
index 0000000..4a89e19
--- /dev/null
+++ b/main/iptables/iptables-1.6.0-musl-fixes.patch
@@ -0,0 +1,45 @@
+--- iptables-1.4.12.1.o/extensions/libip6t_ipv6header.c
++++ iptables-1.4.12.1/extensions/libip6t_ipv6header.c
+@@ -10,6 +10,9 @@
+ #include <netdb.h>
+ #include <xtables.h>
+ #include <linux/netfilter_ipv6/ip6t_ipv6header.h>
++#ifndef IPPROTO_HOPOPTS
++#	define IPPROTO_HOPOPTS 0
++#endif
+
+ enum {
+ 	O_HEADER = 0,
+--- iptables-1.4.12.1.o/extensions/libxt_TCPOPTSTRIP.c
++++ iptables-1.4.12.1/extensions/libxt_TCPOPTSTRIP.c
+@@ -12,6 +12,21 @@
+ #ifndef TCPOPT_MD5SIG
+ #	define TCPOPT_MD5SIG 19
+ #endif
++#ifndef TCPOPT_MAXSEG
++#	define TCPOPT_MAXSEG 2
++#endif
++#ifndef TCPOPT_WINDOW
++#	define TCPOPT_WINDOW 3
++#endif
++#ifndef TCPOPT_SACK_PERMITTED
++#	define TCPOPT_SACK_PERMITTED 4
++#endif
++#ifndef TCPOPT_SACK
++#	define TCPOPT_SACK 5
++#endif
++#ifndef TCPOPT_TIMESTAMP
++#	define TCPOPT_TIMESTAMP 8
++#endif
+
+ enum {
+ 	O_STRIP_OPTION = 0,
+--- iptables-1.4.12.1.o/include/linux/netfilter_ipv4/ip_tables.h
++++ iptables-1.4.12.1/include/linux/netfilter_ipv4/ip_tables.h
+@@ -16,6 +16,7 @@
+ #define _IPTABLES_H
+
+ #include <linux/types.h>
++#include <sys/types.h>
+
+ #include <linux/netfilter_ipv4.h>
-- 
2.7.3

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Timo Teras <[email-masked]>
Date: Fri, 25 Mar 2016 14:02:16 +0200

On Wed, 23 Mar 2016 22:05:19 +0100
Christian Kampka <[email-masked]> wrote:

> main/iptables/iptables-1.6.0-musl-fixes.patch  |  45 +++++++++ 3
> files changed, 55 insertions(+), 138 deletions(-) delete mode 100644
> main/iptables/iptables-1.4.14-musl-fixes.patch create mode 100644
> main/iptables/iptables-1.6.0-musl-fixes.patch

build failed for me with:
nft.c:53:35: fatal error: xtables-config-parser.h: No such file or
directory compilation terminated.

---

---

From: Christian Kampka <[email-masked]>
Date: Fri, 25 Mar 2016 13:42:25 +0000

Hi,

xtables-config-parser.h is supposed to be created as part of the build and
'abuild build' produces it for me reliably (build log attached).
Why it is not building for you I can only speculate. Maybe you can share
your build log so I can have a look at what's going on?

Cheers,
Christian

---

From: Timo Teras <[email-masked]>
Date: Sat, 26 Mar 2016 12:18:27 +0200

On Fri, 25 Mar 2016 13:42:25 +0000
Christian Kampka <[email-masked]> wrote:

> xtables-config-parser.h is supposed to be created as part of the
> build and 'abuild build' produces it for me reliably (build log
> attached). Why it is not building for you I can only speculate. Maybe
> you can share your build log so I can have a look at what's going on?

Sounds parallel build issue. I'm building it on 24-way box with -j24.

Full build log:

]0;abuild: iptables>>> iptables: Checking sanity of /home/tteras/aports/main/iptables/APKBUILD...
>>> iptables: Analyzing dependencies...
(1/11) Installing linux-headers (4.1.12-r0)
(2/11) Installing libmnl (1.0.3-r1)
(3/11) Installing libmnl-dev (1.0.3-r1)
(4/11) Installing libnftnl-libs (1.0.5-r0)
(5/11) Installing libnftnl-dev (1.0.5-r0)
(6/11) Installing bison (3.0.4-r0)
(7/11) Installing flex (2.6.0-r0)
(8/11) Installing perl (5.22.1-r0)
(9/11) Installing autoconf (2.69-r0)
(10/11) Installing automake (1.15-r0)
(11/11) Installing .makedepends-iptables (0)
Executing busybox-1.24.2-r1.trigger
OK: 665 MiB in 127 packages
>>> iptables: Cleaning temporary build dirs...
>>> iptables: Checking sha512sums...
iptables-1.6.0.tar.bz2: OK
iptables-1.6.0-musl-fixes.patch: OK
iptables.initd: OK
iptables.confd: OK
ip6tables.confd: OK
>>> iptables: Unpacking /var/cache/distfiles/iptables-1.6.0.tar.bz2...
>>> iptables: iptables-1.6.0-musl-fixes.patch
patching file extensions/libip6t_ipv6header.c
patching file extensions/libxt_TCPOPTSTRIP.c
patching file include/linux/netfilter_ipv4/ip_tables.h
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... build-aux/install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for x86_64-alpine-linux-musl-gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for x86_64-alpine-linux-musl-ar... no
checking for x86_64-alpine-linux-musl-lib... no
checking for x86_64-alpine-linux-musl-link... no
checking for ar... ar
checking the archiver (ar) interface... ar
checking build system type... x86_64-alpine-linux-musl
checking host system type... x86_64-alpine-linux-musl
checking how to print strings... printf
checking for a sed that does not truncate output... /bin/sed
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for fgrep... /bin/grep -F
checking for ld used by gcc... /usr/x86_64-alpine-linux-musl/bin/ld
checking if the linker (/usr/x86_64-alpine-linux-musl/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 98304
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... yes
checking how to convert x86_64-alpine-linux-musl file names to x86_64-alpine-linux-musl format... func_convert_file_noop
checking how to convert x86_64-alpine-linux-musl file names to toolchain format... func_convert_file_noop
checking for /usr/x86_64-alpine-linux-musl/bin/ld option to reload object files... -r
checking for x86_64-alpine-linux-musl-objdump... no
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for x86_64-alpine-linux-musl-dlltool... no
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for x86_64-alpine-linux-musl-ar... ar
checking for archiver @FILE support... @
checking for x86_64-alpine-linux-musl-strip... no
checking for strip... strip
checking for x86_64-alpine-linux-musl-ranlib... no
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc object... ok
checking for sysroot... no
checking for x86_64-alpine-linux-musl-mt... no
checking for mt... no
checking if : is a manifest tool... no
checking how to run the C preprocessor... gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for dlfcn.h... yes
checking for objdir... .libs
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC -DPIC
checking if gcc PIC flag -fPIC -DPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.o... (cached) yes
checking whether the gcc linker (/usr/x86_64-alpine-linux-musl/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking whether the linker accepts -Wl,--no-as-needed... yes
checking whether /usr/x86_64-alpine-linux-musl/bin/ld -m elf_x86_64 knows -Wl,--no-undefined... yes
checking linux/dccp.h usability... yes
checking linux/dccp.h presence... yes
checking for linux/dccp.h... yes
checking linux/ip_vs.h usability... yes
checking linux/ip_vs.h presence... yes
checking for linux/ip_vs.h... yes
checking linux/magic.h usability... yes
checking linux/magic.h presence... yes
checking for linux/magic.h... yes
checking linux/proc_fs.h usability... no
checking linux/proc_fs.h presence... no
checking for linux/proc_fs.h... no
checking for x86_64-alpine-linux-musl-pkg-config... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for libnetfilter_conntrack... no
WARNING: libnetfilter_conntrack not found, connlabel match will not be built
checking size of struct ip6_hdr... 40
checking for libnfnetlink... no
checking for libmnl... yes
checking for libnftnl... yes
checking for flex... flex
checking lex output file root... lex.yy
checking lex library... none needed
checking whether yytext is a pointer... no
checking for bison... bison -y
checking flex version... configure: WARNING: flex version 2.6.0 found.
		Version 2.5.33 or greater is required. You may experience problems
		while compilating the nftables compatibility layer for iptables.
		Please, consider to upgrade flex.
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating extensions/GNUmakefile
config.status: creating include/Makefile
config.status: creating iptables/Makefile
config.status: creating iptables/xtables.pc
config.status: creating iptables/iptables.8
config.status: creating iptables/iptables-extensions.8.tmpl
config.status: creating iptables/iptables-save.8
config.status: creating iptables/iptables-restore.8
config.status: creating iptables/iptables-apply.8
config.status: creating iptables/iptables-xml.1
config.status: creating libipq/Makefile
config.status: creating libipq/libipq.pc
config.status: creating libiptc/Makefile
config.status: creating libiptc/libiptc.pc
config.status: creating libiptc/libip4tc.pc
config.status: creating libiptc/libip6tc.pc
config.status: creating libxtables/Makefile
config.status: creating utils/Makefile
config.status: creating include/xtables-version.h
config.status: creating include/iptables/internal.h
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing libtool commands

Iptables Configuration:
  IPv4 support:				yes
  IPv6 support:				yes
  Devel support:			yes
  IPQ support:				yes
  Large file support:			yes
  BPF utils support:			no
  nfsynproxy util support:		no
  nftables support:			yes

Build parameters:
  Put plugins into executable (static):	no
  Support plugins via dlopen (shared):	yes
  Installation prefix (--prefix):	/usr
  Xtables extension directory:		/usr/lib/xtables
  Pkg-config directory:			/usr/lib/pkgconfig
  Kernel source directory:		no
  Kernel build directory:		no
  Host:					x86_64-alpine-linux-musl
  GCC binary:				gcc

Iptables modules that will not be built:  connlabel
make  all-recursive
make[1]: Entering directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0'
Making all in libiptc
make[2]: Entering directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/libiptc'
/bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -MT libip4tc.lo -MD -MP -MF .deps/libip4tc.Tpo -c -o libip4tc.lo libip4tc.c
/bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -MT libip6tc.lo -MD -MP -MF .deps/libip6tc.Tpo -c -o libip6tc.lo libip6tc.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes -Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -MT libip4tc.lo -MD -MP -MF .deps/libip4tc.Tpo -c libip4tc.c  -fPIC -DPIC -o .libs/libip4tc.o
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes -Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -MT libip6tc.lo -MD -MP -MF .deps/libip6tc.Tpo -c libip6tc.c  -fPIC -DPIC -o .libs/libip6tc.o
mv -f .deps/libip4tc.Tpo .deps/libip4tc.Plo
/bin/bash ../libtool  --tag=CC   --mode=link gcc -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -version-info 1:0:1 -Wl,--as-needed -o libip4tc.la -rpath /usr/lib libip4tc.lo  
mv -f .deps/libip6tc.Tpo .deps/libip6tc.Plo
/bin/bash ../libtool  --tag=CC   --mode=link gcc -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -version-info 1:0:1 -Wl,--no-as-needed -Wl,--as-needed -o libip6tc.la -rpath /usr/lib libip6tc.lo  
libtool: link: gcc -shared  -fPIC -DPIC  .libs/libip4tc.o    -Os -Wl,--as-needed   -Wl,-soname -Wl,libip4tc.so.0 -o .libs/libip4tc.so.0.1.0
libtool: link: gcc -shared  -fPIC -DPIC  .libs/libip6tc.o    -Os -Wl,--no-as-needed -Wl,--as-needed   -Wl,-soname -Wl,libip6tc.so.0 -o .libs/libip6tc.so.0.1.0
libtool: link: (cd ".libs" && rm -f "libip4tc.so.0" && ln -s "libip4tc.so.0.1.0" "libip4tc.so.0")
libtool: link: (cd ".libs" && rm -f "libip4tc.so" && ln -s "libip4tc.so.0.1.0" "libip4tc.so")
libtool: link: (cd ".libs" && rm -f "libip6tc.so.0" && ln -s "libip6tc.so.0.1.0" "libip6tc.so.0")
libtool: link: ( cd ".libs" && rm -f "libip4tc.la" && ln -s "../libip4tc.la" "libip4tc.la" )
libtool: link: (cd ".libs" && rm -f "libip6tc.so" && ln -s "libip6tc.so.0.1.0" "libip6tc.so")
libtool: link: ( cd ".libs" && rm -f "libip6tc.la" && ln -s "../libip6tc.la" "libip6tc.la" )
/bin/bash ../libtool  --tag=CC   --mode=link gcc -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -version-info 0:0:0 -Wl,--no-as-needed -Wl,--as-needed -o libiptc.la -rpath /usr/lib  libip4tc.la libip6tc.la 
libtool: link: gcc -shared  -fPIC -DPIC   ./.libs/libip4tc.so ./.libs/libip6tc.so  -Os -Wl,--no-as-needed -Wl,--as-needed   -Wl,-soname -Wl,libiptc.so.0 -o .libs/libiptc.so.0.0.0
libtool: link: (cd ".libs" && rm -f "libiptc.so.0" && ln -s "libiptc.so.0.0.0" "libiptc.so.0")
libtool: link: (cd ".libs" && rm -f "libiptc.so" && ln -s "libiptc.so.0.0.0" "libiptc.so")
libtool: link: ( cd ".libs" && rm -f "libiptc.la" && ln -s "../libiptc.la" "libiptc.la" )
make[2]: Leaving directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/libiptc'
Making all in libxtables
make[2]: Entering directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/libxtables'
/bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -I../iptables -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -MT libxtables_la-xtables.lo -MD -MP -MF .deps/libxtables_la-xtables.Tpo -c -o libxtables_la-xtables.lo `test -f 'xtables.c' || echo './'`xtables.c
/bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -I../iptables -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -MT libxtables_la-xtoptions.lo -MD -MP -MF .deps/libxtables_la-xtoptions.Tpo -c -o libxtables_la-xtoptions.lo `test -f 'xtoptions.c' || echo './'`xtoptions.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -I../iptables -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes -Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -MT libxtables_la-xtables.lo -MD -MP -MF .deps/libxtables_la-xtables.Tpo -c xtables.c  -fPIC -DPIC -o .libs/libxtables_la-xtables.o
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -I../iptables -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes -Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -MT libxtables_la-xtoptions.lo -MD -MP -MF .deps/libxtables_la-xtoptions.Tpo -c xtoptions.c  -fPIC -DPIC -o .libs/libxtables_la-xtoptions.o
mv -f .deps/libxtables_la-xtoptions.Tpo .deps/libxtables_la-xtoptions.Plo
mv -f .deps/libxtables_la-xtables.Tpo .deps/libxtables_la-xtables.Plo
/bin/bash ../libtool  --tag=CC   --mode=link gcc -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -version-info 11:0:0 -Wl,--as-needed -o libxtables.la -rpath /usr/lib libxtables_la-xtables.lo libxtables_la-xtoptions.lo  -ldl 
libtool: link: gcc -shared  -fPIC -DPIC  .libs/libxtables_la-xtables.o .libs/libxtables_la-xtoptions.o   -ldl  -Os -Wl,--as-needed   -Wl,-soname -Wl,libxtables.so.11 -o .libs/libxtables.so.11.0.0
libtool: link: (cd ".libs" && rm -f "libxtables.so.11" && ln -s "libxtables.so.11.0.0" "libxtables.so.11")
libtool: link: (cd ".libs" && rm -f "libxtables.so" && ln -s "libxtables.so.11.0.0" "libxtables.so")
libtool: link: ( cd ".libs" && rm -f "libxtables.la" && ln -s "../libxtables.la" "libxtables.la" )
make[2]: Leaving directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/libxtables'
Making all in include
make[2]: Entering directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/include'
make[2]: Nothing to be done for 'all'.
make[2]: Leaving directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/include'
Making all in libipq
make[2]: Entering directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/libipq'
/bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -MT libipq.lo -MD -MP -MF .deps/libipq.Tpo -c -o libipq.lo libipq.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes -Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -MT libipq.lo -MD -MP -MF .deps/libipq.Tpo -c libipq.c  -fPIC -DPIC -o .libs/libipq.o
mv -f .deps/libipq.Tpo .deps/libipq.Plo
/bin/bash ../libtool  --tag=CC   --mode=link gcc -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE  -Wl,--as-needed -o libipq.la -rpath /usr/lib libipq.lo  
libtool: link: gcc -shared  -fPIC -DPIC  .libs/libipq.o    -Os -Wl,--as-needed   -Wl,-soname -Wl,libipq.so.0 -o .libs/libipq.so.0.0.0
libtool: link: (cd ".libs" && rm -f "libipq.so.0" && ln -s "libipq.so.0.0.0" "libipq.so.0")
libtool: link: (cd ".libs" && rm -f "libipq.so" && ln -s "libipq.so.0.0.0" "libipq.so")
libtool: link: ( cd ".libs" && rm -f "libipq.la" && ln -s "../libipq.la" "libipq.la" )
make[2]: Leaving directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/libipq'
Making all in utils
make[2]: Entering directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/utils'
make[2]: Nothing to be done for 'all'.
make[2]: Leaving directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/utils'
Making all in extensions
make[2]: Entering directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/extensions'
  CC       libxt_AUDIT.oo
  CC       libxt_CLASSIFY.oo
  CC       libxt_CONNMARK.oo
  CC       libxt_CONNSECMARK.oo
  CC       libxt_CHECKSUM.oo
  CC       libxt_CT.oo
  CC       libxt_HMARK.oo
  CC       libxt_MARK.oo
  CC       libxt_RATEEST.oo
  CC       libxt_SECMARK.oo
  CC       libxt_IDLETIMER.oo
  CC       libxt_TEE.oo
  CC       libxt_TCPOPTSTRIP.oo
  CC       libxt_TPROXY.oo
  CC       libxt_NFLOG.oo
  CC       libxt_NFQUEUE.oo
  CC       libxt_TOS.oo
  CC       libxt_LED.oo
  CC       libxt_TCPMSS.oo
  CC       libxt_TRACE.oo
  CC       libxt_DSCP.oo
  CC       libxt_addrtype.oo
  CC       libxt_SET.oo
  CC       libxt_SYNPROXY.oo
  CC       libxt_cgroup.oo
  CC       libxt_bpf.oo
  CC       libxt_comment.oo
  CC       libxt_cluster.oo
  CC       libxt_connmark.oo
  CC       libxt_connbytes.oo
  CC       libxt_conntrack.oo
  CC       libxt_connlimit.oo
  CC       libxt_cpu.oo
  CC       libxt_dccp.oo
  CC       libxt_dscp.oo
  CC       libxt_devgroup.oo
  CC       libxt_ecn.oo
  CC       libxt_esp.oo
  CC       libxt_hashlimit.oo
  CC       libxt_helper.oo
  CC       libxt_ipcomp.oo
  CC       libxt_length.oo
  CC       libxt_iprange.oo
  CC       libxt_mac.oo
  CC       libxt_ipvs.oo
  CC       libxt_limit.oo
  CC       libxt_mark.oo
  CC       libxt_mangle.oo
  CC       libxt_multiport.oo
  CC       libxt_nfacct.oo
  CC       libxt_osf.oo
  CC       libxt_pkttype.oo
  CC       libxt_policy.oo
  CC       libxt_owner.oo
  CC       libxt_physdev.oo
  CC       libxt_quota.oo
  CC       libxt_set.oo
  CC       libxt_recent.oo
  CC       libxt_rateest.oo
  CC       libxt_sctp.oo
  CC       libxt_standard.oo
  CC       libxt_rpfilter.oo
  CC       libxt_statistic.oo
  CC       libxt_socket.oo
  CC       libxt_string.oo
  CC       libxt_tcpmss.oo
  CC       libxt_time.oo
  CC       libxt_tos.oo
  CC       libxt_tcp.oo
  CC       libxt_udp.oo
  CCLD     libxt_CT.so
  CC       libxt_u32.oo
  CCLD     libxt_conntrack.so
  CC       libebt_ip.oo
  CC       libebt_802_3.oo
  CC       libebt_limit.oo
  CC       libebt_mark.oo
  CC       libebt_log.oo
  CC       libebt_mark_m.oo
  CC       libebt_nflog.oo
  CC       libipt_CLUSTERIP.oo
  CC       libipt_DNAT.oo
  CC       libipt_ECN.oo
  CC       libipt_MASQUERADE.oo
  CC       libipt_NETMAP.oo
  CC       libipt_LOG.oo
  CC       libipt_REDIRECT.oo
  CC       libipt_SNAT.oo
  CC       libipt_TTL.oo
  CC       libipt_REJECT.oo
  CC       libipt_ah.oo
  CC       libipt_ULOG.oo
  CC       libipt_icmp.oo
  CC       libipt_ttl.oo
  CC       libipt_realm.oo
  CC       libip6t_DNPT.oo
  CC       libip6t_DNAT.oo
  CC       libip6t_HL.oo
  CC       libip6t_MASQUERADE.oo
  CC       libip6t_LOG.oo
  CC       libip6t_NETMAP.oo
  CC       libip6t_REDIRECT.oo
  CC       libip6t_REJECT.oo
  CC       libip6t_SNPT.oo
  CC       libip6t_SNAT.oo
  CC       libip6t_ah.oo
  CC       libip6t_dst.oo
  CC       libip6t_eui64.oo
  CC       libip6t_frag.oo
  CC       libip6t_hbh.oo
  CC       libip6t_hl.oo
  CC       libip6t_ipv6header.oo
  CC       libip6t_icmp6.oo
  CC       libip6t_rt.oo
  CC       libip6t_mh.oo
  CC       libarpt_mangle.oo
  GEN      initext.c
  GEN      initext6.c
  GEN      initext4.c
  GEN      initextb.c
  GEN      initexta.c
  GEN      matches.man
	+ ./libxt_addrtype.man
	+ ./libip6t_ah.man
  GEN      targets.man
	+ ./libipt_ah.man
  CCLD     libxt_CHECKSUM.so
	+ ./libxt_AUDIT.man
	+ ./libxt_bpf.man
  CCLD     libxt_CLASSIFY.so
	+ ./libxt_cgroup.man
	+ ./libxt_CHECKSUM.man
  CCLD     libxt_CONNMARK.so
	+ ./libxt_CLASSIFY.man
	+ ./libipt_CLUSTERIP.man
  CCLD     libxt_CONNSECMARK.so
	+ ./libxt_cluster.man
	+ ./libxt_comment.man
	+ ./libxt_connbytes.man
	+ ./libxt_connlimit.man
	+ ./libxt_CONNMARK.man
  CCLD     libxt_AUDIT.so
  CCLD     libxt_DSCP.so
	+ ./libxt_connmark.man
	+ ./libxt_CONNSECMARK.man
	+ ./libxt_conntrack.man
  CCLD     libxt_HMARK.so
	+ ./libxt_cpu.man
	+ ./libxt_CT.man
	+ ./libxt_DNAT.man
	+ ./libxt_dccp.man
  CCLD     libxt_IDLETIMER.so
  CCLD     libxt_LED.so
  CCLD     libxt_MARK.so
	+ ./libip6t_DNPT.man
	+ ./libxt_devgroup.man
	+ ./libxt_DSCP.man
	+ ./libxt_dscp.man
	+ ./libipt_ECN.man
  CCLD     libxt_NFLOG.so
	+ ./libip6t_dst.man
	+ ./libxt_ecn.man
	+ ./libip6t_HL.man
  CCLD     libxt_NFQUEUE.so
	+ ./libxt_esp.man
	+ ./libxt_HMARK.man
	+ ./libxt_IDLETIMER.man
  CCLD     libxt_RATEEST.so
  CCLD     libxt_SECMARK.so
  CCLD     libxt_SET.so
	+ ./libxt_LED.man
	+ ./libxt_LOG.man
	+ ./libip6t_eui64.man
  CCLD     libxt_SYNPROXY.so
  CCLD     libxt_TCPOPTSTRIP.so
  CCLD     libxt_TCPMSS.so
	+ ./libxt_MARK.man
	+ ./libip6t_frag.man
  CCLD     libxt_TEE.so
	+ ./libxt_hashlimit.man
  CCLD     libxt_TPROXY.so
  CCLD     libxt_TRACE.so
	+ ./libip6t_hbh.man
	+ ./libxt_MASQUERADE.man
  CCLD     libxt_TOS.so
	+ ./libxt_helper.man
  CCLD     libxt_addrtype.so
	+ ./libip6t_hl.man
	+ ./libxt_NETMAP.man
	+ ./libxt_NFLOG.man
	+ ./libxt_NFQUEUE.man
	+ ./libipt_icmp.man
  CCLD     libxt_bpf.so
  CCLD     libxt_cluster.so
	+ ./libip6t_icmp6.man
	+ ./libxt_NOTRACK.man
  CCLD     libxt_comment.so
	+ ./libxt_iprange.man
	+ ./libxt_RATEEST.man
  CCLD     libxt_connbytes.so
  CCLD     libxt_cgroup.so
	+ ./libip6t_ipv6header.man
	+ ./libxt_REDIRECT.man
  CCLD     libxt_connmark.so
	+ ./libip6t_REJECT.man
	+ ./libxt_ipvs.man
  CCLD     libxt_connlimit.so
  CCLD     libxt_devgroup.so
  CCLD     libxt_dccp.so
  CCLD     libxt_cpu.so
	+ ./libipt_REJECT.man
	+ ./libxt_SECMARK.man
  CCLD     libxt_dscp.so
	+ ./libxt_SET.man
  CCLD     libxt_esp.so
  CCLD     libxt_ecn.so
	+ ./libxt_SNAT.man
	+ ./libip6t_SNPT.man
  CCLD     libxt_helper.so
  CCLD     libxt_hashlimit.so
	+ ./libxt_SYNPROXY.man
	+ ./libxt_length.man
  CCLD     libxt_ipcomp.so
	+ ./libxt_limit.man
	+ ./libxt_TCPMSS.man
  CCLD     libxt_limit.so
  CCLD     libxt_ipvs.so
  CCLD     libxt_iprange.so
  CCLD     libxt_length.so
  CCLD     libxt_mac.so
  CCLD     libxt_mangle.so
	+ ./libxt_TCPOPTSTRIP.man
	+ ./libxt_TEE.man
  CCLD     libxt_mark.so
	+ ./libxt_mac.man
	+ ./libxt_TOS.man
	+ ./libxt_mark.man
  CCLD     libxt_physdev.so
	+ ./libip6t_mh.man
  CCLD     libxt_owner.so
  CCLD     libxt_osf.so
	+ ./libxt_multiport.man
	+ ./libxt_nfacct.man
	+ ./libxt_TPROXY.man
  CCLD     libxt_nfacct.so
	+ ./libxt_osf.man
  CCLD     libxt_multiport.so
  CCLD     libxt_pkttype.so
	+ ./libxt_TRACE.man
	+ ./libxt_owner.man
	+ ./libipt_TTL.man
	+ ./libipt_ULOG.man
  CCLD     libxt_policy.so
  CCLD     libxt_quota.so
  CCLD     libxt_rateest.so
  CCLD     libxt_recent.so
  CCLD     libxt_rpfilter.so
  CCLD     libxt_sctp.so
  CCLD     libxt_statistic.so
  CCLD     libxt_string.so
	+ ./libxt_physdev.man
	+ ./libxt_pkttype.man
	+ ./libxt_policy.man
	+ ./libxt_quota.man
  CCLD     libxt_tcpmss.so
  CCLD     libxt_tcp.so
	+ ./libxt_rateest.man
  CCLD     libxt_time.so
  CCLD     libxt_standard.so
	+ ./libipt_realm.man
ln -fs libxt_CT.so libxt_NOTRACK.so
ln -fs libxt_conntrack.so libxt_state.so
  CCLD     libxt_socket.so
  CCLD     libxt_u32.so
  CCLD     libxt_tos.so
  CCLD     libebt_802_3.so
	+ ./libxt_recent.man
  CCLD     libxt_udp.so
  CCLD     libebt_limit.so
  CCLD     libebt_ip.so
	+ ./libxt_rpfilter.man
  CCLD     libebt_log.so
  CCLD     libebt_mark.so
  CCLD     libebt_mark_m.so
  CCLD     libipt_CLUSTERIP.so
	+ ./libip6t_rt.man
  CCLD     libipt_DNAT.so
  CCLD     libebt_nflog.so
  CCLD     libipt_ECN.so
  CCLD     libipt_REDIRECT.so
  CCLD     libipt_MASQUERADE.so
	+ ./libxt_sctp.man
  CCLD     libipt_LOG.so
  CCLD     libipt_NETMAP.so
  CCLD     libipt_SNAT.so
  CCLD     libipt_TTL.so
  CCLD     libipt_REJECT.so
	+ ./libxt_set.man
	+ ./libxt_socket.man
  CCLD     libipt_ah.so
  CCLD     libipt_icmp.so
	+ ./libxt_state.man
  CCLD     libipt_realm.so
	+ ./libxt_statistic.man
  CCLD     libip6t_DNAT.so
	+ ./libxt_string.man
  CCLD     libipt_ttl.so
  CCLD     libip6t_DNPT.so
	+ ./libxt_tcp.man
  CCLD     libipt_ULOG.so
	+ ./libxt_tcpmss.man
  CCLD     libip6t_HL.so
	+ ./libxt_time.man
  CCLD     libip6t_LOG.so
	+ ./libxt_tos.man
  CCLD     libip6t_NETMAP.so
  CCLD     libip6t_MASQUERADE.so
	+ ./libipt_ttl.man
  CCLD     libip6t_REDIRECT.so
  CCLD     libip6t_SNPT.so
	+ ./libxt_u32.man
  CCLD     libip6t_dst.so
	+ ./libxt_udp.man
  CCLD     libip6t_REJECT.so
  CCLD     libip6t_ah.so
  CCLD     libip6t_SNAT.so
  CCLD     libip6t_hbh.so
  CCLD     libip6t_hl.so
  CCLD     libip6t_icmp6.so
  CCLD     libip6t_frag.so
  CCLD     libip6t_ipv6header.so
  CCLD     libip6t_eui64.so
  CC       initext.o
  CC       initexta.o
  CC       initext4.o
  CC       initext6.o
  CC       initextb.o
  CCLD     libip6t_mh.so
  CCLD     libxt_set.so
  CCLD     libarpt_mangle.so
  CCLD     libip6t_rt.so
  AR       libext_arpt.a
  AR       libext_ebt.a
  AR       libext4.a
  AR       libext6.a
  AR       libext.a
make[2]: Leaving directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/extensions'
Making all in iptables
make[2]: Entering directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/iptables'
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_multi-xtables-multi.o -MD -MP -MF .deps/xtables_multi-xtables-multi.Tpo -c -o xtables_multi-xtables-multi.o `test -f 'xtables-multi.c' || echo './'`xtables-multi.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_multi-iptables-xml.o -MD -MP -MF .deps/xtables_multi-iptables-xml.Tpo -c -o xtables_multi-iptables-xml.o `test -f 'iptables-xml.c' || echo './'`iptables-xml.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_multi-iptables-save.o -MD -MP -MF .deps/xtables_multi-iptables-save.Tpo -c -o xtables_multi-iptables-save.o `test -f 'iptables-save.c' || echo './'`iptables-save.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_multi-iptables-restore.o -MD -MP -MF .deps/xtables_multi-iptables-restore.Tpo -c -o xtables_multi-iptables-restore.o `test -f 'iptables-restore.c' || echo './'`iptables-restore.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_multi-iptables-standalone.o -MD -MP -MF .deps/xtables_multi-iptables-standalone.Tpo -c -o xtables_multi-iptables-standalone.o `test -f 'iptables-standalone.c' || echo './'`iptables-standalone.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_multi-iptables.o -MD -MP -MF .deps/xtables_multi-iptables.Tpo -c -o xtables_multi-iptables.o `test -f 'iptables.c' || echo './'`iptables.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_multi-ip6tables-save.o -MD -MP -MF .deps/xtables_multi-ip6tables-save.Tpo -c -o xtables_multi-ip6tables-save.o `test -f 'ip6tables-save.c' || echo './'`ip6tables-save.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_multi-ip6tables-restore.o -MD -MP -MF .deps/xtables_multi-ip6tables-restore.Tpo -c -o xtables_multi-ip6tables-restore.o `test -f 'ip6tables-restore.c' || echo './'`ip6tables-restore.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_multi-ip6tables-standalone.o -MD -MP -MF .deps/xtables_multi-ip6tables-standalone.Tpo -c -o xtables_multi-ip6tables-standalone.o `test -f 'ip6tables-standalone.c' || echo './'`ip6tables-standalone.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_multi-ip6tables.o -MD -MP -MF .deps/xtables_multi-ip6tables.Tpo -c -o xtables_multi-ip6tables.o `test -f 'ip6tables.c' || echo './'`ip6tables.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_multi-xshared.o -MD -MP -MF .deps/xtables_multi-xshared.Tpo -c -o xtables_multi-xshared.o `test -f 'xshared.c' || echo './'`xshared.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-xtables-compat-multi.o -MD -MP -MF .deps/xtables_compat_multi-xtables-compat-multi.Tpo -c -o xtables_compat_multi-xtables-compat-multi.o `test -f 'xtables-compat-multi.c' || echo './'`xtables-compat-multi.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-iptables-xml.o -MD -MP -MF .deps/xtables_compat_multi-iptables-xml.Tpo -c -o xtables_compat_multi-iptables-xml.o `test -f 'iptables-xml.c' || echo './'`iptables-xml.c
/bin/bash ../build-aux/ylwrap xtables-config-parser.y y.tab.c xtables-config-parser.c y.tab.h `echo xtables-config-parser.c | sed -e s/cc$/hh/ -e s/cpp$/hpp/ -e s/cxx$/hxx/ -e s/c++$/h++/ -e s/c$/h/` y.output xtables-config-parser.output -- bison -y -d 
/bin/bash ../build-aux/ylwrap xtables-config-syntax.l lex.yy.c xtables-config-syntax.c -- flex  
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-xtables-save.o -MD -MP -MF .deps/xtables_compat_multi-xtables-save.Tpo -c -o xtables_compat_multi-xtables-save.o `test -f 'xtables-save.c' || echo './'`xtables-save.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-xtables-restore.o -MD -MP -MF .deps/xtables_compat_multi-xtables-restore.Tpo -c -o xtables_compat_multi-xtables-restore.o `test -f 'xtables-restore.c' || echo './'`xtables-restore.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-xtables-standalone.o -MD -MP -MF .deps/xtables_compat_multi-xtables-standalone.Tpo -c -o xtables_compat_multi-xtables-standalone.o `test -f 'xtables-standalone.c' || echo './'`xtables-standalone.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-xtables.o -MD -MP -MF .deps/xtables_compat_multi-xtables.Tpo -c -o xtables_compat_multi-xtables.o `test -f 'xtables.c' || echo './'`xtables.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-nft.o -MD -MP -MF .deps/xtables_compat_multi-nft.Tpo -c -o xtables_compat_multi-nft.o `test -f 'nft.c' || echo './'`nft.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-nft-shared.o -MD -MP -MF .deps/xtables_compat_multi-nft-shared.Tpo -c -o xtables_compat_multi-nft-shared.o `test -f 'nft-shared.c' || echo './'`nft-shared.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-nft-ipv4.o -MD -MP -MF .deps/xtables_compat_multi-nft-ipv4.Tpo -c -o xtables_compat_multi-nft-ipv4.o `test -f 'nft-ipv4.c' || echo './'`nft-ipv4.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-nft-ipv6.o -MD -MP -MF .deps/xtables_compat_multi-nft-ipv6.Tpo -c -o xtables_compat_multi-nft-ipv6.o `test -f 'nft-ipv6.c' || echo './'`nft-ipv6.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-nft-arp.o -MD -MP -MF .deps/xtables_compat_multi-nft-arp.Tpo -c -o xtables_compat_multi-nft-arp.o `test -f 'nft-arp.c' || echo './'`nft-arp.c
mv -f .deps/xtables_multi-xtables-multi.Tpo .deps/xtables_multi-xtables-multi.Po
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-xtables-arp-standalone.o -MD -MP -MF .deps/xtables_compat_multi-xtables-arp-standalone.Tpo -c -o xtables_compat_multi-xtables-arp-standalone.o `test -f 'xtables-arp-standalone.c' || echo './'`xtables-arp-standalone.c
mv -f .deps/xtables_compat_multi-xtables-compat-multi.Tpo .deps/xtables_compat_multi-xtables-compat-multi.Po
mv -f .deps/xtables_multi-ip6tables-standalone.Tpo .deps/xtables_multi-ip6tables-standalone.Po
mv -f .deps/xtables_multi-iptables-standalone.Tpo .deps/xtables_multi-iptables-standalone.Po
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-xtables-arp.o -MD -MP -MF .deps/xtables_compat_multi-xtables-arp.Tpo -c -o xtables_compat_multi-xtables-arp.o `test -f 'xtables-arp.c' || echo './'`xtables-arp.c
nft.c:53:35: fatal error: xtables-config-parser.h: No such file or directory
compilation terminated.
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-getethertype.o -MD -MP -MF .deps/xtables_compat_multi-getethertype.Tpo -c -o xtables_compat_multi-getethertype.o `test -f 'getethertype.c' || echo './'`getethertype.c
gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT 	-DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations 	-Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes 	-Winline -pipe  -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT xtables_compat_multi-nft-bridge.o -MD -MP -MF .deps/xtables_compat_multi-nft-bridge.Tpo -c -o xtables_compat_multi-nft-bridge.o `test -f 'nft-bridge.c' || echo './'`nft-bridge.c
Makefile:784: recipe for target 'xtables_compat_multi-nft.o' failed
make[2]: *** [xtables_compat_multi-nft.o] Error 1
make[2]: *** Waiting for unfinished jobs....
mv -f .deps/xtables_multi-ip6tables-save.Tpo .deps/xtables_multi-ip6tables-save.Po
mv -f .deps/xtables_multi-iptables-save.Tpo .deps/xtables_multi-iptables-save.Po
mv -f .deps/xtables_compat_multi-xtables-standalone.Tpo .deps/xtables_compat_multi-xtables-standalone.Po
mv -f .deps/xtables_compat_multi-xtables-arp-standalone.Tpo .deps/xtables_compat_multi-xtables-arp-standalone.Po
mv -f .deps/xtables_compat_multi-xtables-save.Tpo .deps/xtables_compat_multi-xtables-save.Po
mv -f .deps/xtables_compat_multi-getethertype.Tpo .deps/xtables_compat_multi-getethertype.Po
mv -f .deps/xtables_multi-xshared.Tpo .deps/xtables_multi-xshared.Po
mv -f .deps/xtables_multi-iptables-restore.Tpo .deps/xtables_multi-iptables-restore.Po
updating xtables-config-parser.h
mv -f .deps/xtables_multi-ip6tables-restore.Tpo .deps/xtables_multi-ip6tables-restore.Po
mv -f .deps/xtables_compat_multi-nft-ipv6.Tpo .deps/xtables_compat_multi-nft-ipv6.Po
mv -f .deps/xtables_compat_multi-xtables-restore.Tpo .deps/xtables_compat_multi-xtables-restore.Po
mv -f .deps/xtables_compat_multi-nft-ipv4.Tpo .deps/xtables_compat_multi-nft-ipv4.Po
mv -f .deps/xtables_multi-iptables-xml.Tpo .deps/xtables_multi-iptables-xml.Po
mv -f .deps/xtables_compat_multi-nft-arp.Tpo .deps/xtables_compat_multi-nft-arp.Po
mv -f .deps/xtables_compat_multi-iptables-xml.Tpo .deps/xtables_compat_multi-iptables-xml.Po
mv -f .deps/xtables_compat_multi-nft-bridge.Tpo .deps/xtables_compat_multi-nft-bridge.Po
mv -f .deps/xtables_compat_multi-nft-shared.Tpo .deps/xtables_compat_multi-nft-shared.Po
mv -f .deps/xtables_compat_multi-xtables.Tpo .deps/xtables_compat_multi-xtables.Po
mv -f .deps/xtables_compat_multi-xtables-arp.Tpo .deps/xtables_compat_multi-xtables-arp.Po
mv -f .deps/xtables_multi-ip6tables.Tpo .deps/xtables_multi-ip6tables.Po
mv -f .deps/xtables_multi-iptables.Tpo .deps/xtables_multi-iptables.Po
make[2]: Leaving directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0/iptables'
Makefile:494: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/tteras/aports/main/iptables/src/iptables-1.6.0'
Makefile:400: recipe for target 'all' failed
make: *** [all] Error 2
>>> ERROR: iptables: all failed
]0;>>> iptables: Uninstalling dependencies...

---

---

From: Christian Kampka <[email-masked]>
Date: Sat, 26 Mar 2016 11:39:27 +0000

Hi,

I can confirm the issue with -j24.
I sent in a new patch that pins parallel builds to -j2  which should fix it
for now.

http://patchwork.alpinelinux.org/patch/1802/

Cheers,
Christian

Timo Teras <[email-masked]> schrieb am Sa., 26. März 2016 um 11:18 Uhr:

>  ]0;abuild: iptables >>> iptables: Checking sanity of
> /home/tteras/aports/main/iptables/APKBUILD...
> checking how to convert x86_64-alpine-linux-musl file names to
> x86_64-alpine-linux-musl format... func_convert_file_noop
> checking whether the gcc linker (/usr/x86_64-alpine-linux-musl/bin/ld -m
> elf_x86_64) supports shared libraries... yes
> make[1]: Entering directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0'
> Making all in libiptc
> make[2]: Entering directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/libiptc'
> /bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.
> -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64
> -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL
> -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi
> -Ino/include -Os -fomit-frame-pointer -Wall -Waggregate-return
> -Wmissing-declarations       -Wmissing-prototypes -Wredundant-decls
> -Wshadow -Wstrict-prototypes     -Winline -pipe -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT libip4tc.lo -MD -MP -MF .deps/libip4tc.Tpo -c -o
> libip4tc.lo libip4tc.c
> /bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.
> -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64
> -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL
> -I../include -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi
> -Ino/include -Os -fomit-frame-pointer -Wall -Waggregate-return
> -Wmissing-declarations       -Wmissing-prototypes -Wredundant-decls
> -Wshadow -Wstrict-prototypes     -Winline -pipe -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT libip6tc.lo -MD -MP -MF .deps/libip6tc.Tpo -c -o
> libip6tc.lo libip6tc.c
> libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -D_LARGEFILE_SOURCE=1
> -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT
> -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include
> -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include
> -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations
> -Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes
> -Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -MT libip4tc.lo -MD
> -MP -MF .deps/libip4tc.Tpo -c libip4tc.c  -fPIC -DPIC -o .libs/libip4tc.o
> libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -D_LARGEFILE_SOURCE=1
> -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT
> -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include
> -I../include -Ino/include/uapi -Ino/include -Ino/include/uapi -Ino/include
> -Os -fomit-frame-pointer -Wall -Waggregate-return -Wmissing-declarations
> -Wmissing-prototypes -Wredundant-decls -Wshadow -Wstrict-prototypes
> -Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE -MT libip6tc.lo -MD
> -MP -MF .deps/libip6tc.Tpo -c libip6tc.c  -fPIC -DPIC -o .libs/libip6tc.o
> /bin/bash ../libtool  --tag=CC   --mode=link gcc -Wall -Waggregate-return
> -Wmissing-declarations        -Wmissing-prototypes -Wredundant-decls
> -Wshadow -Wstrict-prototypes     -Winline -pipe -Os -fomit-frame-pointer
> -D_GNU_SOURCE -version-info 1:0:1 -Wl,--as-needed -o libip4tc.la -rpath
> /usr/lib libip4tc.lo
> /bin/bash ../libtool  --tag=CC   --mode=link gcc -Wall -Waggregate-return
> -Wmissing-declarations        -Wmissing-prototypes -Wredundant-decls
> -Wshadow -Wstrict-prototypes     -Winline -pipe -Os -fomit-frame-pointer
> -D_GNU_SOURCE -version-info 1:0:1 -Wl,--no-as-needed -Wl,--as-needed -o
> libip6tc.la -rpath /usr/lib libip6tc.lo
> libtool: link: gcc -shared  -fPIC -DPIC  .libs/libip4tc.o    -Os
> -Wl,--as-needed   -Wl,-soname -Wl,libip4tc.so.0 -o .libs/libip4tc.so.0.1.0
> libtool: link: gcc -shared  -fPIC -DPIC  .libs/libip6tc.o    -Os
> -Wl,--no-as-needed -Wl,--as-needed   -Wl,-soname -Wl,libip6tc.so.0 -o
> .libs/libip6tc.so.0.1.0
> /bin/bash ../libtool  --tag=CC   --mode=link gcc -Wall -Waggregate-return
> -Wmissing-declarations        -Wmissing-prototypes -Wredundant-decls
> -Wshadow -Wstrict-prototypes     -Winline -pipe -Os -fomit-frame-pointer
> -D_GNU_SOURCE -version-info 0:0:0 -Wl,--no-as-needed -Wl,--as-needed -o
> libiptc.la -rpath /usr/lib  libip4tc.la libip6tc.la
> libtool: link: gcc -shared  -fPIC -DPIC   ./.libs/libip4tc.so
> ./.libs/libip6tc.so  -Os -Wl,--no-as-needed -Wl,--as-needed   -Wl,-soname
> -Wl,libiptc.so.0 -o .libs/libiptc.so.0.0.0
> make[2]: Leaving directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/libiptc'
> Making all in libxtables
> make[2]: Entering directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/libxtables'
> /bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.
> -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64
> -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL
> -I../include -I../include -I../iptables -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations         -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe -Os
> -fomit-frame-pointer -D_GNU_SOURCE -MT libxtables_la-xtables.lo -MD -MP -MF
> .deps/libxtables_la-xtables.Tpo -c -o libxtables_la-xtables.lo `test -f
> 'xtables.c' || echo './'`xtables.c
> /bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.
> -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64
> -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL
> -I../include -I../include -I../iptables -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations         -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe -Os
> -fomit-frame-pointer -D_GNU_SOURCE -MT libxtables_la-xtoptions.lo -MD -MP
> -MF .deps/libxtables_la-xtoptions.Tpo -c -o libxtables_la-xtoptions.lo
> `test -f 'xtoptions.c' || echo './'`xtoptions.c
> libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -D_LARGEFILE_SOURCE=1
> -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT
> -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include
> -I../include -I../iptables -Ino/include/uapi -Ino/include -Ino/include/uapi
> -Ino/include -Os -fomit-frame-pointer -Wall -Waggregate-return
> -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wshadow
> -Wstrict-prototypes -Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE
> -MT libxtables_la-xtables.lo -MD -MP -MF .deps/libxtables_la-xtables.Tpo -c
> xtables.c  -fPIC -DPIC -o .libs/libxtables_la-xtables.o
> libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -D_LARGEFILE_SOURCE=1
> -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT
> -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include
> -I../include -I../iptables -Ino/include/uapi -Ino/include -Ino/include/uapi
> -Ino/include -Os -fomit-frame-pointer -Wall -Waggregate-return
> -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wshadow
> -Wstrict-prototypes -Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE
> -MT libxtables_la-xtoptions.lo -MD -MP -MF
> .deps/libxtables_la-xtoptions.Tpo -c xtoptions.c  -fPIC -DPIC -o
> .libs/libxtables_la-xtoptions.o
> /bin/bash ../libtool  --tag=CC   --mode=link gcc -Wall -Waggregate-return
> -Wmissing-declarations        -Wmissing-prototypes -Wredundant-decls
> -Wshadow -Wstrict-prototypes     -Winline -pipe -Os -fomit-frame-pointer
> -D_GNU_SOURCE -version-info 11:0:0 -Wl,--as-needed -o libxtables.la
> -rpath /usr/lib libxtables_la-xtables.lo libxtables_la-xtoptions.lo  -ldl
> libtool: link: gcc -shared  -fPIC -DPIC  .libs/libxtables_la-xtables.o
> .libs/libxtables_la-xtoptions.o   -ldl  -Os -Wl,--as-needed   -Wl,-soname
> -Wl,libxtables.so.11 -o .libs/libxtables.so.11.0.0
> libtool: link: (cd ".libs" && rm -f "libxtables.so.11" && ln -s
> "libxtables.so.11.0.0" "libxtables.so.11")
> make[2]: Leaving directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/libxtables'
> Making all in include
> make[2]: Entering directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/include'
> make[2]: Leaving directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/include'
> Making all in libipq
> make[2]: Entering directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/libipq'
> /bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.
> -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES -D_FILE_OFFSET_BITS=64
> -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL
> -I../include -I../include -Os -fomit-frame-pointer -Wall -Waggregate-return
> -Wmissing-declarations     -Wmissing-prototypes -Wredundant-decls -Wshadow
> -Wstrict-prototypes     -Winline -pipe -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT libipq.lo -MD -MP -MF .deps/libipq.Tpo -c -o libipq.lo
> libipq.c
> libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -D_LARGEFILE_SOURCE=1
> -D_LARGE_FILES -D_FILE_OFFSET_BITS=64 -D_REENTRANT
> -DXTABLES_LIBDIR=\"/usr/lib/xtables\" -DXTABLES_INTERNAL -I../include
> -I../include -Os -fomit-frame-pointer -Wall -Waggregate-return
> -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wshadow
> -Wstrict-prototypes -Winline -pipe -Os -fomit-frame-pointer -D_GNU_SOURCE
> -MT libipq.lo -MD -MP -MF .deps/libipq.Tpo -c libipq.c  -fPIC -DPIC -o
> .libs/libipq.o
> /bin/bash ../libtool  --tag=CC   --mode=link gcc -Wall -Waggregate-return
> -Wmissing-declarations        -Wmissing-prototypes -Wredundant-decls
> -Wshadow -Wstrict-prototypes     -Winline -pipe -Os -fomit-frame-pointer
> -D_GNU_SOURCE  -Wl,--as-needed -o libipq.la -rpath /usr/lib libipq.lo
> libtool: link: gcc -shared  -fPIC -DPIC  .libs/libipq.o    -Os
> -Wl,--as-needed   -Wl,-soname -Wl,libipq.so.0 -o .libs/libipq.so.0.0.0
> make[2]: Leaving directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/libipq'
> Making all in utils
> make[2]: Entering directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/utils'
> make[2]: Leaving directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/utils'
> Making all in extensions
> make[2]: Entering directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/extensions'
>   CC       libxt_AUDIT.oo
>   CC       libxt_CLASSIFY.oo
>   CC       libxt_CONNMARK.oo
>   CC       libxt_CONNSECMARK.oo
>   CC       libxt_CHECKSUM.oo
>   CC       libxt_CT.oo
>   CC       libxt_HMARK.oo
>   CC       libxt_MARK.oo
>   CC       libxt_RATEEST.oo
>   CC       libxt_SECMARK.oo
>   CC       libxt_IDLETIMER.oo
>   CC       libxt_TEE.oo
>   CC       libxt_TCPOPTSTRIP.oo
>   CC       libxt_TPROXY.oo
>   CC       libxt_NFLOG.oo
>   CC       libxt_NFQUEUE.oo
>   CC       libxt_TOS.oo
>   CC       libxt_LED.oo
>   CC       libxt_TCPMSS.oo
>   CC       libxt_TRACE.oo
>   CC       libxt_DSCP.oo
>   CC       libxt_addrtype.oo
>   CC       libxt_SET.oo
>   CC       libxt_SYNPROXY.oo
>   CC       libxt_cgroup.oo
>   CC       libxt_bpf.oo
>   CC       libxt_comment.oo
>   CC       libxt_cluster.oo
>   CC       libxt_connmark.oo
>   CC       libxt_connbytes.oo
>   CC       libxt_conntrack.oo
>   CC       libxt_connlimit.oo
>   CC       libxt_cpu.oo
>   CC       libxt_dccp.oo
>   CC       libxt_dscp.oo
>   CC       libxt_devgroup.oo
>   CC       libxt_ecn.oo
>   CC       libxt_esp.oo
>   CC       libxt_hashlimit.oo
>   CC       libxt_helper.oo
>   CC       libxt_ipcomp.oo
>   CC       libxt_length.oo
>   CC       libxt_iprange.oo
>   CC       libxt_mac.oo
>   CC       libxt_ipvs.oo
>   CC       libxt_limit.oo
>   CC       libxt_mark.oo
>   CC       libxt_mangle.oo
>   CC       libxt_multiport.oo
>   CC       libxt_nfacct.oo
>   CC       libxt_osf.oo
>   CC       libxt_pkttype.oo
>   CC       libxt_policy.oo
>   CC       libxt_owner.oo
>   CC       libxt_physdev.oo
>   CC       libxt_quota.oo
>   CC       libxt_set.oo
>   CC       libxt_recent.oo
>   CC       libxt_rateest.oo
>   CC       libxt_sctp.oo
>   CC       libxt_standard.oo
>   CC       libxt_rpfilter.oo
>   CC       libxt_statistic.oo
>   CC       libxt_socket.oo
>   CC       libxt_string.oo
>   CC       libxt_tcpmss.oo
>   CC       libxt_time.oo
>   CC       libxt_tos.oo
>   CC       libxt_tcp.oo
>   CC       libxt_udp.oo
>   CCLD     libxt_CT.so
>   CC       libxt_u32.oo
>   CCLD     libxt_conntrack.so
>   CC       libebt_ip.oo
>   CC       libebt_802_3.oo
>   CC       libebt_limit.oo
>   CC       libebt_mark.oo
>   CC       libebt_log.oo
>   CC       libebt_mark_m.oo
>   CC       libebt_nflog.oo
>   CC       libipt_CLUSTERIP.oo
>   CC       libipt_DNAT.oo
>   CC       libipt_ECN.oo
>   CC       libipt_MASQUERADE.oo
>   CC       libipt_NETMAP.oo
>   CC       libipt_LOG.oo
>   CC       libipt_REDIRECT.oo
>   CC       libipt_SNAT.oo
>   CC       libipt_TTL.oo
>   CC       libipt_REJECT.oo
>   CC       libipt_ah.oo
>   CC       libipt_ULOG.oo
>   CC       libipt_icmp.oo
>   CC       libipt_ttl.oo
>   CC       libipt_realm.oo
>   CC       libip6t_DNPT.oo
>   CC       libip6t_DNAT.oo
>   CC       libip6t_HL.oo
>   CC       libip6t_MASQUERADE.oo
>   CC       libip6t_LOG.oo
>   CC       libip6t_NETMAP.oo
>   CC       libip6t_REDIRECT.oo
>   CC       libip6t_REJECT.oo
>   CC       libip6t_SNPT.oo
>   CC       libip6t_SNAT.oo
>   CC       libip6t_ah.oo
>   CC       libip6t_dst.oo
>   CC       libip6t_eui64.oo
>   CC       libip6t_frag.oo
>   CC       libip6t_hbh.oo
>   CC       libip6t_hl.oo
>   CC       libip6t_ipv6header.oo
>   CC       libip6t_icmp6.oo
>   CC       libip6t_rt.oo
>   CC       libip6t_mh.oo
>   CC       libarpt_mangle.oo
>   GEN      initext.c
>   GEN      initext6.c
>   GEN      initext4.c
>   GEN      initextb.c
>   GEN      initexta.c
>   GEN      matches.man
>         + ./libxt_addrtype.man
>         + ./libip6t_ah.man
>   GEN      targets.man
>         + ./libipt_ah.man
>   CCLD     libxt_CHECKSUM.so
>         + ./libxt_AUDIT.man
>         + ./libxt_bpf.man
>   CCLD     libxt_CLASSIFY.so
>         + ./libxt_cgroup.man
>         + ./libxt_CHECKSUM.man
>   CCLD     libxt_CONNMARK.so
>         + ./libxt_CLASSIFY.man
>         + ./libipt_CLUSTERIP.man
> make[2]: Leaving directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/extensions'
> Making all in iptables
> make[2]: Entering directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/iptables'
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT
> xtables_multi-xtables-multi.o -MD -MP -MF
> .deps/xtables_multi-xtables-multi.Tpo -c -o xtables_multi-xtables-multi.o
> `test -f 'xtables-multi.c' || echo './'`xtables-multi.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT
> xtables_multi-iptables-xml.o -MD -MP -MF
> .deps/xtables_multi-iptables-xml.Tpo -c -o xtables_multi-iptables-xml.o
> `test -f 'iptables-xml.c' || echo './'`iptables-xml.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT
> xtables_multi-iptables-save.o -MD -MP -MF
> .deps/xtables_multi-iptables-save.Tpo -c -o xtables_multi-iptables-save.o
> `test -f 'iptables-save.c' || echo './'`iptables-save.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT
> xtables_multi-iptables-restore.o -MD -MP -MF
> .deps/xtables_multi-iptables-restore.Tpo -c -o
> xtables_multi-iptables-restore.o `test -f 'iptables-restore.c' || echo
> './'`iptables-restore.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT
> xtables_multi-iptables-standalone.o -MD -MP -MF
> .deps/xtables_multi-iptables-standalone.Tpo -c -o
> xtables_multi-iptables-standalone.o `test -f 'iptables-standalone.c' ||
> echo './'`iptables-standalone.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT
> xtables_multi-iptables.o -MD -MP -MF .deps/xtables_multi-iptables.Tpo -c -o
> xtables_multi-iptables.o `test -f 'iptables.c' || echo './'`iptables.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT
> xtables_multi-ip6tables-save.o -MD -MP -MF
> .deps/xtables_multi-ip6tables-save.Tpo -c -o xtables_multi-ip6tables-save.o
> `test -f 'ip6tables-save.c' || echo './'`ip6tables-save.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT
> xtables_multi-ip6tables-restore.o -MD -MP -MF
> .deps/xtables_multi-ip6tables-restore.Tpo -c -o
> xtables_multi-ip6tables-restore.o `test -f 'ip6tables-restore.c' || echo
> './'`ip6tables-restore.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT
> xtables_multi-ip6tables-standalone.o -MD -MP -MF
> .deps/xtables_multi-ip6tables-standalone.Tpo -c -o
> xtables_multi-ip6tables-standalone.o `test -f 'ip6tables-standalone.c' ||
> echo './'`ip6tables-standalone.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT
> xtables_multi-ip6tables.o -MD -MP -MF .deps/xtables_multi-ip6tables.Tpo -c
> -o xtables_multi-ip6tables.o `test -f 'ip6tables.c' || echo './'`ip6tables.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer -D_GNU_SOURCE -MT
> xtables_multi-xshared.o -MD -MP -MF .deps/xtables_multi-xshared.Tpo -c -o
> xtables_multi-xshared.o `test -f 'xshared.c' || echo './'`xshared.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-xtables-compat-multi.o -MD -MP -MF
> .deps/xtables_compat_multi-xtables-compat-multi.Tpo -c -o
> xtables_compat_multi-xtables-compat-multi.o `test -f
> 'xtables-compat-multi.c' || echo './'`xtables-compat-multi.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-iptables-xml.o -MD -MP -MF
> .deps/xtables_compat_multi-iptables-xml.Tpo -c -o
> xtables_compat_multi-iptables-xml.o `test -f 'iptables-xml.c' || echo
> './'`iptables-xml.c
> /bin/bash ../build-aux/ylwrap xtables-config-parser.y y.tab.c
> xtables-config-parser.c y.tab.h `echo xtables-config-parser.c | sed -e
> s/cc$/hh/ -e s/cpp$/hpp/ -e s/cxx$/hxx/ -e s/c++$/h++/ -e s/c$/h/` y.output
> xtables-config-parser.output -- bison -y -d
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-xtables-save.o -MD -MP -MF
> .deps/xtables_compat_multi-xtables-save.Tpo -c -o
> xtables_compat_multi-xtables-save.o `test -f 'xtables-save.c' || echo
> './'`xtables-save.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-xtables-restore.o -MD -MP -MF
> .deps/xtables_compat_multi-xtables-restore.Tpo -c -o
> xtables_compat_multi-xtables-restore.o `test -f 'xtables-restore.c' || echo
> './'`xtables-restore.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-xtables-standalone.o -MD -MP -MF
> .deps/xtables_compat_multi-xtables-standalone.Tpo -c -o
> xtables_compat_multi-xtables-standalone.o `test -f 'xtables-standalone.c'
> || echo './'`xtables-standalone.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-xtables.o -MD -MP -MF
> .deps/xtables_compat_multi-xtables.Tpo -c -o xtables_compat_multi-xtables.o
> `test -f 'xtables.c' || echo './'`xtables.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-nft.o -MD -MP -MF
> .deps/xtables_compat_multi-nft.Tpo -c -o xtables_compat_multi-nft.o `test
> -f 'nft.c' || echo './'`nft.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-nft-shared.o -MD -MP -MF
> .deps/xtables_compat_multi-nft-shared.Tpo -c -o
> xtables_compat_multi-nft-shared.o `test -f 'nft-shared.c' || echo
> './'`nft-shared.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-nft-ipv4.o -MD -MP -MF
> .deps/xtables_compat_multi-nft-ipv4.Tpo -c -o
> xtables_compat_multi-nft-ipv4.o `test -f 'nft-ipv4.c' || echo
> './'`nft-ipv4.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-nft-ipv6.o -MD -MP -MF
> .deps/xtables_compat_multi-nft-ipv6.Tpo -c -o
> xtables_compat_multi-nft-ipv6.o `test -f 'nft-ipv6.c' || echo
> './'`nft-ipv6.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-nft-arp.o -MD -MP -MF
> .deps/xtables_compat_multi-nft-arp.Tpo -c -o xtables_compat_multi-nft-arp.o
> `test -f 'nft-arp.c' || echo './'`nft-arp.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-xtables-arp-standalone.o -MD -MP -MF
> .deps/xtables_compat_multi-xtables-arp-standalone.Tpo -c -o
> xtables_compat_multi-xtables-arp-standalone.o `test -f
> 'xtables-arp-standalone.c' || echo './'`xtables-arp-standalone.c
> mv -f .deps/xtables_compat_multi-xtables-compat-multi.Tpo
> .deps/xtables_compat_multi-xtables-compat-multi.Po
> mv -f .deps/xtables_multi-ip6tables-standalone.Tpo
> .deps/xtables_multi-ip6tables-standalone.Po
> mv -f .deps/xtables_multi-iptables-standalone.Tpo
> .deps/xtables_multi-iptables-standalone.Po
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-xtables-arp.o -MD -MP -MF
> .deps/xtables_compat_multi-xtables-arp.Tpo -c -o
> xtables_compat_multi-xtables-arp.o `test -f 'xtables-arp.c' || echo
> './'`xtables-arp.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-getethertype.o -MD -MP -MF
> .deps/xtables_compat_multi-getethertype.Tpo -c -o
> xtables_compat_multi-getethertype.o `test -f 'getethertype.c' || echo
> './'`getethertype.c
> gcc -DHAVE_CONFIG_H -I. -I..  -D_LARGEFILE_SOURCE=1 -D_LARGE_FILES
> -D_FILE_OFFSET_BITS=64 -D_REENTRANT  -DXTABLES_LIBDIR=\"/usr/lib/xtables\"
> -DXTABLES_INTERNAL -I../include -I../include -Ino/include/uapi -Ino/include
> -Ino/include/uapi -Ino/include    -Os -fomit-frame-pointer -Wall
> -Waggregate-return -Wmissing-declarations    -Wmissing-prototypes
> -Wredundant-decls -Wshadow -Wstrict-prototypes     -Winline -pipe
> -DENABLE_NFTABLES -DENABLE_IPV4 -DENABLE_IPV6 -Os -fomit-frame-pointer
> -D_GNU_SOURCE -MT xtables_compat_multi-nft-bridge.o -MD -MP -MF
> .deps/xtables_compat_multi-nft-bridge.Tpo -c -o
> xtables_compat_multi-nft-bridge.o `test -f 'nft-bridge.c' || echo
> './'`nft-bridge.c
> mv -f .deps/xtables_compat_multi-xtables-standalone.Tpo
> .deps/xtables_compat_multi-xtables-standalone.Po
> mv -f .deps/xtables_compat_multi-xtables-arp-standalone.Tpo
> .deps/xtables_compat_multi-xtables-arp-standalone.Po
> mv -f .deps/xtables_compat_multi-xtables-save.Tpo
> .deps/xtables_compat_multi-xtables-save.Po
> mv -f .deps/xtables_compat_multi-getethertype.Tpo
> .deps/xtables_compat_multi-getethertype.Po
> mv -f .deps/xtables_compat_multi-xtables-restore.Tpo
> .deps/xtables_compat_multi-xtables-restore.Po
> mv -f .deps/xtables_compat_multi-iptables-xml.Tpo
> .deps/xtables_compat_multi-iptables-xml.Po
> mv -f .deps/xtables_compat_multi-xtables-arp.Tpo
> .deps/xtables_compat_multi-xtables-arp.Po
> make[2]: Leaving directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0/iptables'
> make[1]: Leaving directory
> '/home/tteras/aports/main/iptables/src/iptables-1.6.0'
>  ]0; >>> iptables: Uninstalling dependencies...
>
>