Subject: Re: [alpine-aports] [PATCH] testing/texlive: new aport

From: Isaac Dunham <[email-masked]>
Date: Mon, 11 Jan 2016 07:31:16 -0800

On Mon, Jan 11, 2016 at 03:10:15PM +0000, ScrumpyJack wrote:
> Comprehensive TeX document production system
> http://tug.org/texlive/

It looks like you picked up my APKBUILD and didn't notice that TeX has
been moved to unmaintained, with pkgrel closer to 5.

While I *don't* mind you picking it up (if you are willing to do so,
*please* do!), it would be best to either apply it to
unaintained/texlive or move unmaintained/texlive to testing while
applying most of the changes.

Also, I'm wondering if a package for xdvi would be better than building
and splitting xdvik (which would drop the Motif requirement).

Thanks,
Isaac Dunham
> ---
>  testing/texlive/APKBUILD | 184 +++++++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 184 insertions(+)
>  create mode 100644 testing/texlive/APKBUILD
> 
> diff --git a/testing/texlive/APKBUILD b/testing/texlive/APKBUILD
> new file mode 100644
> index 0000000..223f442
> --- /dev/null
> +++ b/testing/texlive/APKBUILD
> @@ -0,0 +1,184 @@
> +# Contributor: Carlo Landmeter <[email-masked]>
> +# Maintainer:
> +pkgname=texlive
> +pkgver=20150521
> +pkgrel=3
> +pkgdesc="Comprehensive TeX document production system"
> +url="http://tug.org/texlive/"
> +arch="all"
> +license="GPL"
> +depends="perl"
> +depends_dev=""
> +makedepends="$freetype-dev libpng-dev poppler-dev icu-dev harfbuzz-dev
> +         cairo-dev pixman-dev zziplib-dev libpaper-dev graphite2-dev
> +         libxmu-dev fontconfig-dev libxaw-dev motif-dev"
> +install=""
> +subpackages="$pkgname-dev $pkgname-doc xdvik:xdvi $pkgname-xetex:xetex $pkgname-luatex:lua $pkgname-full:meta"
> +source="ftp://ftp.tug.org/historic/systems/$pkgname/${pkgver%????}/$pkgname-$pkgver-source.tar.xz"
> +
> +_LUATEX="dvilualatex dviluatex lualollipop"
> +_PDFTEX="amstex cslatex csplain eplain etex jadetex latex lollipop mex
> +	mllatex mltex pdfetex pdfcslatex pdfcsplain pdfjadetex pdflatex
> +	pdfmex pdfxmltex texsis utf8mex xmltex"
> +_XETEX="xelatex xelollipop"
> +
> +_builddir="$srcdir"/texlive-${pkgver}-source
> +prepare() {
> +	local i
> +	cd "$_builddir"
> +	for i in $source; do
> +		case $i in
> +		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
> +		esac
> +	done
> +}
> +
> +build() {
> +	cd "$_builddir"
> +	mkdir -p $_builddir/build && cd $_builddir/build
> +	../configure -C \
> +		--build=$CBUILD \
> +		--host=$CHOST \
> +		--prefix=/usr \
> +		--sysconfdir=/etc \
> +		--mandir=/usr/share/man \
> +		--infodir=/usr/share/info \
> +		--localstatedir=/var \
> +		--enable-epsfwin \
> +		--enable-ipc \
> +		--enable-luatex \
> +		--enable-mftalkwin \
> +		--enable-regiswin \
> +		--enable-shared \
> +		--enable-tektronixwin \
> +		--enable-unitermwin \
> +		--enable-xetex \
> +		--disable-biber \
> +		--disable-bibtex-x \
> +		--disable-chktex \
> +		--disable-cjkutils \
> +		--disable-detex \
> +		--disable-dialog \
> +		--disable-dvi2tty \
> +		--disable-dvipng \
> +		--disable-dvipsk \
> +		--disable-dvisvgm \
> +		--disable-largefile \
> +		--disable-lcdf-typetools \
> +		--disable-multiplatform \
> +		--disable-native-texlive-build \
> +		--disable-pdfopen \
> +		--disable-ps2eps \
> +		--disable-ps2pkm \
> +		--disable-psutils \
> +		--disable-t1utils \
> +		--disable-tex4htk \
> +		--disable-ttf2pk2 \
> +		--disable-vlna \
> +		--disable-xindy \
> +		--with-ps=gs \
> +		--with-banner-add="/Alpine Linux" \
> +		--with-system-cairo \
> +		--with-system-freetype2 \
> +		--with-system-graphite2 \
> +		--with-system-harfbuzz \
> +		--with-system-icu \
> +		--with-system-libpaper \
> +		--with-system-libpng \
> +		--with-system-pixman \
> +		--with-system-poppler \
> +		--with-system-xpdf \
> +		--with-system-zlib \
> +		--with-system-zziplib \
> +		--with-x-dvi-toolkit=motif \
> +		--without-texinfo \
> +		|| return 1
> +	make || return 1
> +}
> +
> +package() {
> +	cd "$_builddir"/build
> +	make DESTDIR="$pkgdir" install || return 1
> +	cp -rf ../texk/tests/TeXLive \
> +		"$pkgdir"/usr/share/texmf-dist/scripts/texlive || return 1
> +	for TEXCMD in $_PDFTEX;	do
> +		ln -s pdftex "$pkgdir"/usr/bin/$TEXCMD || return 1
> +	done
> +	ln -s eptex "$pkgdir"/usr/bin/platex && \
> +	ln -s euptex "$pkgdir"/usr/bin/uplatex || return 1
> +	sed -i -e 's:SELFAUTOPARENT:TEXMFROOT:' \
> +	  "$pkgdir"/usr/share/texmf-dist/scripts/texlive/tlmgr.pl || return 1
> +	sed -i -e 's:^\(TEXMFROOT *= *\)$SELFAUTOPARENT$:\1/usr/share:g' \
> +	  "$pkgdir"/usr/share/texmf-dist/web2c/texmf.cnf || return 1
> +}
> +
> +xetex() {
> +#	split off XeTeX because it depends on graphite/harfbuzz/icu
> +	pkgdesc="TeX typesetting engine supporting modern typography and bidirectional text"
> +	depends="$pkgname"
> +	mkdir -p "$subpkgdir" || return 1
> +	install -d -m 0755 "$subpkgdir"/usr/bin || return 1
> +	mv "$pkgdir"/usr/bin/xetex "$subpkgdir"/usr/bin/ || return 1
> +	for TEXCMD in $_XETEX; do
> +		ln -s xetex "$subpkgdir"/usr/bin/$TEXCMD || return 1
> +	done
> +}
> +
> +meta() {
> +	pkgdesc="A complete TeX distribution"
> +	depends="$pkgname $pkgname-doc $pkgname-luatex $pkgname-xetex xdvik"
> +	mkdir -p "$subpkgdir" || return 1
> +}
> +
> +lua() {
> +	pkgdesc="LuaTeX is an extended version of pdfTeX, scriptable in Lua"
> +# lua2dox_filter is a bash script
> +	depends="bash $pkgname"
> +	mkdir -p "$subpkgdir" || return 1
> +	cd "$subpkgdir" || return 1
> +	install -d -m 0755 usr/bin usr/lib \
> +		usr/share/texmf-dist/scripts/context/stubs/unix || return 1
> +	mv "$pkgdir"/usr/bin/*lua* "$subpkgdir"/usr/bin/ && \
> +	mv "$pkgdir"/usr/lib/lib*lua*.so.* "$subpkgdir"/usr/lib/ || return 1
> +	mv "$pkgdir"/usr/share/texmf-dist/scripts/*lua* \
> +		"$subpkgdir"/usr/share/texmf-dist/scripts/ || return 1
> +	mv "$pkgdir"/usr/share/texmf-dist/scripts/context/stubs/unix/luatools \
> +	"$subpkgdir"/usr/share/texmf-dist/scripts/context/stubs/unix/luatools \
> +		|| return 1
> +	for TEXCMD in $_LUATEX
> +		do ln -s luatex "$subpkgdir"/usr/bin/$TEXCMD || return 1
> +		done
> +	cd -
> +#	The following directories are used strictly for Lua scripts:
> +#	for DIR in
> +#		usr/share/texmf-dist/scripts/checkcites/ \
> +#		usr/share/texmf-dist/scripts/getmap/ \
> +#		usr/share/texmf-dist/scripts/m-tx/ \
> +#		usr/share/texmf-dist/scripts/musixtex/ \
> +#		usr/share/texmf-dist/scripts/pmx/ \
> +#		usr/share/texmf-dist/scripts/pmxchords/ \
> +#		usr/share/texmf-dist/scripts/ptex2pdf/ ;
> +#	do
> +#		mv "$pkgdir"/"$DIR" "$subpkgdir"/usr/share/texmf-dist/scripts/
> +#	done
> +
> +}
> +
> +xdvi() {
> +	# currently, xdvi needs a number of files and scripts from texlive;
> +	# we split it off so that it doesn't drag in X and Motif.
> +	depends="texlive"
> +	pkgdesc="Xdvi from texlive, using the texlive libraries"
> +	provides="xdvi"
> +	mkdir -p "$subpkgdir" || return 1
> +	cd "$subpkgdir" && \
> +	install -d -m 0755 usr/bin usr/share/texmf-dist/ && \
> +	mv "$pkgdir"/usr/bin/xdvi "$pkgdir"/usr/bin/xdvi-* usr/bin/ && \
> +	mv "$pkgdir"/usr/share/texmf-dist/xdvi usr/share/texmf-dist/ \
> +	|| return 1
> +	cd -
> +}
> +
> +md5sums="e526bd57118c4c4d5e9d525d20b5ac02  texlive-20150521-source.tar.xz"
> +sha256sums="ed9bcd7bdce899c3c27c16a8c5c3017c4f09e1d7fd097038351b72497e9d4669  texlive-20150521-source.tar.xz"
> +sha512sums="9d06bb88c489715787ce619c4c6b5e2d4251e1db8d48ae7fe2d1a253634c76bc6d7282ef9c93c77847845cae01eafb58dfb37ba3fb83a6d223f0d7fe8f5d3855  texlive-20150521-source.tar.xz"
> --
> 2.6.4
> 
> 
> 
> ---
> Unsubscribe:  [email-masked]
> Help:         [email-masked]
> ---
> 

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: nicholas <[email-masked]>
Date: Mon, 11 Jan 2016 16:49:13 +0000

>been moved to unmaintained, with pkgrel closer to 5.

Aha, I thought the patch owner would chime up. Excellent. We'll put your
name on it.

The unmaintainedness of the old package is a bit of a saga.  Have a look
at #3920 #4514 #4969 and the irc logs for December if you have the time.

In short, issues were closed, others opened ... and the package ended up
in unmaintained. It isn't close to a working package and should have
been deleted from testing.

Your new APKBUILD, relayed by Mark Collin, built fine in edge after a
very minor tweak, and Mark has tested it privately.

>applying most of the changes.

I think we should delete the unmaintained package (built for #3920) and
push this one to testing (built for #4969)

>and splitting xdvik (which would drop the Motif requirement).

Be my guest :)

Thanks for your all work on this on, there's been quite a bit of noise
about it.

---