Subject: Re: [alpine-aports] [PATCH] main/curl: strip to subpackages and cleanups

From: Natanael Copa <[email-masked]>
Date: Mon, 25 Jan 2016 13:44:40 +0100

On Mon, 25 Jan 2016 14:00:30 +0200
Valery Kartel <[email-masked]> wrote:

> - remove unused patch
> - move libcurl and zsh completion to subpackages
> ---
>  ...-generate-code-for-disable-manual-as-well.patch | 42 ----------------------
>  main/curl/APKBUILD                                 | 40 +++++++++++----------
>  2 files changed, 22 insertions(+), 60 deletions(-)
>  delete mode 100644 main/curl/0001-mkhelp-generate-code-for-disable-manual-as-well.patch
> 
> diff --git a/main/curl/0001-mkhelp-generate-code-for-disable-manual-as-well.patch b/main/curl/0001-mkhelp-generate-code-for-disable-manual-as-well.patch
> deleted file mode 100644
> index d23b484..0000000
> --- a/main/curl/0001-mkhelp-generate-code-for-disable-manual-as-well.patch
> +++ /dev/null
> @@ -1,42 +0,0 @@
> -From 38d582ff541353d738858299d4a2b78bafac03ed Mon Sep 17 00:00:00 2001
> -From: Daniel Stenberg <[email-masked]>
> -Date: Wed, 26 Mar 2014 13:22:10 +0100
> -Subject: [PATCH] mkhelp: generate code for --disable-manual as well
> -
> -This allows configure --disable-manual to run and build without having
> -to regenerate the src/tool_hugehelp.c file which otherwise is necessary
> -since we ship tarballs with that file present.
> -
> -Reported-by: Remi Gacogne
> -Bug: http://curl.haxx.se/bug/view.cgi?id=1350
> ----
> - src/mkhelp.pl | 6 +++++-
> - 1 file changed, 5 insertions(+), 1 deletion(-)
> -
> -diff --git a/src/mkhelp.pl b/src/mkhelp.pl
> -index 444b669..7ed86f7 100644
> ---- a/src/mkhelp.pl
> -+++ b/src/mkhelp.pl
> -@@ -6,7 +6,7 @@
> - #                            | (__| |_| |  _ <| |___
> - #                             \___|\___/|_| \_\_____|
> - #
> --# Copyright (C) 1998 - 2011, Daniel Stenberg, <[email-masked]>, et al.
> -+# Copyright (C) 1998 - 2014, Daniel Stenberg, <[email-masked]>, et al.
> - #
> - # This software is licensed as described in the file COPYING, which
> - # you should have received as part of this distribution. The terms
> -@@ -256,6 +256,10 @@ foot();
> - 
> - sub foot {
> -   print <<FOOT
> -+#else /* !USE_MANUAL */
> -+/* built-in manual is disabled, blank function */
> -+#include "tool_hugehelp.h"
> -+void hugehelp(void) {}
> - #endif /* USE_MANUAL */
> - FOOT
> -   ;
> --- 
> -1.9.1
> -
> diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
> index 4962d9e..87f476d 100644
> --- a/main/curl/APKBUILD
> +++ b/main/curl/APKBUILD
> @@ -1,40 +1,29 @@
> +# Contributor: Valery Kartel <[email-masked]>
>  # Contributor: Åukasz Jendrysik <[email-masked]>
>  # Maintainer: Natanael Copa <[email-masked]>
>  pkgname=curl
>  pkgver=7.46.0
> -pkgrel=1
> +pkgrel=2
>  pkgdesc="An URL retrival utility and library"
>  url="http://curl.haxx.se"
>  arch="all"
>  license="MIT"
>  depends="ca-certificates"
>  depends_dev="zlib-dev openssl-dev libssh2-dev"
> -makedepends="groff $depends_dev perl"
> -source="http://curl.haxx.se/download/curl-$pkgver.tar.bz2"
> -subpackages="$pkgname-doc $pkgname-dev"
> +makedepends="$depends_dev groff perl"
> +source="http://curl.haxx.se/download/$pkgname-$pkgver.tar.bz2"
> +subpackages="$pkgname-doc $pkgname-dev libcurl $pkgname-zsh-completion:zshcomp"
>  
> -_builddir="$srcdir/$pkgname-$pkgver"
> -
> -prepare() {
> -	local i
> -	cd "$_builddir"
> -	for i in $source; do
> -		case $i in
> -		*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
> -		esac
> -	done
> -}

i like to keep the prepare function in case we need to add a patch
later.

For example see commit:
http://git.alpinelinux.org/cgit/aports/commit/?id=81070afb94cd7454dd87cadfb0d0faed7e556de8

I spent almost a day to debug the issue that commit is supposed to
solve. However, the patch was actually not applied:

http://git.alpinelinux.org/cgit/aports/commit/?id=d836f6e8fb1d5165bf70839a7c953a56568848d7

So, I prefer to keep it unless there is a good reason to remove it.

> +_builddir="$srcdir"/$pkgname-$pkgver
>  build() {
>  	cd "$_builddir"
>  	./configure \
>  		--build=$CBUILD \
>  		--host=$CHOST \
>  		--prefix=/usr \
> -		--mandir=/usr/share/man \
> -		--without-libidn \
>  		--enable-ipv6 \
>  		--enable-unix-sockets \
> -		--disable-ldap \

I don't like removing the --disable-* things. It will prevent to
unintentionally link against ldap and libidn in case it happens to be
installed at developer box.

otherwise i think its ok.

> +		--disable-static \
>  		|| return 1
>  	make || return 1
>  }
> @@ -44,6 +33,21 @@ package() {
>  	make DESTDIR="$pkgdir" install || return 1
>  }
>  
> +libcurl() {
> +	pkgdesc="The multiprotocol file transfer library"
> +	mkdir -p "$subpkgdir"/usr
> +	mv "$pkgdir"/usr/lib "$subpkgdir"/usr
> +}
> +
> +zshcomp() {
> +	pkgdesc="Zsh completion for $pkgname"
> +	arch="noarch"
> +	depends=""
> +	install_if="$pkgname=$pkgver-r$pkgrel zsh"
> +	mkdir -p "$subpkgdir"/usr/
> +	mv "$pkgdir"/usr/share "$subpkgdir"/usr
> +}
> +
>  md5sums="9979f989a2a9930d10f1b3deeabc2148  curl-7.46.0.tar.bz2"
>  sha256sums="b7d726cdd8ed4b6db0fa1b474a3c59ebbbe4dcd4c61ac5e7ade0e0270d3195ad  curl-7.46.0.tar.bz2"
>  sha512sums="ff47216a2b4a2d14a2e98e0e87867897a9bf059c58d2d73aa47a69ccd94977367e2de15bea641abfb00e236a8b016ee869675c2cc702f7919da5fe612bd8b5e1  curl-7.46.0.tar.bz2"

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Valery Kartel <[email-masked]>
Date: Mon, 25 Jan 2016 14:51:35 +0200

Ok, I'll made v2 commit сonsidering your comments

2016-01-25 14:44 GMT+02:00 Natanael Copa <[email-masked]>:

> >  delete mode 100644
> main/curl/0001-mkhelp-generate-code-for-disable-manual-as-well.patch
> >
> > diff --git
> a/main/curl/0001-mkhelp-generate-code-for-disable-manual-as-well.patch
> b/main/curl/0001-mkhelp-generate-code-for-disable-manual-as-well.patch
> > deleted file mode 100644
> > index d23b484..0000000
> > ---
> a/main/curl/0001-mkhelp-generate-code-for-disable-manual-as-well.patch
> > +++ /dev/null
> > @@ -1,42 +0,0 @@
> >  # Contributor: Å ukasz Jendrysik <[email-masked]>