Subject: [alpine-aports] [PATCH] add provides=firefox-esr to testing/firefox

From: Jens Staal <[email-masked]>
Date: Wed, 16 Nov 2016 09:18:59 +0100

This patch adds provides firefox-esr to testing/firefox
Otherwise, firefox will block installation of alpine-desktop

>From 566b99d34e74050971e32f6d982bfd3738c1852b Mon Sep 17 00:00:00 2001
From: Jens Staal <[email-masked]>
Date: Wed, 16 Nov 2016 09:05:26 +0100
Subject: [PATCH] testing/firefox: add provides=firefox-esr

www.firefox.com
Firefox Web Browser
---
 testing/firefox/APKBUILD | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
index 76b650e..9be40ea 100644
--- a/testing/firefox/APKBUILD
+++ b/testing/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
 pkgver=50.0
 _pkgver=$pkgver
 _xulver=$pkgver
-pkgrel=0
+pkgrel=1
 pkgdesc="Firefox web browser"
 url="http://www.firefox.com"
 arch="all !aarch64"
@@ -47,6 +47,7 @@ makedepends="$depends_dev
 	yasm
 	zip
 	"
+provides="firefox-esr=$pkgver"
 
 install=""
 subpackages="$pkgname-dev"
-- 
2.10.2

---

From: Timo Teras <[email-masked]>
Date: Wed, 16 Nov 2016 11:07:34 +0200

On Wed, 16 Nov 2016 09:18:59 +0100

> Otherwise, firefox will block installation of alpine-desktop

I personally would do it the other way around...

alpine-desktop should depend on firefox, and firefox-esr should provide
firefox=$pkgver.

@ncopa any thoughts?

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Jens Staal <[email-masked]>
Date: Wed, 16 Nov 2016 10:22:50 +0100

> alpine-desktop should depend on firefox, and firefox-esr should provide

Fine by me either way :)

by the way, my 2 previous patch submissions "new port:
testing/wine-mono" and "new port: testing/mesa" have pathces attached.
I forgot to add [PATCH] in the subject.

especially the testing/mesa will be important later for my
testing/wine-staging since it includes gallium nine.

---

---

From: Natanael Copa <[email-masked]>
Date: Wed, 16 Nov 2016 13:35:33 -0200

On Wed, 16 Nov 2016 11:07:34 +0200

> alpine-desktop should depend on firefox, and firefox-esr should provide

I think we should kill alpine-desktop and have a setup-desktop script
instead. Using a meta package makes it difficult to replace/remove
components.

-nc

---