Subject: [alpine-aports] [PATCH] testing/micropython: Reduced makedepends

From: Marian Buschsieweke <[email-masked]>
Date: Thu, 3 Aug 2017 16:21:54 +0200

python2 no longer needed in order to build micropython
---
 testing/micropython/APKBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/testing/micropython/APKBUILD b/testing/micropython/APKBUILD
index 1306af73b7..2cdacc0514 100644
--- a/testing/micropython/APKBUILD
+++ b/testing/micropython/APKBUILD
@@ -8,7 +8,7 @@ url="http://www.micropython.org/"
 arch="all"
 license="MIT"
 depends=""
-makedepends="libffi-dev python3 python2"
+makedepends="libffi-dev python3"
 subpackages="$pkgname-cross"
 source="${pkgname}-${pkgver}.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/v${pkgver}.tar.gz
         0000-unix-mpconfigport.patch
@@ -19,7 +19,7 @@ builddir="${srcdir}/${pkgname}-${pkgver}"
 build() {
 	cd "$builddir"
 	unset CFLAGS
-	make -C unix #PYTHON=python3
+	make -C unix PYTHON=python3
 }
 
 check() {
@@ -28,7 +28,7 @@ check() {
 	# ffi callback fails on kernel with PaX
 	rm tests/unix/ffi_callback.py
 
-	make -C unix test #PYTHON=python3
+	make -C unix test PYTHON=python3
 }
 
 package() {
-- 
2.13.3

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 3 Aug 2017 16:35:41 +0200

On Thu,  3 Aug 2017 16:21:54 +0200

> python2 no longer needed in order to build micropython

Sorry, I already pushed a similar fix, together with an updated arch setting.

Thanks!

-nc

---