Patches for aports can be sent to this list

1

[alpine-aports] [PATCH] community/borgbackup: upgrade to 1.1.6

Sascha Paunovic
Details
Message ID
<20180611125221.16133-1-azarus@posteo.net>
Sender timestamp
1528721541
DKIM signature
missing
Download raw message
Patch: +4 -28
Also, remove no longer needed patch
---
 community/borgbackup/APKBUILD          | 10 ++++------
 community/borgbackup/msgpack-fix.patch | 22 ----------------------
 2 files changed, 4 insertions(+), 28 deletions(-)
 delete mode 100644 community/borgbackup/msgpack-fix.patch

diff --git a/community/borgbackup/APKBUILD b/community/borgbackup/APKBUILD
index 21cbe60798..3ff9e41655 100644
--- a/community/borgbackup/APKBUILD
+++ b/community/borgbackup/APKBUILD
@@ -1,16 +1,15 @@
 # Contributor: Olivier Mauras <olivier@mauras.ch>
 # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
 pkgname=borgbackup
-pkgver=1.1.5
-pkgrel=1
+pkgver=1.1.6
+pkgrel=0
 pkgdesc="Deduplicating backup program"
 url="https://borgbackup.readthedocs.io/"
 arch="all"
 license="BSD-3-Clause"
 depends="python3 py3-msgpack py3-zmq"
 makedepends="python3-dev lz4-dev acl-dev attr-dev libressl-dev linux-headers"
-source="https://github.com/$pkgname/borg/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
-	msgpack-fix.patch"
+source="https://github.com/$pkgname/borg/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
 
 build() {
 	cd "$builddir"
@@ -26,5 +25,4 @@ package() {
 	find . -name '*.h' -delete -o -name '*.c' -delete -o -name '*.pyx' -delete
 }
 
-sha512sums="22071e4b37059d816592baff852772720769b3d86eb1d071abba67f9d13de809066aa29cdf18f1aaef127d1f24288913a7b0b63d157fb98840b1a71606dc0554  borgbackup-1.1.5.tar.gz
-75cb9c8f3d75ab7ca716d4e0c92ad8097225f1bd5f0a5e8e8213099f56fd4d1ca57587427c20a0695ed154f962fe2a8a0950c7449e29ddf79f5f27aa8ff029dd  msgpack-fix.patch"
+sha512sums="5741c48bdb70a26d40bd583f207460e35bb7dd560424889d37eb4d90ee96947457faf09bae0fa2b26b42ec71ef6eeaec1b770ba3257223a2637fcb55266e4a17  borgbackup-1.1.6.tar.gz"
diff --git a/community/borgbackup/msgpack-fix.patch b/community/borgbackup/msgpack-fix.patch
deleted file mode 100644
index 67a44204c4..0000000000
--- a/community/borgbackup/msgpack-fix.patch
@@ -1,22 +0,0 @@
---- borgbackup-1.1.5/setup.py.orig
-+++ borgbackup-1.1.5/setup.py
-@@ -36,10 +36,15 @@
- on_rtd = os.environ.get('READTHEDOCS')
- 
- install_requires = [
--    # msgpack pure python data corruption was fixed in 0.4.6.
--    # msgpack 0.5.0 was a bit of a troublemaker.
--    # also, msgpack dropped py34 support at 0.5.0.
--    'msgpack-python>=0.4.6,<0.5.0',
-+    # we are rather picky about msgpack versions, because a good working msgpack is
-+    # very important for borg, see https://github.com/borgbackup/borg/issues/3753
-+    # best versions seem to be 0.4.6, 0.4.7, 0.4.8 and 0.5.6:
-+    'msgpack-python >=0.4.6, <=0.5.6, !=0.5.0, !=0.5.1, !=0.5.2, !=0.5.3, !=0.5.4, !=0.5.5',
-+    # if you can't satisfy the above requirement, these are versions that might
-+    # also work ok, IF you make sure to use the COMPILED version of msgpack-python,
-+    # NOT the PURE PYTHON fallback implementation: ==0.5.1, ==0.5.4
-+    # using any other version is not supported by borg development, feel free to
-+    # do it on your own risk (and after own testing).
- ]
- 
- # note for package maintainers: if you package borgbackup for distribution,
-- 
2.17.1



---
Unsubscribe:  alpine-aports+unsubscribe@lists.alpinelinux.org
Help:         alpine-aports+help@lists.alpinelinux.org
---
Natanael Copa
Details
Message ID
<20180611225346.5ad08838@ncopa-desktop.copa.dup.pw>
In-Reply-To
<20180611125221.16133-1-azarus@posteo.net> (view parent)
Sender timestamp
1528750449
DKIM signature
missing
Download raw message
Patch: +2 -1
On Mon, 11 Jun 2018 14:52:21 +0200
Sascha Paunovic <azarus@posteo.net> wrote:

> Also, remove no longer needed patch
> ---
>  community/borgbackup/APKBUILD          | 10 ++++------
>  community/borgbackup/msgpack-fix.patch | 22 ----------------------
>  2 files changed, 4 insertions(+), 28 deletions(-)
>  delete mode 100644 community/borgbackup/msgpack-fix.patch

I am applying this with this additional change:

diff --git a/community/borgbackup/APKBUILD b/community/borgbackup/APKBUILD
index 3ff9e41655..248f685c5a 100644
--- a/community/borgbackup/APKBUILD
+++ b/community/borgbackup/APKBUILD
@@ -8,7 +8,8 @@ url="https://borgbackup.readthedocs.io/"
 arch="all"
 license="BSD-3-Clause"
 depends="python3 py3-msgpack py3-zmq"
-makedepends="python3-dev lz4-dev acl-dev attr-dev libressl-dev linux-headers"
+makedepends="python3-dev lz4-dev acl-dev attr-dev libressl-dev linux-headers
+       py3-setuptools"
 source="https://github.com/$pkgname/borg/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
 
 build() {


Thanks!


> 
> diff --git a/community/borgbackup/APKBUILD b/community/borgbackup/APKBUILD
> index 21cbe60798..3ff9e41655 100644
> --- a/community/borgbackup/APKBUILD
> +++ b/community/borgbackup/APKBUILD
> @@ -1,16 +1,15 @@
>  # Contributor: Olivier Mauras <olivier@mauras.ch>
>  # Maintainer: Jakub Jirutka <jakub@jirutka.cz>
>  pkgname=borgbackup
> -pkgver=1.1.5
> -pkgrel=1
> +pkgver=1.1.6
> +pkgrel=0
>  pkgdesc="Deduplicating backup program"
>  url="https://borgbackup.readthedocs.io/"
>  arch="all"
>  license="BSD-3-Clause"
>  depends="python3 py3-msgpack py3-zmq"
>  makedepends="python3-dev lz4-dev acl-dev attr-dev libressl-dev linux-headers"
> -source="https://github.com/$pkgname/borg/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
> -	msgpack-fix.patch"
> +source="https://github.com/$pkgname/borg/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
>  
>  build() {
>  	cd "$builddir"
> @@ -26,5 +25,4 @@ package() {
>  	find . -name '*.h' -delete -o -name '*.c' -delete -o -name '*.pyx' -delete
>  }
>  
> -sha512sums="22071e4b37059d816592baff852772720769b3d86eb1d071abba67f9d13de809066aa29cdf18f1aaef127d1f24288913a7b0b63d157fb98840b1a71606dc0554  borgbackup-1.1.5.tar.gz
> -75cb9c8f3d75ab7ca716d4e0c92ad8097225f1bd5f0a5e8e8213099f56fd4d1ca57587427c20a0695ed154f962fe2a8a0950c7449e29ddf79f5f27aa8ff029dd  msgpack-fix.patch"
> +sha512sums="5741c48bdb70a26d40bd583f207460e35bb7dd560424889d37eb4d90ee96947457faf09bae0fa2b26b42ec71ef6eeaec1b770ba3257223a2637fcb55266e4a17  borgbackup-1.1.6.tar.gz"
> diff --git a/community/borgbackup/msgpack-fix.patch b/community/borgbackup/msgpack-fix.patch
> deleted file mode 100644
> index 67a44204c4..0000000000
> --- a/community/borgbackup/msgpack-fix.patch
> +++ /dev/null
> @@ -1,22 +0,0 @@
> ---- borgbackup-1.1.5/setup.py.orig
> -+++ borgbackup-1.1.5/setup.py
> -@@ -36,10 +36,15 @@
> - on_rtd = os.environ.get('READTHEDOCS')
> - 
> - install_requires = [
> --    # msgpack pure python data corruption was fixed in 0.4.6.
> --    # msgpack 0.5.0 was a bit of a troublemaker.
> --    # also, msgpack dropped py34 support at 0.5.0.
> --    'msgpack-python>=0.4.6,<0.5.0',
> -+    # we are rather picky about msgpack versions, because a good working msgpack is
> -+    # very important for borg, see https://github.com/borgbackup/borg/issues/3753
> -+    # best versions seem to be 0.4.6, 0.4.7, 0.4.8 and 0.5.6:
> -+    'msgpack-python >=0.4.6, <=0.5.6, !=0.5.0, !=0.5.1, !=0.5.2, !=0.5.3, !=0.5.4, !=0.5.5',
> -+    # if you can't satisfy the above requirement, these are versions that might
> -+    # also work ok, IF you make sure to use the COMPILED version of msgpack-python,
> -+    # NOT the PURE PYTHON fallback implementation: ==0.5.1, ==0.5.4
> -+    # using any other version is not supported by borg development, feel free to
> -+    # do it on your own risk (and after own testing).
> - ]
> - 
> - # note for package maintainers: if you package borgbackup for distribution,



---
Unsubscribe:  alpine-aports+unsubscribe@lists.alpinelinux.org
Help:         alpine-aports+help@lists.alpinelinux.org
---