Subject: [alpine-aports] [PATCH] testing/numlockx: new aport

From: Alex Raschi <[email-masked]>
Date: Wed, 8 Aug 2018 11:00:17 +0200

https://tracker.debian.org/pkg/numlockx
Enable NumLock in X11 sessions
---
 testing/numlockx/APKBUILD | 42 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
 create mode 100644 testing/numlockx/APKBUILD

diff --git a/testing/numlockx/APKBUILD b/testing/numlockx/APKBUILD
new file mode 100644
index 0000000000..f0431fa07e
--- /dev/null
+++ b/testing/numlockx/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Alex Raschi <[email-masked]>
+pkgname=numlockx
+pkgver=1.2
+_pkgver=7.1 # debian sub version
+pkgrel=0
+pkgdesc="Enable NumLock in X11 sessions"
+url="https://tracker.debian.org/pkg/numlockx"
+arch="all"
+license="MIT"
+depends=""
+makedepends="libx11-dev libxtst-dev"
+options="!check" # no test suite
+source="https://salsa.debian.org/debian/numlockx/-/archive/debian/$pkgver-$_pkgver/$pkgname-debian-$pkgver-$_pkgver.tar.gz"
+builddir="$srcdir/$pkgname-debian-$pkgver-$_pkgver"
+
+prepare() {
+	default_prepare
+	local patch=
+
+	for patch in improve-help get-state; do
+		patch < debian/patches/"$patch".patch
+	done
+}
+
+build() {
+	cd "$builddir"
+	./configure \
+		--build=$CBUILD \
+		--host=$CHOST \
+		--prefix=/usr \
+		--sysconfdir=/etc \
+		--mandir=/usr/share/man \
+		--localstatedir=/var
+	make
+}
+
+package() {
+	cd "$builddir"
+	make DESTDIR="$pkgdir" install
+}
+
+sha512sums="55cb3f334efb5de8d5f8b4b3d604f5f67aeeb3e3c6b9e2a3b1af99ada7aeb3d8440164628a8df68cd90fb66110669c586e7bf3809259ae4572446d5982159017  numlockx-debian-1.2-7.1.tar.gz"
-- 
2.18.0

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 4 Sep 2018 10:37:04 +0200

On Wed,  8 Aug 2018 11:00:17 +0200

> +++ b/testing/numlockx/APKBUILD

According the above URL, the upstream homepage is
http://home.kde.org/~seli/numlockx/ which is gone. So it looks like
this application is not longer maintained upstream?

Also Fedora points to a upstream homepage:
https://src.fedoraproject.org/cgit/rpms/numlockx.git/tree/numlockx.spec
http://ktown.kde.org/~seli/numlockx/

My question is, where do we send patches and bugreports upstream?

---

---

From: Alex Raschi <[email-masked]>
Date: Tue, 4 Sep 2018 13:13:15 +0000

Debian is a reliable source, i think reporting bugs to them is probably the
best option.
Plus debian includes some patches that other distros don't include like
with scrot package.

Arch, Void, Fedora and Freebsd haven't touched these packages for a while,
debian
at least shows some activity:
https://salsa.debian.org/debian/numlockx/commits/master

On Tue, Sep 4, 2018 at 8:37 AM Natanael Copa <[email-masked]> wrote:

> > +source="
> https://salsa.debian.org/debian/numlockx/-/archive/debian/$pkgver-$_pkgver/$pkgname-debian-$pkgver-$_pkgver.tar.gz
> "

---

From: "Milan P. Stanic" <[email-masked]>
Date: Tue, 4 Sep 2018 15:43:45 +0200

> Plus debian includes some patches that other distros don't include like

Right, I made weex apk for my use with the debian as the source, and
I'm thinking to use debian src as the source for other packages which I
build.
[...]

---

---

From: Alex Raschi <[email-masked]>
Date: Tue, 4 Sep 2018 15:14:29 +0200

https://tracker.debian.org/pkg/numlockx
Enable NumLock in X11 sessions
---
Changes v1 -> v2:
 - align to scrot APKBUILD

 testing/numlockx/APKBUILD | 46 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)
 create mode 100644 testing/numlockx/APKBUILD

diff --git a/testing/numlockx/APKBUILD b/testing/numlockx/APKBUILD
new file mode 100644
index 0000000000..773ed2a743
--- /dev/null
+++ b/testing/numlockx/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Alex Raschi <[email-masked]>
+pkgname=numlockx
+pkgver=1.2.7.1
+_opkgver=${pkgver%.*.*} # original version
+_dpkgver=${pkgver#*.*.} # debian sub version
+pkgrel=0
+pkgdesc="Enable NumLock in X11 sessions"
+url="https://tracker.debian.org/pkg/numlockx"
+arch="all"
+license="MIT"
+depends=""
+makedepends="libx11-dev libxtst-dev"
+options="!check" # no test suite
+source="http://ftp.debian.org/debian/pool/main/n/$pkgname/${pkgname}_$_opkgver.orig.tar.gz
+	http://ftp.debian.org/debian/pool/main/n/$pkgname/${pkgname}_$_opkgver-$_dpkgver.debian.tar.xz"
+builddir="$srcdir/$pkgname-$_opkgver"
+
+prepare() {
+	default_prepare
+	local patch=
+	local patches="$srcdir"/debian/patches
+
+	for patch in $(cat "$patches"/series); do
+		patch -p1 -d "$builddir" -i "$patches"/"$patch"
+	done
+}
+
+build() {
+	cd "$builddir"
+	./configure \
+		--build=$CBUILD \
+		--host=$CHOST \
+		--prefix=/usr \
+		--sysconfdir=/etc \
+		--mandir=/usr/share/man \
+		--localstatedir=/var
+	make
+}
+
+package() {
+	cd "$builddir"
+	make DESTDIR="$pkgdir" install
+}
+
+sha512sums="efaaa67e8b2723cb1e8461dde664f1f8e9b21f34edfe2e1135a6b756fa2843aed1a386f2f9d70bd62ddae9aedfeeff856a18da8b542f2cff440f93b38e5a853e  numlockx_1.2.orig.tar.gz
+e42a233881f0687d073d2a2c204ecb22f1216d3539888158623dc655bb4d85c17316d8f1ba51a86c50072e93e6ecdf33ce8c568b98b93344099ae78b32da26c7  numlockx_1.2-7.1.debian.tar.xz"
-- 
2.18.0

---