Subject: [alpine-aports] [PATCH] main/apr-util: re-add mysql support

From: Stefan Schwarz <[email-masked]>
Date: Thu, 4 Oct 2018 15:08:54 +0200

was removed in commit 3f7f81, builds without any issue
---
 main/apr-util/APKBUILD | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/main/apr-util/APKBUILD b/main/apr-util/APKBUILD
index e19783c316..98d72700f2 100644
--- a/main/apr-util/APKBUILD
+++ b/main/apr-util/APKBUILD
@@ -1,17 +1,17 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=apr-util
 pkgver=1.6.1
-pkgrel=2
+pkgrel=3
 pkgdesc="The Apache Portable Runtime Utility Library"
 url="http://apr.apache.org/"
 arch="all"
 license="Apache-2.0"
 depends=
-subpackages="$pkgname-dev $pkgname-dbm_db $pkgname-dbd_pgsql
+subpackages="$pkgname-dev $pkgname-dbm_db $pkgname-dbd_pgsql $pkgname-dbd_mysql
 	$pkgname-dbd_sqlite3 $pkgname-ldap"
 
 depends_dev="expat-dev apr-dev openldap-dev sqlite-dev postgresql-dev
-	db-dev libressl-dev"
+	db-dev libressl-dev mariadb-dev"
 makedepends="$depends_dev bash chrpath libressl"
 source="http://www.apache.org/dist/apr/$pkgname-$pkgver.tar.bz2"
 builddir="$srcdir/$pkgname-$pkgver"
@@ -25,6 +25,7 @@ build() {
 		--with-apr=/usr \
 		--with-ldap \
 		--with-pgsql \
+                --with-mysql \
 		--with-sqlite3 \
 		--with-berkeley-db \
 		--with-crypto \
@@ -46,6 +47,7 @@ _mv_mod() {
 	pkgdesc="The Apache Portable Runtime Utility Library - $2 driver"
 	depends=
 	local _moddir="usr/lib/apr-util-1"
+	ls "$pkgdir"/$_moddir
 	mkdir -p "$subpkgdir"/$_moddir
 	mv "$pkgdir"/$_moddir/apr_$1*.so "$subpkgdir"/$_moddir/
 }
-- 
2.19.0

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 4 Oct 2018 16:09:08 +0200

Hi,

Thank you for sending this. Please see comments below.

On Thu,  4 Oct 2018 15:08:54 +0200

> +++ b/main/apr-util/APKBUILD

Looks like space instead of tabs here.

>  	local _moddir="usr/lib/apr-util-1"

I suppose this is not needed either.

>  	mv "$pkgdir"/$_moddir/apr_$1*.so "$subpkgdir"/$_moddir/

I think I just commit and fix the two issues above.

Thank you!

-nc

---