Subject: [alpine-aports] [PATCH] testing/exa: new aport

From: Chloe Kudryavtsev <[email-masked]>
Date: Sun, 11 Nov 2018 00:38:08 -0500

Exa is an ls-like with no external dependencies and additonal features
such as:
- git awareness (for tree-like functionality + gitignore and git status)
- color-fronting filetype recognition
- listing of extended attributes
and more.
---
 testing/exa/APKBUILD | 68 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 68 insertions(+)
 create mode 100644 testing/exa/APKBUILD

diff --git a/testing/exa/APKBUILD b/testing/exa/APKBUILD
new file mode 100644
index 0000000000..97c5c87015
--- /dev/null
+++ b/testing/exa/APKBUILD
@@ -0,0 +1,68 @@
+# Contributor: Chloe Kudryavtsev <[email-masked]>
+# Maintainer: Chloe Kudryavtsev <[email-masked]>
+pkgname=exa
+pkgver=0.8.0
+pkgrel=0
+pkgdesc="A modern version of 'ls'"
+url="https://the.exa.website/"
+arch="all"
+license="MIT"
+depends=""
+makedepends="cargo cmake"
+install=""
+subpackages="
+	$pkgname-doc
+	$pkgname-bash-completion:bash:noarch
+	$pkgname-fish-completion:fish:noarch
+	$pkgname-zsh-completion:zsh:noarch
+	"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ogham/exa/archive/v$pkgver.tar.gz"
+builddir="$srcdir/exa-$pkgver"
+
+build() {
+	cd "$builddir"
+	export CARGO_HOME="$srcdir/cargo"
+	export RUSTFLAGS="-C target-feature=-crt-static"
+	cargo build \
+		--release \
+		--verbose
+}
+
+check() {
+	cd "$builddir"
+	export CARGO_HOME="$srcdir/cargo"
+	export RUSTFLAGS="-C target-feature=-crt-static"
+	cargo test --all \
+		--release \
+		--verbose
+}
+
+package() {
+	cd "$builddir"
+	install -m755 -D target/release/exa "$pkgdir/usr/bin/exa"
+	install -m644 -D contrib/man/exa.1 "$pkgdir/usr/share/man/man1/exa.1"
+
+	install -m644 -D contrib/completions.bash \
+		"$pkgdir/usr/share/bash-completions/completions/exa"
+	install -m644 -D contrib/completions.fish \
+		"$pkgdir/usr/share/fish/completions/exa.fish"
+	install -m644 -D contrib/completions.zsh \
+		"$pkgdir/usr/share/zsh/site-functions/_exa"
+}
+
+bash() {
+	mkdir -p "$subpkgdir/usr/share"
+	mv "$pkgdir/usr/share/bash-completions" "$subpkgdir/usr/share/"
+}
+
+fish() {
+	mkdir -p "$subpkgdir/usr/share"
+	mv "$pkgdir/usr/share/fish" "$subpkgdir/usr/share/"
+}
+
+zsh() {
+	mkdir -p "$subpkgdir/usr/share"
+	mv "$pkgdir/usr/share/zsh" "$subpkgdir/usr/share/"
+}
+
+sha512sums="5ac142f40af8408e03e7fa7b204216182ad696e44c1d044bd73d04957a638a8ed7295c15fc49279165b5dfb2d8b6a559847930de0e267f479cdab88fe9c49beb  exa-0.8.0.tar.gz"
-- 
2.19.1

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Leonardo Arena <[email-masked]>
Date: Tue, 5 Feb 2019 09:04:43 +0100

Hi,

sorry for the late feedback.

It fails build here with:

>>> exa: Unpacking /var/cache/distfiles/exa-0.8.0.tar.gz...
    Updating crates.io index
Segmentation fault
>>> ERROR: exa: build failed

Thanks

/eo

---

From: Chloe Kudryavtsev <[email-masked]>
Date: Tue, 12 Feb 2019 15:06:34 -0500

On 2/5/19 3:04 AM, Leonardo Arena wrote:
> Hi

Hi,

>      Updating crates.io <http://crates.io> index
> Segmentation fault
>  >>> ERROR: exa: build failed

This turned out to be a regression in libcurl 7.64.
It's fixed upstream, and there's a patch floating in patchwork to fix it 
in the meanwhile, if desired.
It should be gone in the next release.

However, some of these APKBUILDs (bat in particular) are already out of 
date.
I'll re-submit PRs over on github once I have *everything* in order.

---