Subject: [alpine-aports] [PATCH] main/py-faker: disable check on armhf

From: Drew DeVault <[email-masked]>
Date: Tue, 19 Mar 2019 08:14:57 -0600

---
 main/py-faker/APKBUILD | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/main/py-faker/APKBUILD b/main/py-faker/APKBUILD
index 9d58b1ab22..6101dd19e5 100644
--- a/main/py-faker/APKBUILD
+++ b/main/py-faker/APKBUILD
@@ -17,6 +17,13 @@ checkdepends="
 source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
 builddir=$srcdir/$_pkgname-$pkgver
 
+case $arch in
+	armhf)
+		# check is broken on armhf due to time_t issues
+		options="!check"
+		;;
+esac
+
 prepare() {
 	cd "$builddir"
 	# They erroneously require a specific version of pytest
-- 
2.21.0

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 19 Mar 2019 15:21:30 +0100

On Tue, 19 Mar 2019 08:14:57 -0600

>  	# They erroneously require a specific version of pytest

NACK. this was fixed in upstream in newer release.

Upstream issue: https://github.com/joke2k/faker/issues/912

Thanks!

-nc

---