Patches for aports can be sent to this list

[alpine-aports] [PATCH] main/irssi: upgrade to 1.2.0

Milan P. Stanić
Details
Message ID
<20190329144707.32436-1-mps@arvanta.net>
Sender timestamp
1553870827
DKIM signature
missing
Download raw message
Patch: +16 -29
upgrade to current stable
remove libressl-2.7.patch
add otr subpackage
enable true-color
---
 main/irssi/APKBUILD           | 23 ++++++++++++++++-------
 main/irssi/libressl-2.7.patch | 22 ----------------------
 2 files changed, 16 insertions(+), 29 deletions(-)
 delete mode 100644 main/irssi/libressl-2.7.patch

diff --git a/main/irssi/APKBUILD b/main/irssi/APKBUILD
index c845c3b064..0afc740a4e 100644
--- a/main/irssi/APKBUILD
+++ b/main/irssi/APKBUILD
@@ -1,15 +1,14 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=irssi
-pkgver=1.1.2
+pkgver=1.2.0
 pkgrel=0
 pkgdesc="Modular textUI IRC client with IPv6 support"
 url="https://irssi.org/"
 arch="all"
 license="GPL-2.0-or-later"
-makedepends="glib-dev openssl-dev ncurses-dev perl-dev automake autoconf libtool"
-subpackages="$pkgname-doc $pkgname-dev $pkgname-proxy $pkgname-perl"
+makedepends="glib-dev openssl-dev ncurses-dev perl-dev automake autoconf libtool libotr-dev"
+subpackages="$pkgname-doc $pkgname-dev $pkgname-proxy $pkgname-perl $pkgname-otr"
 source="https://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz
-	libressl-2.7.patch
 	"
 builddir="$srcdir"/$pkgname-$pkgver
 
@@ -50,7 +49,9 @@ build() {
 		--mandir=/usr/share/man \
 		--with-perl=module \
 		--with-perl-lib=vendor \
-		--with-proxy
+		--with-proxy \
+		--enable-true-color \
+		--with-otr=yes
 	make
 }
 
@@ -89,5 +90,13 @@ proxy() {
 	mv "$pkgdir"/usr/lib/irssi/modules/libirc_proxy.* "$subpkgdir"/usr/lib/irssi/modules/
 }
 
-sha512sums="706f811c810b976888101a29bab6ff6b9aa6116678994b3710d6b266bfbc0ae2be1d4fd889aedfbf0a13a2e3da3f1affcce0018346ecc582865eaccd8cc79f84  irssi-1.1.2.tar.xz
-6b5d987a9aeb189f3926272b37c631d04403832b495004779e8c23e9925a19349c7303927bab65b964ecb631fe7ac2394cf1c8e42ab69e300e30a121a95215ad  libressl-2.7.patch"
+otr() {
+	depends="$pkgname"
+	pkgdesc="Irssi module for enabling OTR functionality"
+	mkdir -p "$subpkgdir"/usr/lib/irssi/modules
+	mv "$pkgdir"/usr/lib/irssi/modules/libotr_core.* "$subpkgdir"/usr/lib/irssi/modules/
+	mkdir -p "$subpkgdir"/usr/share/irssi/help
+	mv "$pkgdir"/usr/share/irssi/help/otr "$subpkgdir"/usr/share/irssi/help/
+}
+
+sha512sums="343530ca63355dd6683e84f31602c9162e1e3158e52ce81e37519d1e42abbdcb621fb710fcb605fcafd7e7ea3f2c30ed62607d4ea91d8c8dc29bf893e54aee40  irssi-1.2.0.tar.xz"
diff --git a/main/irssi/libressl-2.7.patch b/main/irssi/libressl-2.7.patch
deleted file mode 100644
index f3705805f1..0000000000
--- a/main/irssi/libressl-2.7.patch
@@ -1,22 +0,0 @@
-diff --git a/src/core/network-openssl.c b/src/core/network-openssl.c
-index 9fddf07..e6de608 100644
---- a/src/core/network-openssl.c
-+++ b/src/core/network-openssl.c
-@@ -35,7 +35,7 @@
- #include <openssl/err.h>
- 
- /* OpenSSL 1.1.0 introduced some backward-incompatible changes to the api */
--#if (OPENSSL_VERSION_NUMBER >= 0x10100000L) && !defined(LIBRESSL_VERSION_NUMBER)
-+#if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
- /* The two functions below could be already defined if OPENSSL_API_COMPAT is
-  * below the 1.1.0 version so let's do a clean start */
- #undef  X509_get_notBefore
-@@ -47,7 +47,7 @@
- 
- /* OpenSSL 1.1.0 also introduced some useful additions to the api */
- #if (OPENSSL_VERSION_NUMBER >= 0x10002000L)
--#if (OPENSSL_VERSION_NUMBER < 0x10100000L) || defined (LIBRESSL_VERSION_NUMBER)
-+#if (OPENSSL_VERSION_NUMBER < 0x10100000L)
- static int X509_STORE_up_ref(X509_STORE *vfy)
- {
-     int n;
-- 
2.20.1



---
Unsubscribe:  alpine-aports+unsubscribe@lists.alpinelinux.org
Help:         alpine-aports+help@lists.alpinelinux.org
---