Subject: [alpine-aports] [PATCH] testing/mdbook: new APKBUILD

From: Drew DeVault <[email-masked]>
Date: Sun, 31 Mar 2019 18:22:26 -0600

---
 testing/mdbook/APKBUILD | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)
 create mode 100644 testing/mdbook/APKBUILD

diff --git a/testing/mdbook/APKBUILD b/testing/mdbook/APKBUILD
new file mode 100644
index 0000000000..0fce856e1c
--- /dev/null
+++ b/testing/mdbook/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Drew DeVault <[email-masked]>
+pkgname=mdbook
+pkgver=0.2.3
+pkgrel=0
+pkgdesc="mdBook is a utility to create modern online books from Markdown files"
+url="https://rust-lang-nursery.github.io/mdBook"
+arch="all"
+license="MPL-2.0"
+depends=""
+makedepends="rust cargo"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rust-lang-nursery/mdBook/archive/v$pkgver.tar.gz"
+builddir="$srcdir/mdBook-$pkgver"
+export CARGO_HOME="$srcdir"/cargo
+export RUSTFLAGS="-C target-feature=-crt-static"
+
+build() {
+	cd "$builddir"
+	cargo build --release --verbose
+}
+
+check() {
+	cd "$builddir"
+	cargo test --all --release --verbose
+}
+
+package() {
+	cd "$builddir"
+	install -Dm755 target/release/mdbook "$pkgdir"/usr/bin/mdbook
+}
+
+sha512sums="4d339a8f51dd5e80950b0b40ba95225828d3a698ebacef1dd7de0e6771fb74111e821c1b384b334c23d54e8a21ccc14fbefe34081a4e25ecdb2823d42c9ca9b0  mdbook-0.2.3.tar.gz"
-- 
2.21.0

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Leonardo <[email-masked]>
Date: Wed, 3 Apr 2019 15:05:59 +0200

Hi,

>   create mode 100644 testing/mdbook/APKBUILD

it segfaults for me:

     Updating crates.io index
Segmentation fault
 >>> ERROR: mdbook: build failed

Also arch must be restricted to "x86_64" due to rust.

Thanks!

/eo

---

---

From: Drew DeVault <[email-masked]>
Date: Thu, 4 Apr 2019 10:09:01 -0400

---
This addressed the arch issue, but I'm unable to reproduce the cargo
segfault when I build this on my machine.

index 0000000000..1cb9e1ecd8
+arch="x86_64"

---

---

From: Leonardo <[email-masked]>
Date: Fri, 5 Apr 2019 14:33:58 +0200

Hi,

> segfault when I build this on my machine.

pushed as-is and it went through on the builders.

Thanks!

/eo

---