Subject: [alpine-aports] [PATCH 0/9] Miscellaneous Python adoptions & updates

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 15:09:45 -0400

Drew DeVault (9):
  main/py-asn1: adopt
  main/py-freezegun: new APKBUILD
  py-dateutil: adopt, upgrade to 2.8.0
  community/py-distutils-extra: adopt
  main/py-pluggy: update to 0.9.0
  testing/py-pyphen: adopt
  main/py-requests: adopt
  main/py-six: adopt
  community/py-sqlalchemy: adopt, update to 1.3.2

 community/py-distutils-extra/APKBUILD |  3 +-
 community/py-sqlalchemy/APKBUILD      |  7 ++--
 main/py-asn1/APKBUILD                 |  2 +-
 main/py-dateutil/APKBUILD             | 54 ++++++++++++++----------
 main/py-freezegun/APKBUILD            | 60 +++++++++++++++++++++++++++
 main/py-pluggy/APKBUILD               |  4 +-
 main/py-requests/APKBUILD             |  2 +-
 main/py-six/APKBUILD                  |  3 +-
 testing/py-pyphen/APKBUILD            |  3 +-
 9 files changed, 103 insertions(+), 35 deletions(-)
 create mode 100644 main/py-freezegun/APKBUILD

-- 
2.21.0

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 15:09:51 -0400

---
 testing/py-pyphen/APKBUILD | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/testing/py-pyphen/APKBUILD b/testing/py-pyphen/APKBUILD
index ed797e8982..a86428efe5 100644
--- a/testing/py-pyphen/APKBUILD
+++ b/testing/py-pyphen/APKBUILD
@@ -1,6 +1,5 @@
-# Contributor: 
 # Contributor: Stefan Wagner <[email-masked]>
-# Maintainer: 
+# Maintainer: Drew DeVault <[email-masked]>
 pkgname=py-pyphen
 _pkgname=Pyphen
 pkgver=0.9.5
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 15:09:48 -0400

---
 main/py-dateutil/APKBUILD | 54 ++++++++++++++++++++++++---------------
 1 file changed, 33 insertions(+), 21 deletions(-)

diff --git a/main/py-dateutil/APKBUILD b/main/py-dateutil/APKBUILD
index 813966756b..32a83e4671 100644
--- a/main/py-dateutil/APKBUILD
+++ b/main/py-dateutil/APKBUILD
@@ -1,23 +1,38 @@
-# Contributor: 
-# Maintainer: 
+# Maintainer: Drew DeVault <[email-masked]>
 pkgname=py-dateutil
-_pkgname=python-dateutil
-pkgver=2.7.3
+_pyname=python-dateutil
+pkgver=2.8.0
 pkgrel=0
 pkgdesc="Python extensions for datetime module"
 url="https://dateutil.readthedocs.io"
 arch="noarch"
-license="BSD"
-depends="py-six"
+license="Apache-2.0"
+depends="py2-six py3-six"
 makedepends="python2-dev python3-dev py-setuptools"
+checkdepends="
+	pytest py3-pytest py2-hypothesis py3-hypothesis py2-freezegun py3-freezegun
+"
 subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgname-$pkgver"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+prepare() {
+	cp -r "$builddir" "$builddir"-py2
+}
 
 build() {
 	cd "$builddir"
-	python2 setup.py build || return 1
-	python3 setup.py build || return 1
+	python3 setup.py build
+	cd "$builddir"-py2
+	python2 setup.py build
+}
+
+check() {
+	cd "$builddir"
+	pytest-3
+	cd "$builddir"-py2
+	pytest-2
 }
 
 package() {
@@ -25,24 +40,21 @@ package() {
 }
 
 _py2() {
-	replaces="$pkgname"
-	depends="${depends//py-/py2-}"
+	cd "$builddir"-py2
 	_py python2
 }
 
 _py3() {
-	depends="${depends//py-/py3-}"
+	cd "$builddir"
 	_py python3
 }
 
 _py() {
-	local python="$1"
-	pkgdesc="$pkgdesc (for $python)"
-	depends="$depends $python"
-	install_if="$pkgname=$pkgver-r$pkgrel $python"
-
-	cd "$builddir"
-	$python setup.py install --prefix=/usr --root="$subpkgdir"
+	_python="$1"
+	pkgdesc="$pkgdesc (for $_python)"
+	depends="$depends $_python"
+	install_if="$pkgname=$pkgver-r$pkgrel $_python"
+	$_python setup.py install --prefix=/usr --root="$subpkgdir"
 }
 
-sha512sums="6b9973fa7db69d931bc6e772201c67bb7bbfa693ba35484d34960bd7e6227f2a2343df814a9fdbbff253e750299c48e7cdb2a609bf4522595df8a7fc595784fd  python-dateutil-2.7.3.tar.gz"
+sha512sums="ec7da86203572582f883a4686acf8a732a2de4f396d809057eb51b2c60dbca5623a7fa90c2c0618c281a2282c60841739bd837731a51cc876f4ff369297f2f81  python-dateutil-2.8.0.tar.gz"
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 15:09:47 -0400

---
 main/py-freezegun/APKBUILD | 60 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 60 insertions(+)
 create mode 100644 main/py-freezegun/APKBUILD

diff --git a/main/py-freezegun/APKBUILD b/main/py-freezegun/APKBUILD
new file mode 100644
index 0000000000..27ba843ae7
--- /dev/null
+++ b/main/py-freezegun/APKBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Drew DeVault <[email-masked]>
+pkgname=py-freezegun
+_pyname=freezegun
+pkgver=0.3.11
+pkgrel=0
+pkgdesc="Let your Python tests travel through time"
+url="https://github.com/spulec/freezegun"
+arch="noarch"
+license="Apache-2.0"
+depends="py2-six py3-six py-dateutil"
+makedepends="python2-dev python3-dev py-setuptools"
+checkdepends="
+	pytest py3-pytest py2-mock py3-mock py2-nose py3-nose
+"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+prepare() {
+	cp -r "$builddir" "$builddir"-py2
+}
+
+build() {
+	cd "$builddir"
+	python3 setup.py build
+	cd "$builddir"-py2
+	python2 setup.py build
+}
+
+check() {
+	cd "$builddir"
+	pytest-3
+	cd "$builddir"-py2
+	pytest-2
+}
+
+package() {
+	mkdir -p "$pkgdir"
+}
+
+_py2() {
+	cd "$builddir"-py2
+	_py python2
+}
+
+_py3() {
+	cd "$builddir"
+	_py python3
+}
+
+_py() {
+	_python="$1"
+	pkgdesc="$pkgdesc (for $_python)"
+	depends="$depends $_python"
+	install_if="$pkgname=$pkgver-r$pkgrel $_python"
+	$_python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="e8b392176641d52f6ed795c9af5fbc0a62892aeedf32b42375b56ab44a9ad7a5ecd3bb81363ed0ae65204aff2ef894cd7f2e17f42be72f31d3409b2bffa59ab8  freezegun-0.3.11.tar.gz"
-- 
2.21.0

---

---

From: Natanael Copa <[email-masked]>
Date: Wed, 3 Apr 2019 21:21:01 +0200

On Wed,  3 Apr 2019 15:09:47 -0400

> index 0000000000..27ba843ae7

...

> +depends="py2-six py3-six py-dateutil"

...

> +	depends="$depends $_python"

this means that py2-freezegun will depend on py3-six and py3-freezegun
will depend on py2-six. Is that intentional?

-nc

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 15:22:32 -0400

> will depend on py2-six. Is that intentional?

A bootstrap build will require disabling check on py-six to avoid
circular dependencies. Let me add that...

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 15:09:49 -0400

---
 community/py-distutils-extra/APKBUILD | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/community/py-distutils-extra/APKBUILD b/community/py-distutils-extra/APKBUILD
index 35b7b7a4c4..f1026cde6a 100644
--- a/community/py-distutils-extra/APKBUILD
+++ b/community/py-distutils-extra/APKBUILD
@@ -1,5 +1,4 @@
-# Contributor: 
-# Maintainer: 
+# Maintainer: Drew DeVault <[email-masked]>
 pkgname=py-distutils-extra
 _pkgname=python-distutils-extra
 pkgver=2.39
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 15:09:46 -0400

---
 main/py-asn1/APKBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/main/py-asn1/APKBUILD b/main/py-asn1/APKBUILD
index de3fb86053..ece1846cbf 100644
--- a/main/py-asn1/APKBUILD
+++ b/main/py-asn1/APKBUILD
@@ -1,5 +1,5 @@
 # Contributor: Peter Bui <[email-masked]>
-# Maintainer: 
+# Maintainer: Drew DeVault <[email-masked]>
 pkgname=py-asn1
 _pkgname=pyasn1
 pkgver=0.4.5
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 15:09:50 -0400

---
 main/py-pluggy/APKBUILD | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/main/py-pluggy/APKBUILD b/main/py-pluggy/APKBUILD
index 00af015971..55d35841a5 100644
--- a/main/py-pluggy/APKBUILD
+++ b/main/py-pluggy/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Stuart Cardall <[email-masked]>
 pkgname=py-pluggy
 _pkgname=${pkgname#py-*}
-pkgver=0.7.1
+pkgver=0.9.0
 pkgrel=0
 pkgdesc="Plugin management and hook calling for Python"
 url="https://pluggy.readthedocs.io/en/latest/"
@@ -50,4 +50,4 @@ check() {
 	tox
 }
 
-sha512sums="e19f6c1b3f2e711df1c8b075a2b802751afd218f1b692f08b2434c01d71c402331ff8c937550fbdfece2098f6d6856422d485f193e188916b365ded2e4087697  pluggy-0.7.1.tar.gz"
+sha512sums="377d201393b11afbbe7dcce6053a4200782e4d2017252a4dee3859a5cf3eb21534ebd6ac7c9fd518b5eff441009b1b5791c8fc86e59385b7eddfc9dbc103eb33  pluggy-0.9.0.tar.gz"
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 15:09:53 -0400

---
 main/py-six/APKBUILD | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/main/py-six/APKBUILD b/main/py-six/APKBUILD
index 1c9b5d097d..75ed8129b5 100644
--- a/main/py-six/APKBUILD
+++ b/main/py-six/APKBUILD
@@ -1,5 +1,4 @@
-# Contributor: 
-# Maintainer: 
+# Maintainer: Drew DeVault <[email-masked]>
 pkgname=py-six
 _pkgname=six
 pkgver=1.12.0
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 15:09:52 -0400

---

diff --git a/main/py-requests/APKBUILD b/main/py-requests/APKBUILD
index 7256d9b53f..badfded370 100644
--- a/main/py-requests/APKBUILD
+++ b/main/py-requests/APKBUILD
@@ -1,5 +1,5 @@
 # Contributor: Peter Bui <[email-masked]>
-# Maintainer: 
+# Maintainer: Drew DeVault <[email-masked]>
 pkgname=py-requests
 _pkgname=requests
 pkgver=2.21.0
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 15:09:54 -0400

---
 community/py-sqlalchemy/APKBUILD | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/community/py-sqlalchemy/APKBUILD b/community/py-sqlalchemy/APKBUILD
index 964b36a6de..bf5bf85afb 100644
--- a/community/py-sqlalchemy/APKBUILD
+++ b/community/py-sqlalchemy/APKBUILD
@@ -1,9 +1,8 @@
-# Contributor: 
 # Contributor: Drew DeVault <[email-masked]>
-# Maintainer: 
+# Maintainer: Drew DeVault <[email-masked]>
 pkgname=py-sqlalchemy
 _pkgname=SQLAlchemy
-pkgver=1.3.1
+pkgver=1.3.2
 pkgrel=0
 pkgdesc="An object relational mapper for Python"
 url="https://pypi.python.org/pypi/SQLAlchemy"
@@ -57,4 +56,4 @@ _py() {
 	$python setup.py install --prefix=/usr --root="$subpkgdir"
 }
 
-sha512sums="a5f9506060cce7c688be5d0b25c5a34a904a64e07447e11d9a2e546c1020849038f370f5808d817f192ec36d6df7443ad328145be1af2baaad3913dab6b4cb8d  SQLAlchemy-1.3.1.tar.gz"
+sha512sums="fbbcff21e722a26a914d701cce430fcc5dac503fffb65e385e86754f39b585b5a4c6b4914533bc4adfe48269130e9b5c1c8c539aa60481c721c2ce7cfedca1bf  SQLAlchemy-1.3.2.tar.gz"
-- 
2.21.0

---