Subject: [alpine-aports] [PATCH 00/12] Adopt & upgrade celery

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 16:27:03 -0400

Drew DeVault (12):
  main/py-redis: adopt, update to 3.2.1
  testing/py-serpent: new APKBUILD
  testing/py-pyro4: new APKBUILD
  testing/py-case: new APKBUILD
  testing/py-billiard: adopt, upgrade to 3.6.0.0
  testing/py-hypothesis: update to 4.14.3
  main/py-hypothesis: move from testing
  py-hypothesis: adopt, normalize APKBUILD
  testing/py-amqp: adopt, update to 2.4.2
  testing/py-amqp: normalize APKBUILD
  testing/py-kombu: adopt, update to 4.5.0
  testing/celery: adopt; update to 4.3.0

 main/py-hypothesis/APKBUILD    | 62 ++++++++++++++++++++++++++++++
 main/py-redis/APKBUILD         | 64 +++++++++++++++++++------------
 main/py-redis/redis.conf       | 11 ++++++
 testing/celery/APKBUILD        | 11 +++---
 testing/py-amqp/APKBUILD       | 64 +++++++++++++++++++------------
 testing/py-billiard/APKBUILD   | 10 ++---
 testing/py-case/APKBUILD       | 59 +++++++++++++++++++++++++++++
 testing/py-hypothesis/APKBUILD | 47 -----------------------
 testing/py-kombu/APKBUILD      | 69 ++++++++++++++++++++++------------
 testing/py-pyro4/APKBUILD      | 60 +++++++++++++++++++++++++++++
 testing/py-serpent/APKBUILD    | 57 ++++++++++++++++++++++++++++
 11 files changed, 385 insertions(+), 129 deletions(-)
 create mode 100644 main/py-hypothesis/APKBUILD
 create mode 100644 main/py-redis/redis.conf
 create mode 100644 testing/py-case/APKBUILD
 delete mode 100644 testing/py-hypothesis/APKBUILD
 create mode 100644 testing/py-pyro4/APKBUILD
 create mode 100644 testing/py-serpent/APKBUILD

-- 
2.21.0

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 16:27:10 -0400

---
 {testing => main}/py-hypothesis/APKBUILD | 0
 1 file changed, 0 insertions(+), 0 deletions(-)
 rename {testing => main}/py-hypothesis/APKBUILD (100%)

diff --git a/testing/py-hypothesis/APKBUILD b/main/py-hypothesis/APKBUILD
similarity index 100%
rename from testing/py-hypothesis/APKBUILD
rename to main/py-hypothesis/APKBUILD
-- 
2.21.0

---

---

From: Leonardo <[email-masked]>
Date: Fri, 5 Apr 2019 14:03:43 +0200

Hi,

> rename to main/py-hypothesis/APKBUILD

I think I'm missing something here. I can't find any package in main 
which depends on it. Is there some upcoming patch that needs it?

Thanks

/eo

---

---

From: Drew DeVault <[email-masked]>
Date: Fri, 5 Apr 2019 11:22:52 -0400

On 2019-04-05  2:03 PM, Leonardo wrote:
> I think I'm missing something here. I can't find any package in main which
> depends on it. Is there some upcoming patch that needs it?

py-dateutil. This was discussed here:

https://patchwork.alpinelinux.org/patch/4735/

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 16:27:04 -0400

*** BLURB HERE ***
>From 71e82404a5444df72eb1d5db6f4435319ffd2232 Mon Sep 17 00:00:00 2001
From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 14:09:30 -0400
Subject: [PATCH 01/12] main/py-redis: adopt, update to 3.2.1

---
 main/py-redis/APKBUILD   | 64 +++++++++++++++++++++++++---------------
 main/py-redis/redis.conf | 11 +++++++
 2 files changed, 51 insertions(+), 24 deletions(-)
 create mode 100644 main/py-redis/redis.conf

diff --git a/main/py-redis/APKBUILD b/main/py-redis/APKBUILD
index 28e99c683b..6ce586a33d 100644
--- a/main/py-redis/APKBUILD
+++ b/main/py-redis/APKBUILD
@@ -1,49 +1,65 @@
-# Maintainer:
+# Maintainer: Drew DeVault <[email-masked]>
 pkgname=py-redis
-_pkgname=${pkgname#py-}
-pkgver=2.10.6
+_pyname=redis
+pkgver=3.2.1
 pkgrel=0
 pkgdesc="Python client for Redis key-value store"
 url="https://github.com/andymccurdy/redis-py"
 arch="noarch"
 license="MIT"
-depends=""
-depends_dev=""
-makedepends="python2-dev python3-dev py-setuptools"
-install=""
-subpackages="py2-redis:py2 py3-redis:py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+makedepends="python2 python3 py2-setuptools py3-setuptools"
+checkdepends="redis py2-mock py3-mock pytest py3-pytest"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="
+	https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz
+	redis.conf
+"
+builddir=$srcdir/$_pyname-$pkgver
 
-builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+	cp -r "$builddir" "$builddir"-py2
+}
 
 build() {
 	cd "$builddir"
-	python2 setup.py build
 	python3 setup.py build
+	cd "$builddir"-py2
+	python2 setup.py build
 }
 
-_py() {
-        local python="$1"
-        pkgdesc="$pkgdesc ${python#python}"
-        depends="$depends $python"
-        install_if="$pkgname=$pkgver-r$pkgrel $python"
-
-        cd "$builddir"
-        $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
+check() (
+	cd "$srcdir"
+	redis-server redis.conf &
+	redis_pid=$!
+	trap "kill -9 $redis_pid" EXIT
+	cd "$builddir"
+	pytest-3
+	cd "$builddir"-py2
+	pytest-2
+)
 
 package() {
 	mkdir -p "$pkgdir"
 }
 
-py2() {
-	cd "$builddir"
+_py2() {
+	cd "$builddir"-py2
 	_py python2
 }
 
-py3() {
+_py3() {
 	cd "$builddir"
 	_py python3
 }
 
-sha512sums="e7df464bc3b26e23f6a0d2d2896306c1e4792b9a2a4ecaea6dd8690ffa17853cc85345f063307295dd3c2da399f7f203f4b21d785f7e073c0501732257419dad  redis-2.10.6.tar.gz"
+_py() {
+	_python="$1"
+	pkgdesc="$pkgdesc (for $_python)"
+	depends="$depends $_python"
+	install_if="$pkgname=$pkgver-r$pkgrel $_python"
+	$_python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="be51642a8895325c3c61993dd83c3299a9e2cefc1010e04f182833f720ff161bea43d3a57d28afba991949fcf6e967c4f778002967641bffe651d5db384f2e08  redis-3.2.1.tar.gz
+ef0d86a0dbd0dd80e4c66c962d0b03764f0298f8b94bebd644d40f0c219167b576adf8a133605bf6e976298e702e14eef7f9aaf3a56c8dcda62c678599ea1f21  redis.conf"
diff --git a/main/py-redis/redis.conf b/main/py-redis/redis.conf
new file mode 100644
index 0000000000..c7eec89a5b
--- /dev/null
+++ b/main/py-redis/redis.conf
@@ -0,0 +1,11 @@
+bind 127.0.0.1
+protected-mode yes
+port 6379
+tcp-backlog 511
+timeout 0
+tcp-keepalive 300
+supervised no
+loglevel notice
+logfile /dev/null
+databases 16
+always-show-logo no
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 16:27:05 -0400

---
 testing/py-serpent/APKBUILD | 57 +++++++++++++++++++++++++++++++++++++
 1 file changed, 57 insertions(+)
 create mode 100644 testing/py-serpent/APKBUILD

diff --git a/testing/py-serpent/APKBUILD b/testing/py-serpent/APKBUILD
new file mode 100644
index 0000000000..75992f8012
--- /dev/null
+++ b/testing/py-serpent/APKBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Drew DeVault <[email-masked]>
+pkgname=py-serpent
+_pyname=serpent
+pkgver=1.28
+pkgrel=0
+pkgdesc="Serialization based on ast.literal_eval for Python"
+url="https://pypi.org/project/serpent/"
+arch="noarch"
+license="MIT"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+makedepends="python2 python3 py2-setuptools py3-setuptools"
+checkdepends="py2-attrs py3-attrs py2-tz py3-tz"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir=$srcdir/$_pyname-$pkgver
+
+prepare() {
+	cp -r "$builddir" "$builddir"-py2
+}
+
+build() {
+	cd "$builddir"
+	python3 setup.py build
+	cd "$builddir"-py2
+	python2 setup.py build
+}
+
+check() {
+	cd "$builddir"
+	python3 setup.py test
+	cd "$builddir"-py2
+	python2 setup.py test
+}
+
+package() {
+	mkdir -p "$pkgdir"
+}
+
+_py2() {
+	cd "$builddir"-py2
+	_py python2
+}
+
+_py3() {
+	cd "$builddir"
+	_py python3
+}
+
+_py() {
+	_python="$1"
+	pkgdesc="$pkgdesc (for $_python)"
+	depends="$depends $_python"
+	install_if="$pkgname=$pkgver-r$pkgrel $_python"
+	$_python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="776bc497c7cd815c4ef44107bdf53b62bb92229beba0be7efceb9fba57dc7c677bf09832db335485df3e466acdffe6ebf4b3636ae9b49e60075379a7419a29ad  serpent-1.28.tar.gz"
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 16:27:06 -0400

---
 testing/py-pyro4/APKBUILD | 60 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 60 insertions(+)
 create mode 100644 testing/py-pyro4/APKBUILD

diff --git a/testing/py-pyro4/APKBUILD b/testing/py-pyro4/APKBUILD
new file mode 100644
index 0000000000..1eda79ead8
--- /dev/null
+++ b/testing/py-pyro4/APKBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Drew DeVault <[email-masked]>
+pkgname=py-pyro4
+_pyname=Pyro4
+pkgver=4.75
+pkgrel=0
+pkgdesc="Python remote objects"
+url="http://pyro4.readthedocs.io/"
+arch="noarch"
+license="MIT"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+_py2_deps="py2-serpent"
+_py3_deps="py3-serpent"
+makedepends="$_py2_deps $_py3_deps python2 python3 py2-setuptools py3-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir=$srcdir/$_pyname-$pkgver
+
+prepare() {
+	cp -r "$builddir" "$builddir"-py2
+}
+
+build() {
+	cd "$builddir"
+	python3 setup.py build
+	cd "$builddir"-py2
+	python2 setup.py build
+}
+
+check() {
+	cd "$builddir"
+	python3 setup.py test
+	cd "$builddir"-py2
+	python2 setup.py test
+}
+
+package() {
+	mkdir -p "$pkgdir"
+}
+
+_py2() {
+	depends="$_py2_deps"
+	cd "$builddir"-py2
+	_py python2
+}
+
+_py3() {
+	depends="$_py3_deps"
+	cd "$builddir"
+	_py python3
+}
+
+_py() {
+	_python="$1"
+	pkgdesc="$pkgdesc (for $_python)"
+	depends="$depends $_python"
+	install_if="$pkgname=$pkgver-r$pkgrel $_python"
+	$_python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="ecbf514ad6c877eb3166cad2ec70e16b148995a93562d737e17a8f0e222c647dd352271c383c7ba3cdf41e4678f81af34a761e9e3a74ba2dc4984dc86c158b0f  Pyro4-4.75.tar.gz"
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 16:27:07 -0400

---
 testing/py-case/APKBUILD | 59 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 59 insertions(+)
 create mode 100644 testing/py-case/APKBUILD

diff --git a/testing/py-case/APKBUILD b/testing/py-case/APKBUILD
new file mode 100644
index 0000000000..ab206b9812
--- /dev/null
+++ b/testing/py-case/APKBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Drew DeVault <[email-masked]>
+pkgname=py-case
+_pyname=case
+pkgver=1.5.0
+pkgrel=0
+pkgdesc="Python unittest utilities"
+url="https://github.com/celery/case/"
+arch="noarch"
+license="BSD"
+makedepends="python2-dev python3-dev py2-setuptools py3-setuptools"
+checkdepends="
+	py2-coverage py3-coverage py2-mock py3-mock py2-nose py3-nose py2-unittest2
+"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+prepare() {
+	cd "$builddir"
+	cp -r "$builddir" "$builddir"-py2
+}
+
+build() {
+	cd "$builddir"
+	python3 setup.py build
+	cd "$builddir"-py2
+	python2 setup.py build
+}
+
+check() {
+	cd "$builddir"
+	python3 setup.py test
+	cd "$builddir"-py2
+	python2 setup.py test
+}
+
+package() {
+	mkdir -p "$pkgdir"
+}
+
+_py2() {
+	cd "$builddir"-py2
+	_py python2
+}
+
+_py3() {
+	cd "$builddir"
+	_py python3
+}
+
+_py() {
+	_python="$1"
+	pkgdesc="$pkgdesc (for $_python)"
+	depends="$depends $_python"
+	install_if="$pkgname=$pkgver-r$pkgrel $_python"
+	$_python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+sha512sums="0ae03ab175903bc55a81df9c1847587960bec64202be66702456b447c3114d8a9b49fa7bfa08cb032040bc2c1f17411642392abee617e4400fae0a9b67d38702  case-1.5.0.tar.gz"
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 16:27:08 -0400

---
 testing/py-billiard/APKBUILD | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)

diff --git a/testing/py-billiard/APKBUILD b/testing/py-billiard/APKBUILD
index 4e27cf5a4b..ca382d3414 100644
--- a/testing/py-billiard/APKBUILD
+++ b/testing/py-billiard/APKBUILD
@@ -1,14 +1,12 @@
-# Maintainer: 
+# Maintainer: Drew DeVault <[email-masked]>
 pkgname=py-billiard
-pkgver=3.5.0.3
+pkgver=3.6.0.0
 pkgrel=0
 pkgdesc="a message queue abstraction layer"
 url="https://pypi.python.org/pypi/billiard/"
 arch="all"
 license="BSD"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools"
-install=""
+makedepends="python2-dev python3-dev py2-setuptools py3-setuptools"
 subpackages="py2-billiard:py2 py3-billiard:py3"
 source="https://files.pythonhosted.org/packages/source/b/billiard/billiard-$pkgver.tar.gz"
 builddir="$srcdir/billiard-$pkgver"
@@ -43,4 +41,4 @@ py3() {
 	_py python3
 }
 
-sha512sums="f3a98e9b7af8c0b5741bcea915c0ff8d6e32e26d79637d14fc09ea85dd80693ea8205e13ac2d86e5035c377fdd6d769a2647b005dc10af8b106c75464458a808  billiard-3.5.0.3.tar.gz"
+sha512sums="0a71de026d2a781b83fe2c549ecbfe9b6fbd574d8067fc46ba7eca6b76633a123620853d22696df3563d050043cfe75b14b4b69bf5217e0af964aaa0bcbe08ff  billiard-3.6.0.0.tar.gz"
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 16:27:09 -0400

---
 testing/py-hypothesis/APKBUILD | 20 ++++++++++++--------
 1 file changed, 12 insertions(+), 8 deletions(-)

diff --git a/testing/py-hypothesis/APKBUILD b/testing/py-hypothesis/APKBUILD
index c87eeecf64..783aaab202 100644
--- a/testing/py-hypothesis/APKBUILD
+++ b/testing/py-hypothesis/APKBUILD
@@ -1,17 +1,21 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=py-hypothesis
-pkgver=3.38.0
-pkgrel=1
+pkgver=4.14.3
+pkgrel=0
 pkgdesc="Advanced property-based (QuickCheck-like) testing for Python"
 url="http://hypothesis.works/"
 arch="noarch"
 license="MPL-2.0"
-depends=""
-makedepends="py-setuptools python2-dev python3-dev py-enum34"
-install=""
+depends="py-coverage"
+_py2_deps="py2-coverage"
+_py3_deps="py3-coverage"
+makedepends="
+	$_py2_deps $_py3_deps python2-dev python3-dev py2-setuptools py3-setuptools
+	py-enum34
+"
 subpackages="py2-hypothesis:_py py3-hypothesis:_py"
-source="py-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/$pkgver.tar.gz"
-builddir="$srcdir/hypothesis-python-$pkgver"
+source="py-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/hypothesis-python-$pkgver.tar.gz"
+builddir="$srcdir/hypothesis-hypothesis-python-$pkgver/hypothesis-python"
 
 build() {
 	cd "$builddir"
@@ -44,4 +48,4 @@ _py() {
 	mv "$pkgdir"/usr/lib/${python}* "$subpkgdir"/usr/lib/
 }
 
-sha512sums="9001b045013f720885e53649c9445ac12c149e609b2532fc52ed2b4743aad59a2a59d6775988f65a23b58983a726849d75c368d291662c4b1d62e5d769efe88e  py-hypothesis-3.38.0.tar.gz"
+sha512sums="56f0a796741b1a46bfe91e578dc76067b612d0041dd8b93043521c8e53827a5bcdd815f94e91d22d4ae9d13125bfb9012cb1c4660635e7cc93472141be504efb  py-hypothesis-4.14.3.tar.gz"
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 16:27:11 -0400

Note that the old APKBUILD did not actually run any tests, but the fixed
check() runs into tests which appear to be broken upstream.
---
 main/py-hypothesis/APKBUILD | 47 +++++++++++++++++++++++--------------
 1 file changed, 29 insertions(+), 18 deletions(-)

diff --git a/main/py-hypothesis/APKBUILD b/main/py-hypothesis/APKBUILD
index 783aaab202..06adfb4eab 100644
--- a/main/py-hypothesis/APKBUILD
+++ b/main/py-hypothesis/APKBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Natanael Copa <[email-masked]>
+# Maintainer: Drew DeVault <[email-masked]>
 pkgname=py-hypothesis
 pkgver=4.14.3
 pkgrel=0
@@ -6,46 +6,57 @@ pkgdesc="Advanced property-based (QuickCheck-like) testing for Python"
 url="http://hypothesis.works/"
 arch="noarch"
 license="MPL-2.0"
-depends="py-coverage"
 _py2_deps="py2-coverage"
 _py3_deps="py3-coverage"
 makedepends="
 	$_py2_deps $_py3_deps python2-dev python3-dev py2-setuptools py3-setuptools
 	py-enum34
 "
-subpackages="py2-hypothesis:_py py3-hypothesis:_py"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
 source="py-hypothesis-$pkgver.tar.gz::https://github.com/HypothesisWorks/hypothesis-python/archive/hypothesis-python-$pkgver.tar.gz"
 builddir="$srcdir/hypothesis-hypothesis-python-$pkgver/hypothesis-python"
+options="!check" # upstream tests are broken
+
+prepare() {
+	cp -r "$builddir" "$builddir"-py2
+}
 
 build() {
 	cd "$builddir"
-	python2 setup.py build
 	python3 setup.py build
+	cd "$builddir"-py2
+	python2 setup.py build
 }
 
 check() {
 	cd "$builddir"
-	python2 setup.py check
-	python3 setup.py check
+	python3 setup.py test
+	cd "$builddir"-py2
+	python2 setup.py test
 }
 
 package() {
+	mkdir -p "$pkgdir"
+}
+
+_py2() {
+	depends="$_py2_deps"
+	cd "$builddir"-py2
+	_py python2
+}
+
+_py3() {
+	depends="$_py3_deps"
 	cd "$builddir"
-	python2 setup.py install --prefix=/usr --root="$pkgdir"
-	python3 setup.py install --prefix=/usr --root="$pkgdir"
+	_py python3
 }
 
 _py() {
-	local py=${subpkgname%%-*}
-	local python="python${py#py}"
-	depends="$python"
-	case $py in
-		py2) depends="$depends py-enum34";;
-	esac
-	pkgdesc="$pkgdesc ($python)"
-	install_if="$pkgname=$pkgver-r$pkgrel $python"
-	mkdir -p "$subpkgdir"/usr/lib
-	mv "$pkgdir"/usr/lib/${python}* "$subpkgdir"/usr/lib/
+	_python="$1"
+	pkgdesc="$pkgdesc (for $_python)"
+	depends="$depends $_python"
+	install_if="$pkgname=$pkgver-r$pkgrel $_python"
+	$_python setup.py install --prefix=/usr --root="$subpkgdir"
 }
 
 sha512sums="56f0a796741b1a46bfe91e578dc76067b612d0041dd8b93043521c8e53827a5bcdd815f94e91d22d4ae9d13125bfb9012cb1c4660635e7cc93472141be504efb  py-hypothesis-4.14.3.tar.gz"
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 16:27:13 -0400

---
 testing/py-amqp/APKBUILD | 58 ++++++++++++++++++++++++++--------------
 1 file changed, 38 insertions(+), 20 deletions(-)

diff --git a/testing/py-amqp/APKBUILD b/testing/py-amqp/APKBUILD
index cdc46765bb..23c63b23e7 100644
--- a/testing/py-amqp/APKBUILD
+++ b/testing/py-amqp/APKBUILD
@@ -1,46 +1,64 @@
 # Maintainer: Drew DeVault <[email-masked]>
 pkgname=py-amqp
+_pyname=amqp
 pkgver=2.4.2
 pkgrel=0
 pkgdesc="an AMQP implementation"
 url="https://pypi.python.org/pypi/amqp/"
 arch="noarch"
 license="BSD"
-depends=""
-makedepends="python2-dev python3-dev py-setuptools"
-install=""
-subpackages="py2-amqp:py2 py3-amqp:py3"
-source="https://files.pythonhosted.org/packages/source/a/amqp/amqp-$pkgver.tar.gz"
-builddir="$srcdir/amqp-$pkgver"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+makedepends="python2 python3 py2-setuptools py3-setuptools"
+checkdepends="
+	py2-vine py3-vine py2-case py3-case py2-nose py3-nose py2-mock py3-mock
+	py2-unittest2
+"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir=$srcdir/$_pyname-$pkgver
+# requires a running rabbitmq sever, which is more complicated than it sounds
+options="!check"
+
+prepare() {
+	cd "$builddir"
+	sed -i requirements/test.txt -e 's/pytest-sugar.*//g'
+	cp -r "$builddir" "$builddir"-py2
+}
 
 build() {
 	cd "$builddir"
-	python2 setup.py build
 	python3 setup.py build
+	cd "$builddir"-py2
+	python2 setup.py build
 }
 
-package() {
-	mkdir -p "$pkgdir"
+check() {
+	cd "$builddir"
+	python3 setup.py test
+	cd "$builddir"-py2
+	python2 setup.py test
 }
 
-_py() {
-        local python="$1"
 
-py2() {
-	cd "$builddir"
+_py2() {
+	cd "$builddir"-py2
 	_py python2
 }
 
-py3() {
+_py3() {
 	cd "$builddir"
 	_py python3
+	}
+
+_py() {
+	_python="$1"
 
 sha512sums="dba880c07ee8b503e02f11ea5804f559ac2eb85717118d796558b1890032482babd15930af78f9d11b77530d496fce3ba8c8579eec71ce5a3f76b8d8a181af34  amqp-2.4.2.tar.gz"
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 16:27:12 -0400

---
 testing/py-amqp/APKBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/testing/py-amqp/APKBUILD b/testing/py-amqp/APKBUILD
index 01a38dd691..cdc46765bb 100644
--- a/testing/py-amqp/APKBUILD
+++ b/testing/py-amqp/APKBUILD
@@ -1,6 +1,6 @@
-# Maintainer: 
+# Maintainer: Drew DeVault <[email-masked]>
 pkgname=py-amqp
-pkgver=2.4.1
+pkgver=2.4.2
 pkgrel=0
 pkgdesc="an AMQP implementation"
 url="https://pypi.python.org/pypi/amqp/"
@@ -43,4 +43,4 @@ py3() {
 	_py python3
 }
 
-sha512sums="dba1c0eefea17ec3e354f23e8838bc2dcd33d39c0df30908889b52cd59e4a67f925b9003e47b437bb12c0495ec11ac92584addf98dfa4d0cb838e37d8d390be9  amqp-2.4.1.tar.gz"
+sha512sums="dba880c07ee8b503e02f11ea5804f559ac2eb85717118d796558b1890032482babd15930af78f9d11b77530d496fce3ba8c8579eec71ce5a3f76b8d8a181af34  amqp-2.4.2.tar.gz"
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 16:27:14 -0400

---
 testing/py-kombu/APKBUILD | 69 +++++++++++++++++++++++++--------------
 1 file changed, 45 insertions(+), 24 deletions(-)

diff --git a/testing/py-kombu/APKBUILD b/testing/py-kombu/APKBUILD
index 2903aee369..cbe661bb8d 100644
--- a/testing/py-kombu/APKBUILD
+++ b/testing/py-kombu/APKBUILD
@@ -1,47 +1,68 @@
 # Contributor: Stefan Wagner <[email-masked]>
-# Maintainer: 
+# Maintainer: Drew DeVault <[email-masked]>
 pkgname=py-kombu
-pkgver=4.2.1
+_pyname=kombu
+pkgver=4.5.0
 pkgrel=0
 pkgdesc="a message queue abstraction layer"
 url="https://pypi.python.org/pypi/kombu/"
 arch="noarch"
 license="BSD"
-depends="py-amqp"
-makedepends="python2-dev python3-dev py-setuptools"
-install=""
-subpackages="py2-kombu:py2 py3-kombu:py3"
-source="https://files.pythonhosted.org/packages/source/k/kombu/kombu-$pkgver.tar.gz"
-builddir="$srcdir/kombu-$pkgver"
+_py2_deps="py2-amqp py2-vine"
+_py3_deps="py3-amqp py3-vine"
+makedepends="
+	$_py2_deps $_py3_deps python2-dev python3-dev py2-setuptools py3-setuptools
+"
+checkdepends="
+	py2-pyro4 py3-pyro4 py2-case py3-case py2-nose py3-nose py2-mock py3-mock
+	py2-tz py3-tz pytest py3-pytest
+"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+prepare() {
+	cd "$builddir"
+	sed -i requirements/test.txt -e 's/pytest-sugar//g'
+	cp -r "$builddir" "$builddir"-py2
+}
 
 build() {
-	cd "$_builddir"
-	python2 setup.py build
+	cd "$builddir"
 	python3 setup.py build
+	cd "$builddir"-py2
+	python2 setup.py build
 }
 
-package() {
-	mkdir -p "$pkgdir"
+check() {
+	cd "$builddir"
+	python3 setup.py test
+	cd "$builddir"-py2
+	python2 setup.py test
 }
 
-_py() {
-        local python="$1"
 
-py2() {
-	cd "$builddir"
+_py2() {
+	depends="$_py2_deps"
+	cd "$builddir"-py2
 	_py python2
 }
 
-py3() {
+_py3() {
+	depends="$_py3_deps"
 	cd "$builddir"
 	_py python3
 }
 
-sha512sums="a480444199aeee4e0048803a49ee85f2b348734eccf0e746189ea7db3787cb27baa89765a71cf88288ec7171252d55e13bc787641a543d3f91d6eb3d30c6a90c  kombu-4.2.1.tar.gz"
+_py() {
+	_python="$1"
+	pkgdesc="$pkgdesc (for $_python)"
+	depends="$depends $_python"
+	install_if="$pkgname=$pkgver-r$pkgrel $_python"
+	$_python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+sha512sums="028ae2f65da52e3192791490cfc3d5298426c774891bac7b8b81f0d36f61be3c171b72f344c6c59be5820aca8c9c61b6f695ac3f5e181c1fd98a1d0e9fa7a9ae  kombu-4.5.0.tar.gz"
-- 
2.21.0

---

---

From: Drew DeVault <[email-masked]>
Date: Wed, 3 Apr 2019 16:27:15 -0400

---
 testing/celery/APKBUILD | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/testing/celery/APKBUILD b/testing/celery/APKBUILD
index bfe4320832..4b466084c2 100644
--- a/testing/celery/APKBUILD
+++ b/testing/celery/APKBUILD
@@ -1,12 +1,12 @@
-# Maintainer: 
+# Maintainer: Drew DeVault <[email-masked]>
 pkgname=celery
-pkgver=4.1.0
-pkgrel=4
+pkgver=4.3.0
+pkgrel=0
 pkgdesc="Official Python low-level client for Elasticsearch"
 url="http://www.celeryproject.org/"
 arch="noarch"
 license="Apache-2.0"
-depends="py-urllib3 py-redis py-vine py-kombu py-billiard"
+depends="py3-urllib3 py3-redis py3-vine py3-kombu py3-billiard"
 makedepends="python3-dev"
 install="$pkgname.pre-install"
 source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.tar.gz
@@ -14,6 +14,7 @@ source="https://files.pythonhosted.org/packages/source/${pkgname:0:1}/$pkgname/$
 	celery.initd"
 pkgusers="celery"
 pkggroups="celery"
+subpackages="$pkgname-openrc"
 builddir="$srcdir/"$pkgname-$pkgver
 provides="py3-celery"
 
@@ -45,6 +46,6 @@ check() {
 	python3 setup.py test
 }
 
-sha512sums="5232adc43ba55d01f2b030382075750033e0c5c2abdc8308903e0cef7a465513b7765e2ae495da6555b377452ae233500530ef9d57e584a5352a54c5f4731c64  celery-4.1.0.tar.gz
+sha512sums="91dd16bd6c9544c76d84e468872e052bdf5e1737980a1a3baee914c75c88db44b9ac8de7ddc4278988ca6cb159496b6560cecd6bb51d6352725009e97d268afb  celery-4.3.0.tar.gz
 f9458bce0d8990de646df564bec96baa0e45867f44e41380d38520905e00c941b1ce261314bb78edaa14c591e0aa9386d24c58a61f69fb0fecc616c34a24dea1  celery.confd
 ff8c0451efa7157fd61f2335f4187bef6cbdd51856c7cfad4de02244c6c5ca7c584f9108731b52f020fee866365d9f092ded266c90d13cb34e92a7ffb63fed57  celery.initd"
-- 
2.21.0

---

---

From: Leonardo <[email-masked]>
Date: Fri, 5 Apr 2019 13:58:01 +0200

Hi,

>    testing/celery: adopt; update to 4.3.0

this patch is broken and the commit message isn't relevant to the actual 
changes. Could you resend it?

Thanks!

/eo

---

---

From: Drew DeVault <[email-masked]>
Date: Fri, 5 Apr 2019 11:12:35 -0400

This 0/12 email is a cover letter which serves to introduce the patch
series - not a patch itself. These are generated with the
--cover-letter. It can just be git am --skip'd when applying the series.

---