Subject: Re: [alpine-aports] [PATCH 2/6] testing/libsigrok: New aport

From: Milan P. Stanić <[email-masked]>
Date: Thu, 30 May 2019 16:51:42 +0200

Hi,

On Wed, 2019-05-29 at 16:27, Marian Buschsieweke wrote:
> Hi,
> 
> I started the docker container with --privileged -v /dev/bus/usb:/dev/bus/usb
> to allow libusb to be initialized. With that I could successfully build the
> package in docker (including unit tests passing).
> 
> Can you please check again if it is still failing for you?

I tried check again and it failed. I'm attached test-suite.log
to this mail.

If the check need real machine or privileged container I'm not sure it
could be built on Alpine builders because they are LXC containers with
not much privileges.
In that case only option is to disable check with:
options="!check" #comment why check is not possible

-- 
Regards

> Kind regards,
> Marian
> 
> -------------------------------------------------------------
> M.Sc. Marian Buschsieweke
> Dept. Communication and Networked Systems (ComSys)
> Institute for Intelligent Cooperating Systems (IKS)
> Otto-von-Guericke-University of Magdeburg
> Universitätsplatz 2, Building 29, Room 314
> 39106 Magdeburg
> Germany
> 
> http://www.comsys.ovgu.de/Team/Marian+Buschsieweke.html
> Tel.: +49 - 391 - 67 - 52673
> Fax:  +49 - 391 - 67 - 41161
> 
> -------------------------------------------------------------
> 
> On Wed, 29 May 2019 16:22:22 +0200
> Marian Buschsieweke <[email-masked]> wrote:
> 
> > Hi,
> > 
> > thanks for your reply. Can you send me the test log, so that I can check the
> > issue?
> > 
> > I could not reproduces it on my native Alpine installation. But in a docker the
> > units tests fail for me as well, as libusb cannot be initialized within a
> > docker container. I'm trying to find a way to reproduce the issue on a clean
> > Alpine install.
> > 
> > Kind regards,
> > Marian
> > 
> > -------------------------------------------------------------
> > M.Sc. Marian Buschsieweke
> > Dept. Communication and Networked Systems (ComSys)
> > Institute for Intelligent Cooperating Systems (IKS)
> > Otto-von-Guericke-University of Magdeburg
> > Universitätsplatz 2, Building 29, Room 314
> > 39106 Magdeburg
> > Germany
> > 
> > http://www.comsys.ovgu.de/Team/Marian+Buschsieweke.html
> > Tel.: +49 - 391 - 67 - 52673
> > Fax:  +49 - 391 - 67 - 41161
> > 
> > -------------------------------------------------------------
> > 
> > On Mon, 27 May 2019 10:19:19 +0200
> > Milan P. Stanić <[email-masked]> wrote:
> > 
> > > Hi,
> > > 
> > > Did you received mail I sent on 2019-05-20, see below.
> > > 
> > > I sent it only to [email-masked] thinking you are
> > > subscribed, sorry.
> > > 
> > > On Mon, 2019-05-20 at 18:06, Milan P. Stanić wrote:  
> > > > Hi,
> > > > 
> > > > Package fails check() on x86_64.
> > > > ---
> > > > copying selected object files to avoid basename conflicts...
> > > > ar: `u' modifier ignored since `D' is the default (see `U')
> > > > make  tests/main
> > > >   CC       tests/lib.o
> > > >   CC       tests/main.o
> > > >   CC       tests/core.o
> > > >   CC       tests/input_all.o
> > > >   CC       tests/input_binary.o
> > > >   CC       tests/output_all.o
> > > >   CC       tests/transform_all.o
> > > >   CC       tests/session.o
> > > >   CC       tests/strutil.o
> > > >   CC       tests/version.o
> > > >   CC       tests/driver_all.o
> > > >   CC       tests/device.o
> > > >   CC       tests/trigger.o
> > > >   CC       tests/analog.o
> > > >   CCLD     tests/main
> > > > make  check-TESTS
> > > > FAIL: tests/main
> > > > ============================================================================
> > > > Testsuite summary for libsigrok 0.5.1
> > > > ============================================================================
> > > > # TOTAL: 1
> > > > # PASS:  0
> > > > # SKIP:  0
> > > > # XFAIL: 0
> > > > # FAIL:  1
> > > > # XPASS: 0
> > > > # ERROR: 0
> > > > ============================================================================
> > > > See ./test-suite.log
> > > > Please report to [email-masked]
> > > > ============================================================================
> > > > make[2]: *** [Makefile:3859: test-suite.log] Error 1
> > > > make[1]: *** [Makefile:3967: check-TESTS] Error 2
> > > > make: *** [Makefile:4183: check-am] Error 2    
> > > > >>> ERROR: libsigrok: check failed    
> > > > ---
> > > > 
> > > > On Thu, 2019-04-04 at 18:55, Marian Buschsieweke wrote:    
> > > > > A C library providing access to logic analyzers and related file formats
> > > > > https://sigrok.org/wiki/Libsigrok
> > > > > ---
> > > > >  testing/libsigrok/APKBUILD | 36 ++++++++++++++++++++++++++++++++++++
> > > > >  1 file changed, 36 insertions(+)
> > > > >  create mode 100644 testing/libsigrok/APKBUILD
> > > > > 
> > > > > diff --git a/testing/libsigrok/APKBUILD b/testing/libsigrok/APKBUILD
> > > > > new file mode 100644
> > > > > index 0000000000..ed97790047
> > > > > --- /dev/null
> > > > > +++ b/testing/libsigrok/APKBUILD
> > > > > @@ -0,0 +1,36 @@
> > > > > +# Maintainer: Marian Buschsieweke <[email-masked]>
> > > > > +
> > > > > +pkgname="libsigrok"
> > > > > +pkgver=0.5.1
> > > > > +pkgrel=0
> > > > > +pkgdesc="A C library providing access to logic analyzers and related file formats"
> > > > > +url="https://sigrok.org/wiki/Libsigrok"
> > > > > +makedepends="libzip-dev glib-dev libserialport-dev libusb-dev libftdi1-dev
> > > > > +             glibmm-dev check-dev"
> > > > > +depends=""
> > > > > +arch="all"
> > > > > +license="GPL-3.0-only"
> > > > > +source="http://sigrok.org/download/source/$pkgname/$pkgname-$pkgver.tar.gz"
> > > > > +subpackages="$pkgname-dev"
> > > > > +builddir="$srcdir/$pkgname-$pkgver"
> > > > > +
> > > > > +build() {
> > > > > +	cd "${builddir}"
> > > > > +	./configure --prefix=/usr/
> > > > > +	make
> > > > > +}
> > > > > +
> > > > > +check() {
> > > > > +	cd "${builddir}"
> > > > > +	make check
> > > > > +}
> > > > > +
> > > > > +package() {
> > > > > +	cd "${builddir}"
> > > > > +	make DESTDIR="$pkgdir" install
> > > > > +	mkdir -p "${pkgdir}/lib/udev/rules.d"
> > > > > +	cp contrib/60-libsigrok.rules "${pkgdir}/lib/udev/rules.d/60-libsigrok.rules"
> > > > > +	cp contrib/61-libsigrok-plugdev.rules "${pkgdir}/lib/udev/rules.d/60-libsigrok.rules"
> > > > > +}
> > > > > +
> > > > > +sha512sums="48337fc4625dc0abc162ae54e04ce091047835aa1e49ba1ab84542805008d1ff5646b143fde57e317f3b34514c0e6d4dcb7b1c5944f3f16bdef1a7169edc3517  libsigrok-0.5.1.tar.gz"
> > > > > -- 
> > > > > 2.21.0
> > > > > 
> > > > > 
> > > > > 
> > > > > ---
> > > > > Unsubscribe:  [email-masked]
> > > > > Help:         [email-masked]
> > > > > ---
> > > > >     
> > > > 
> > > > 
> > > > ---
> > > > Unsubscribe:  [email-masked]
> > > > Help:         [email-masked]
> > > > ---
> > > >     
> > 
> 

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Milan P. Stanić <[email-masked]>
Date: Thu, 30 May 2019 16:55:22 +0200

Hi,

sorry log slipt somehow. Hope this time it will be here.