Subject: [PATCH 1/8] testing/py-nbxmpp: Update 0.6.7 --> 0.6.10

From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 13:42:39 +0200

---
 testing/py-nbxmpp/APKBUILD | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/testing/py-nbxmpp/APKBUILD b/testing/py-nbxmpp/APKBUILD
index 81dd3b07a7..904b1fe4ae 100644
--- a/testing/py-nbxmpp/APKBUILD
+++ b/testing/py-nbxmpp/APKBUILD
@@ -1,8 +1,8 @@
 # Maintainer: Marian Buschsieweke <[email-masked]>
 pkgname=py-nbxmpp
 _pkgname="${pkgname#py-}"
-pkgver=0.6.7
-pkgrel=1
+pkgver=0.6.10
+pkgrel=0
 pkgdesc="A non-blocking XMPP implementation for python"
 url="https://dev.gajim.org/gajim/python-nbxmpp/"
 arch="noarch"
@@ -14,7 +14,6 @@ options="!check" # no test suite
 builddir="$srcdir"/$_pkgname-$pkgver
 
 build() {
-	cd "$builddir"
 	python2 setup.py build
 	python3 setup.py build
 }
@@ -41,4 +40,4 @@ _py() {
 	$python setup.py install --prefix=/usr --root="$subpkgdir"
 }
 
-sha512sums="95617cf3e947472515814c8acaaa7adf198732aada82e637467d1b92efb2a5d3d03335ba848c269ae73336c22f02ba3f8bc32b9afc726b0526b7028c13736981  nbxmpp-0.6.7.tar.gz"
+sha512sums="df586498ea66da4b6720753b25bd0222ee3360684e844d0d5bc2f364c2566243cc358976fe34b050e3358c3e584f880d8ac1c34e84eca34efaa18ab0c2f37eaf  nbxmpp-0.6.10.tar.gz"
-- 
2.22.0

---

From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 13:42:43 +0200

Python module for copy and paste clipboard functions
https://github.com/asweigart/pyperclip
---
 testing/py3-pyperclip/APKBUILD | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
 create mode 100644 testing/py3-pyperclip/APKBUILD

diff --git a/testing/py3-pyperclip/APKBUILD b/testing/py3-pyperclip/APKBUILD
new file mode 100644
index 0000000000..1d90d78f2b
--- /dev/null
+++ b/testing/py3-pyperclip/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Marian Buschsieweke <[email-masked]>
+# Maintainer: Marian Buschsieweke <[email-masked]>
+pkgname=py3-pyperclip
+_pkgname=pyperclip
+pkgver=1.7.0
+pkgrel=0
+pkgdesc="Python module for copy and paste clipboard functions"
+url="https://github.com/asweigart/pyperclip"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="python3-dev py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/${_pkgname/-/_}-$pkgver
+options="!check" # bug in tests prevents them from even starting :-/
+
+build() {
+	cd "$builddir"
+	python3 setup.py build
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+	cd "$builddir"
+	python3 setup.py test
+}
+sha512sums="7f22227ea894a236703f61ab950e198fab969fac5713ca8eac6df213183a47a244add88a462b9ddf63ed5bec36af5bc2578949f01ed31e0b63316d1761a935bd  py3-pyperclip-1.7.0.tar.gz"
-- 
2.22.0

---

From: Leo <[email-masked]>
Date: Sat, 13 Jul 2019 12:12:50 -0300

> +makedepends="python3-dev py-setuptools"

py3-setuptools instead of py-setuptools and python3-dev can be removed

> +	cd "$builddir"

Can be removed

> +	cd "$builddir"

Can be removed

---

From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 20:16:24 +0200

Hi,

the attached patch is fixed according to your comments. Thanks for the quick
review.

Kind regards,
Marian

On Sat, 13 Jul 2019 12:12:50 -0300

> py3-setuptools instead of py-setuptools and python3-dev can be removed

From 95b2f403b43543bbb2952591c06396f80f86ed5d Mon Sep 17 00:00:00 2001
From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 13:11:38 +0200
Subject: [PATCH 5/8] testing/py3-pyperclip: New aport

Python module for copy and paste clipboard functions
https://github.com/asweigart/pyperclip
---
 testing/py3-pyperclip/APKBUILD | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
 create mode 100644 testing/py3-pyperclip/APKBUILD

index 0000000000..493f117e8f
@@ -0,0 +1,27 @@
+makedepends="py3-setuptools"

---

From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 13:42:41 +0200

a tiny, document oriented database
https://github.com/msiemens/tinydb
---
 testing/py3-tinydb/APKBUILD | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100644 testing/py3-tinydb/APKBUILD

diff --git a/testing/py3-tinydb/APKBUILD b/testing/py3-tinydb/APKBUILD
new file mode 100644
index 0000000000..dc1f16ce2a
--- /dev/null
+++ b/testing/py3-tinydb/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Marian Buschsieweke <[email-masked]>
+# Maintainer: Marian Buschsieweke <[email-masked]>
+pkgname=py3-tinydb
+_pkgname=tinydb
+pkgver=3.13.0
+pkgrel=0
+pkgdesc="a tiny, document oriented database"
+url="https://github.com/msiemens/tinydb"
+arch="noarch"
+license="MIT"
+makedepends="python3-dev py-setuptools yaml-dev py3-pytest py3-pytest-cov"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/${_pkgname/-/_}-$pkgver
+
+build() {
+	cd "$builddir"
+	python3 setup.py build
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+	cd "$builddir"
+	python3 setup.py test
+}
+sha512sums="2fe92aa36c0e4541e87de005146615c2e80fc7fb94539ee3ba236a35b2a681545a30f8e88132408c2c3b4de65a0d316e40b93a102f76def2aa82519fa016a7b8  py3-tinydb-3.13.0.tar.gz"
-- 
2.22.0

---

From: Leo <[email-masked]>
Date: Sat, 13 Jul 2019 12:18:20 -0300

> +makedepends="python3-dev py-setuptools yaml-dev py3-pytest py3-pytest-cov"

Use py3-setuptools, python3-dev and yaml-dev can be replaced by py3-yaml and
be moved to checkdepends together with py3-pytest{,-cov}

Can be removed

Can be removed

---

From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 20:15:10 +0200

Hi,

Kind regards,
Marian

On Sat, 13 Jul 2019 12:18:20 -0300

> be moved to checkdepends together with py3-pytest{,-cov}

From 49a2c8bbc0e1c3d182ff7b2051a7932b7353ab30 Mon Sep 17 00:00:00 2001
From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 12:44:30 +0200
Subject: [PATCH 3/8] testing/py3-tinydb: New aport

a tiny, document oriented database
https://github.com/msiemens/tinydb
---
 testing/py3-tinydb/APKBUILD | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
 create mode 100644 testing/py3-tinydb/APKBUILD

index 0000000000..8b2acc04c7
@@ -0,0 +1,26 @@
+makedepends="py3-setuptools py3-yaml py3-pytest py3-pytest-cov"

---

From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 13:42:40 +0200

Internationalized Usernames and Passwords
https://github.com/byllyfish/precis_i18n
---
 testing/py3-precis-i18n/APKBUILD | 38 ++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)
 create mode 100644 testing/py3-precis-i18n/APKBUILD

diff --git a/testing/py3-precis-i18n/APKBUILD b/testing/py3-precis-i18n/APKBUILD
new file mode 100644
index 0000000000..cba48a67f9
--- /dev/null
+++ b/testing/py3-precis-i18n/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Marian Buschsieweke <[email-masked]>
+# Maintainer: Marian Buschsieweke <[email-masked]>
+pkgname=py3-precis-i18n
+_pkgname=precis-i18n
+pkgver=1.0
+pkgrel=0
+pkgdesc="Internationalized Usernames and Passwords"
+url="https://github.com/byllyfish/precis_i18n"
+arch="noarch"
+license="MIT"
+makedepends="python3-dev py-setuptools"
+source="
+	$_pkgname-$pkgver.tar.gz::https://github.com/byllyfish/precis_i18n/archive/v${pkgver}.tar.gz
+	$_pkgname-$pkgver-derived-props-11.0.txt::https://github.com/byllyfish/precis_i18n/raw/f68b66a80fa36ff1004f5a88696edb424a75dd76/test/derived-props-11.0.txt
+	"
+builddir="$srcdir"/${_pkgname/-/_}-$pkgver
+
+prepare() {
+	default_prepare
+	# Somehow one file required for the unit tests is not included in the release
+	cp "$srcdir"/$_pkgname-$pkgver-derived-props-11.0.txt "$builddir"/test/derived-props-11.0.txt
+}
+
+build() {
+	cd "$builddir"
+	python3 setup.py build
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+	cd "$builddir"
+	python3 setup.py test
+}
+sha512sums="b43622458fefb051e6f5ae6e347abfa65195052c63290b2be3ffb7c05eae0300caee53713d7216ee36c4ef0508cc4828e4d7ed3c65df873a684b803cc19bd410  precis-i18n-1.0.tar.gz
+df144b1790483055d9f6430c543892feed70402df6e0177daa94e005b5f9797f5885d7a5c1393a8a4555bcd0f7e85444f9e9f1152141b817f4e911bc2481e8bc  precis-i18n-1.0-derived-props-11.0.txt"
-- 
2.22.0

---

From: Leo <[email-masked]>
Date: Sat, 13 Jul 2019 12:14:02 -0300

> +makedepends="python3-dev py-setuptools"

python3-dev can be removed and use py3-setuptools instead of py-setuptools

> +	cd "$builddir"

can be removed

> +	cd "$builddir"

can be removed

---

From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 20:14:33 +0200

Hi,

Kind regards,
Marian

On Sat, 13 Jul 2019 12:14:02 -0300

> python3-dev can be removed and use py3-setuptools instead of py-setuptools

From 7a4b06ad8989c54fd7c22fc6d3431111fe28c831 Mon Sep 17 00:00:00 2001
From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 12:26:19 +0200
Subject: [PATCH 2/8] testing/py3-precis-i18n: New aport

Internationalized Usernames and Passwords
https://github.com/byllyfish/precis_i18n
---
 testing/py3-precis-i18n/APKBUILD | 36 ++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
 create mode 100644 testing/py3-precis-i18n/APKBUILD

index 0000000000..0f8d9838d5
@@ -0,0 +1,36 @@

---

From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 13:42:42 +0200

Independent BSON codec for Python that doesn’t depend on MongoDB
https://github.com/py-bson/bson
---
 testing/py3-bson/APKBUILD | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100644 testing/py3-bson/APKBUILD

diff --git a/testing/py3-bson/APKBUILD b/testing/py3-bson/APKBUILD
new file mode 100644
index 0000000000..3a72580a09
--- /dev/null
+++ b/testing/py3-bson/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Marian Buschsieweke <[email-masked]>
+# Maintainer: Marian Buschsieweke <[email-masked]>
+pkgname=py3-bson
+_pkgname=bson
+pkgver=0.5.8
+pkgrel=0
+pkgdesc="Independent BSON codec for Python that doesn’t depend on MongoDB"
+url="https://github.com/py-bson/bson"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="python3-dev py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/${_pkgname/-/_}-$pkgver
+
+build() {
+	cd "$builddir"
+	python3 setup.py build
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+check() {
+	cd "$builddir"
+	python3 setup.py test
+}
+sha512sums="a01762c80e9b11355b1679b3c5aad2e729b9a2e58eb061eb303c0bdae326968f4329ec0cfe1b928f288d011adf516c24600e2867cdec627777bf3648d7c1bad8  py3-bson-0.5.8.tar.gz"
-- 
2.22.0

---

From: Leo <[email-masked]>
Date: Sat, 13 Jul 2019 12:08:07 -0300

> +makedepends="python3-dev py-setuptools"

Since this is a py3- package the py-setuptools should be py3-setuptools

Since this py3- package is noarch the python3-dev is not required, it can be
removed entirely

Can be removed

Can be removed

---

From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 20:15:46 +0200

Hi,

Kind regards,
Marian

On Sat, 13 Jul 2019 12:08:07 -0300

> Since this py3- package is noarch the python3-dev is not required, it can be

From 70bec0b623aa555824107992f0ef0b0825c5832d Mon Sep 17 00:00:00 2001
From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 12:47:23 +0200
Subject: [PATCH 4/8] testing/py3-bson: New aport
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

 testing/py3-bson/APKBUILD | 26 ++++++++++++++++++++++++++

index 0000000000..246a82bad2

---

From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 13:42:45 +0200

---
 testing/gajim/APKBUILD                      | 15 ++++++++++-----
 testing/gajim/fix_dependency_spelling.patch | 12 ++++++++++++
 2 files changed, 22 insertions(+), 5 deletions(-)
 create mode 100644 testing/gajim/fix_dependency_spelling.patch

diff --git a/testing/gajim/APKBUILD b/testing/gajim/APKBUILD
index 2b1a7fa90f..2dc09351f2 100644
--- a/testing/gajim/APKBUILD
+++ b/testing/gajim/APKBUILD
@@ -1,16 +1,20 @@
 # Maintainer: Marian Buschsieweke <[email-masked]>
 pkgname=gajim
-pkgver=1.0.3
-pkgrel=1
+pkgver=1.1.3
+pkgrel=0
 pkgdesc="A full featured and easy to use XMPP client"
 url="https://gajim.org/"
 arch="noarch"
 license="GPL-3.0-only"
-depends="py3-cairo py3-gobject3 py3-asn1 py3-nbxmpp py3-openssl gtk+3.0"
+depends="py3-cairo py3-gobject3 py3-asn1 py3-nbxmpp py3-openssl py3-precis-i18n py3-keyring py3-cssutils gtk+3.0"
 makedepends="py-setuptools python3-dev gettext-dev"
 checkdepends="xvfb dbus"
-source="https://$pkgname.org/downloads/1.0/$pkgname-$pkgver.tar.bz2"
+source="
+	https://$pkgname.org/downloads/${pkgver:0:3}/$pkgname-$pkgver.tar.bz2
+	fix_dependency_spelling.patch
+	"
 builddir="$srcdir"/$pkgname-$pkgver
+subpackages="$pkgname-doc $pkgname-lang"
 
 build() {
         cd "$builddir"
@@ -36,5 +40,6 @@ package() {
         python3 setup.py install --prefix=/usr --root="$pkgdir"
 }
 
-sha512sums="a6d7f92a22a9dddc8a4b07eda0aae0b6fb4db57c73133ee19937f7e2a2a82c5351051d1f3627c94a44434276ed001b83d375f708f177962125af66cda8579ec8  gajim-1.0.3.tar.bz2"
 
+sha512sums="18062832f9b9295c7a844c347d5ece4a6db43126d5b58bbf362fdf2f8e082e2241c46dae6d1cbe66ebf2ef19f65618102c3c21fa0079a96fc21511e6e93420ac  gajim-1.1.3.tar.bz2
+08b4f81ad301a639494ceab33566b42194b33c4d0801df2078980053227c22eb16f8f00f43c17d5022db58739b380caade88dd8b69f5c5f1cf6be6a606ff2117  fix_dependency_spelling.patch"
diff --git a/testing/gajim/fix_dependency_spelling.patch b/testing/gajim/fix_dependency_spelling.patch
new file mode 100644
index 0000000000..7fd61a756b
--- /dev/null
+++ b/testing/gajim/fix_dependency_spelling.patch
@@ -0,0 +1,12 @@
+diff -rupN gajim-1.1.3-bak/setup.cfg gajim-1.1.3/setup.cfg
+--- gajim-1.1.3-bak/setup.cfg	2019-07-13 13:21:47.213443123 +0200
++++ gajim-1.1.3/setup.cfg	2019-07-13 13:21:59.913397194 +0200
+@@ -21,7 +21,7 @@ packages = find:
+ test_suite = test
+ install_requires = 
+ 	cssutils>=1.0.2
+-	keyring
++	pyKeyring
+ 	nbxmpp>=0.6.9,<0.7.0
+ 	precis-i18n>=1.0.0
+ 	pyOpenSSL>=0.12
-- 
2.22.0

---

From: Leo <[email-masked]>
Date: Sat, 13 Jul 2019 12:11:52 -0300

The commit title is wrong, please fix

<repo>/<package>: upgrade to <version>

> +depends="py3-cairo py3-gobject3 py3-asn1 py3-nbxmpp py3-openssl py3-precis-i18n py3-keyring py3-cssutils gtk+3.0"

Please cut this line at 80 columns

---

From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 20:18:16 +0200

Hi,

the attached patch is fixed according to your comments. Thanks for the quick
review. Also, I couldn't resist from making the indent consistently.

Kind regards,
Marian

On Sat, 13 Jul 2019 12:11:52 -0300

> Please cut this line at 80 columns

From db753ee2f8bc8ee23b1cbdfea9fff2b5b57bb6f8 Mon Sep 17 00:00:00 2001
From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 13:36:20 +0200
Subject: [PATCH 7/8] testing/gajim: upgrade to 1.1.3

---
 testing/gajim/APKBUILD                      | 28 +++++++++++++--------
 testing/gajim/fix_dependency_spelling.patch | 12 +++++++++
 2 files changed, 30 insertions(+), 10 deletions(-)
 create mode 100644 testing/gajim/fix_dependency_spelling.patch

index 2b1a7fa90f..a1ef7ec93e 100644
@@ -1,20 +1,27 @@
+depends="
+	py3-cairo py3-gobject3 py3-asn1 py3-nbxmpp py3-openssl
+	py3-precis-i18n py3-keyring py3-cssutils gtk+3.0
 
 build() {
-        cd "$builddir"
-        python3 setup.py build
+	cd "$builddir"
+	python3 setup.py build
 }
 
 check() {
@@ -28,13 +35,14 @@ check() {
 	else
 		kill $xvfb_pid
 		return 1
-        fi
+	fi
 }
 
 package() {
-        cd "$builddir"
-        python3 setup.py install --prefix=/usr --root="$pkgdir"
+	cd "$builddir"
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
 }

---

From: Leo <[email-masked]>
Date: Sat, 13 Jul 2019 12:19:43 -0300

Commit title tis wrong, should be:

<repository>/<package>: upgrade to <version>

---

From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 20:13:12 +0200

Hi,

thanks for the fast review. The attached patch is fixed accordingly.

Kind regards,
Marian

On Sat, 13 Jul 2019 12:19:43 -0300

> <repository>/<package>: upgrade to <version>

From e92c31b23ece90c5f0b80bfb594a8fea3929645d Mon Sep 17 00:00:00 2001
From: Marian Buschsieweke <[email-masked]>
Date: Sat, 13 Jul 2019 12:27:55 +0200
Subject: [PATCH 1/8] testing/py-nbxmpp: upgrade to 0.6.10

---

 build() {
-	cd "$builddir"
 	python2 setup.py build
 	python3 setup.py build
 }