Subject: [PATCH] testing/grafana: upgrade to 6.5.0

From: Drew DeVault <[email-masked]>
Date: Wed, 27 Nov 2019 17:54:58 -0500

---
I would like to state for the record that grafana is a terrible piece of
software.

 testing/grafana/APKBUILD | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/testing/grafana/APKBUILD b/testing/grafana/APKBUILD
index df42e524eb..abfa4dac21 100644
--- a/testing/grafana/APKBUILD
+++ b/testing/grafana/APKBUILD
@@ -1,10 +1,10 @@
 # Contributor: Konstantin Kulikov <[email-masked]>
 # Maintainer: Konstantin Kulikov <[email-masked]>
 pkgname=grafana
-pkgver=6.4.4
+pkgver=6.5.0
 pkgrel=0
-_commit=092e51408a # git rev-parse --short HEAD
-_stamp=1573041873 # git --no-pager show -s --format=%ct
+_commit=24a5d2fe8b # git rev-parse --short HEAD
+_stamp=1574679696 # git --no-pager show -s --format=%ct
 pkgdesc="Open source, feature rich metrics dashboard and graph editor"
 url="https://grafana.com"
 arch="x86_64" # Builds are slow on arm archs, x86 requires python2.
@@ -16,6 +16,7 @@ subpackages="$pkgname-openrc"
 source="$pkgname-$pkgver.tar.gz::https://github.com/grafana/grafana/archive/v$pkgver.tar.gz
 	go.mod go.sum apk.go $pkgname.initd $pkgname.confd"
 builddir=$srcdir
+options="!check" # Upstream will be given tests when they learn how to use them responsibly
 
 export GOPATH=${GOPATH:-$srcdir/go}
 export GOCACHE=${GOCACHE:-$srcdir/go-build}
@@ -58,7 +59,7 @@ package() {
 	cp -r "$builddir/$pkgname-$pkgver/conf" "$builddir/$pkgname-$pkgver/public" "$pkgdir/usr/share/$pkgname/"
 }
 
-sha512sums="5499b0491bbdcc056b576f0e680798a8f9aeea3e3538d45d1cfe68bdc283579939e35ec3b8f921333c655c90b985e82a74635e9dcc356ced354b3305ce4efa79  grafana-6.4.4.tar.gz
+sha512sums="ba13149485f6b4a4d1de9740a33d46377c694e321d2a5d26bcbf452cad3a91cda54e9979a9aa112318918ae7c011ce1b47cb797bd01e481c506a9a81d1299f5e  grafana-6.5.0.tar.gz
 ee3e915c75aad9b80218f98c47eef418a5655a7dd4d7b3f6b1923aaca13a065b0f5b04ad92922d365ce84d1e0b2c700a434c315a18a363c25b8c23959892a449  go.mod
 10caa000cba330bb9e223c3072b492b2c88152f21f49a857ce498f5306a504c9fe6eaa271e971b004fa0adf937cf5e4c584f56dce9318b2aeab36c550396fb0a  go.sum
 8fff794134b497c1d272ac69972bb468849007cb32b9255d792b74a58aea7be739d3db348da686a26fb092244c614a300dfffafb74c58a34a7c7505138158b19  apk.go
-- 
2.24.0

---

From: Konstantin Kulikov <[email-masked]>
Date: Thu, 28 Nov 2019 13:29:43 +0300

1. Grafana ships significant bugs with every minor release, always
wait for patch release before updating (6.5.1 was coincidentally
released a few minutes ago)
2. you have to run go get
github.com/grafana/grafana/pkg/cmd/grafana-server@COMMITHASH && go mod
tidy because I packaged it that way. I think it is fine to revert it
to simpler go build -mod=vendor for now because x/errors update no
longer needed, they have wrong go.mod file and they vendor their deps
anyway, but in the long run I'd like every go binary to have proper
version information recorded in them (queryable with go version -m
/path/to/binary or via https://godoc.org/runtime/debug#ReadBuildInfo)

>Upstream will be given tests when they learn how to use them responsibly

Can you explain better? Even unit tests are useful as they test
assumptions made by devs about target system and grafanas tests worked
well enough for me before.