Subject: [PATCH] community/gst-plugins-bad: enable SCTP stack

From: Daniel Santana <[email-masked]>
Date: Wed, 29 Jan 2020 14:07:43 -0300

This is required by the webrtcbin element to use data channels.
---
 community/gst-plugins-bad/APKBUILD | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/community/gst-plugins-bad/APKBUILD b/community/gst-plugins-bad/APKBUILD
index b1576aa63a..509ff4246d 100644
--- a/community/gst-plugins-bad/APKBUILD
+++ b/community/gst-plugins-bad/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=gst-plugins-bad
 pkgver=1.16.2
-pkgrel=3
+pkgrel=4
 pkgdesc="GStreamer streaming media framework bad plug-ins"
 url="https://gstreamer.freedesktop.org"
 arch="all"
@@ -14,7 +14,7 @@ makedepends="alsa-lib-dev bluez-dev bzip2-dev curl-dev directfb-dev faac-dev
 	libmodplug-dev libsrtp-dev libvdpau-dev libwebp-dev libnice-dev
 	libx11-dev mesa-dev meson neon-dev openssl-dev opus-dev orc-compiler
 	orc-dev spandsp-dev tiff-dev x265-dev vulkan-loader-dev vulkan-headers
-	wayland-dev wayland-protocols gobject-introspection-dev"
+	wayland-dev wayland-protocols gobject-introspection-dev libusrsctp-dev"
 
 case "$CARCH" in
 	s390x) ;;
@@ -36,6 +36,7 @@ build() {
 		-Dpackage-name="GStreamer bad plug-ins (Alpine Linux)" \
 		-Dintrospection=enabled \
 		-Dvulkan=enabled \
+		-Dsctp=enabled \
 		. output
 	ninja -C output
 }
-- 
2.25.0

---

From: Leo <[email-masked]>
Date: Thu, 30 Jan 2020 00:28:10 +0100

On Wed, 29 Jan 2020 14:07:43 -0300
Daniel Santana <[email-masked]> wrote:

> diff --git a/community/gst-plugins-bad/APKBUILD
> b/community/gst-plugins-bad/APKBUILD index b1576aa63a..509ff4246d
> 100644 --- a/community/gst-plugins-bad/APKBUILD
> @@ -14,7 +14,7 @@ makedepends="alsa-lib-dev bluez-dev bzip2-dev
> curl-dev directfb-dev faac-dev libmodplug-dev libsrtp-dev
> libvdpau-dev libwebp-dev libnice-dev libx11-dev mesa-dev meson
> neon-dev openssl-dev opus-dev orc-compiler orc-dev spandsp-dev
> tiff-dev x265-dev vulkan-loader-dev vulkan-headers
>  		-Dpackage-name="GStreamer bad plug-ins (Alpine
> Linux)" \ -Dintrospection=enabled \
>  		-Dvulkan=enabled \
> +		-Dsctp=enabled \
>  		. output
>  	ninja -C output
>  }

gst-plugins-bad is in community/ while libusrsctp is in testing/.

Please move libusrsctp to testing.

---

From: Daniel Santana <[email-masked]>
Date: Wed, 29 Jan 2020 22:27:54 -0300

case "$CARCH" in
 	s390x) ;;

---

From: Daniel Santana <[email-masked]>
Date: Wed, 29 Jan 2020 22:27:55 -0300

---
 {testing => community}/e2tools/APKBUILD  | 0
 {testing => community}/e2tools/e2cp.1    | 0
 {testing => community}/e2tools/e2ln.1    | 0
 {testing => community}/e2tools/e2ls.1    | 0
 {testing => community}/e2tools/e2mkdir.1 | 0
 {testing => community}/e2tools/e2mv.1    | 0
 {testing => community}/e2tools/e2rm.1    | 0
 {testing => community}/e2tools/e2tail.1  | 0
 {testing => community}/e2tools/e2tools.7 | 0
 9 files changed, 0 insertions(+), 0 deletions(-)
 rename {testing => community}/e2tools/APKBUILD (100%)
 rename {testing => community}/e2tools/e2cp.1 (100%)
 rename {testing => community}/e2tools/e2ln.1 (100%)
 rename {testing => community}/e2tools/e2ls.1 (100%)
 rename {testing => community}/e2tools/e2mkdir.1 (100%)
 rename {testing => community}/e2tools/e2mv.1 (100%)
 rename {testing => community}/e2tools/e2rm.1 (100%)
 rename {testing => community}/e2tools/e2tail.1 (100%)
 rename {testing => community}/e2tools/e2tools.7 (100%)

diff --git a/testing/e2tools/APKBUILD b/community/e2tools/APKBUILD
similarity index 100%
rename from testing/e2tools/APKBUILD
rename to community/e2tools/APKBUILD
diff --git a/testing/e2tools/e2cp.1 b/community/e2tools/e2cp.1
similarity index 100%
rename from testing/e2tools/e2cp.1
rename to community/e2tools/e2cp.1
diff --git a/testing/e2tools/e2ln.1 b/community/e2tools/e2ln.1
similarity index 100%
rename from testing/e2tools/e2ln.1
rename to community/e2tools/e2ln.1
diff --git a/testing/e2tools/e2ls.1 b/community/e2tools/e2ls.1
similarity index 100%
rename from testing/e2tools/e2ls.1
rename to community/e2tools/e2ls.1
diff --git a/testing/e2tools/e2mkdir.1 b/community/e2tools/e2mkdir.1
similarity index 100%
rename from testing/e2tools/e2mkdir.1
rename to community/e2tools/e2mkdir.1
diff --git a/testing/e2tools/e2mv.1 b/community/e2tools/e2mv.1
similarity index 100%
rename from testing/e2tools/e2mv.1
rename to community/e2tools/e2mv.1
diff --git a/testing/e2tools/e2rm.1 b/community/e2tools/e2rm.1
similarity index 100%
rename from testing/e2tools/e2rm.1
rename to community/e2tools/e2rm.1
diff --git a/testing/e2tools/e2tail.1 b/community/e2tools/e2tail.1
similarity index 100%
rename from testing/e2tools/e2tail.1
rename to community/e2tools/e2tail.1
diff --git a/testing/e2tools/e2tools.7 b/community/e2tools/e2tools.7
similarity index 100%
rename from testing/e2tools/e2tools.7
rename to community/e2tools/e2tools.7
-- 
2.25.0